Bug 4080 - HP LaserJet 1018 not print after restart or system reboot
: HP LaserJet 1018 not print after restart or system reboot
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: LXDE Edition
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: Aleksandr Kazantcev
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-06-06 00:34 MSD by Eugene Budanov
Modified: 2015-01-22 18:13 MSK (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Budanov 2014-06-06 00:34:28 MSD
I have HP LJ 1018 connected via USB cable. After installation of hplip driver and setup printer, I can print test page successfully. But if I reboot system or power off and power on printer again printer not work. 

HP driver detect printer, I can see toner level or connection status, but can't print until I download firmware from HP site again. 

[tasula@laptop ~]$ lsusb 
Bus 002 Device 002: ID 046d:c016 Logitech, Inc. Optical Wheel Mouse 
Bus 004 Device 002: ID 0b05:1712 ASUSTek Computer, Inc. BT-183 Bluetooth 2.0+EDR adapter 
Bus 005 Device 006: ID 03f0:4117 Hewlett-Packard LaserJet 1018 
Bus 005 Device 004: ID 04f2:b071 Chicony Electronics Co., Ltd 2.0M UVC Webcam / CNF7129 
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub 
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub 
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub 
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub 
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub 

[tasula@laptop ~]$ rpm -qa | grep hplip 
hplip-hpijs-3.13.11-25-rosa2012.1.i586 
hplip-hpijs-ppds-3.13.11-25-rosa2012.1.i586 
hplip-model-data-3.13.11-25-rosa2012.1.i586 
hplip-3.13.11-25-rosa2012.1.i586 
hplip-gui-3.13.11-25-rosa2012.1.i586
Comment 1 Eugene Budanov 2014-07-14 15:09:11 MSD
Quick look on last weekend shows, that alternative opensource driver foo2zjs in our repos not workring. Because it's conflicts with usblp which we use for printing sybsystem by default.
Comment 2 FirstLevel 2014-10-08 22:34:56 MSD
Please could You check the problem for new release 2014.1
Comment 3 Eugene Budanov 2014-10-12 13:53:26 MSD
This is problem in HPLIP. I found a workaround for this: http://forum.rosalab.ru/viewtopic.php?f=36&t=2805&p=31666&hilit=1018#p31580
Comment 4 Vladimir Potapov 2014-10-12 16:09:30 MSD
Do fix in package?