Bug 4076 - [UPDATE REQUEST] grub2-2.00-47
: [UPDATE REQUEST] grub2-2.00-47
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-06-03 21:49 MSD by Konstantin Vlasov
Modified: 2014-06-09 19:08 MSD (History)
0 users

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
konstantin.vlasov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin Vlasov 2014-06-03 21:49:27 MSD
A bug was fixed: when installing Grub2 on EFI system with an existing Windows, the generated grub2.cfg might contain an invalid entry for Windows which would fail to boot. The problem is reproduced when path to the EFI loader file (returned by `efibootmgr -v') was in uppercase, such as:
\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI
instead of
\EFI\Microsoft\Boot\Bootmgfw.efi
Comment 1 Konstantin Vlasov 2014-06-03 21:50:30 MSD
https://abf.rosalinux.ru/build_lists/1902339
https://abf.rosalinux.ru/build_lists/1902340

Advisory: Fixed invalid Windows boot entry generation when path to the EFI file was in upper case.