Bug 4057 - Can't boot right after fresh installation
: Can't boot right after fresh installation
Status: RESOLVED WORKSFORME
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: i586 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-05-26 11:54 MSD by Evgeniy
Modified: 2016-01-28 17:32 MSK (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Evgeniy 2014-05-26 11:54:03 MSD
Description of problem:

I can not boot after fresh installation.

When booting, I see infinite loop of ROSA logo.

I pressed ESC and saw the text mode, but couldn't use it.

In Grub2 I added "failsafe" to the string, booted. Linux asked me for root password or press "Control-D" to go on. I couldn't type anything, it asked me for password in infinite loop.

Fortunately, I took a picture of the screen with my phone.

Here are the errors:

[FAILED] Failed to start Load legacy module configuration
See 'systemctl status fedora-loadmodules.service' for details
<....>
[FAILED] Failed to mount /windows
//(/windows should be mounted as ntfs-3g with defaults parameters)
[DEPEND] Dependency failed for Local File Systems
[DEPEND] Dependency failed for Setup links in /boot for running kernel.
[DEPEND] Dependency failed for Relabel all filesystems, if necessary.
[DEPEND] Dependency failed for Mark the need to relabel after reboot.

CPU: Athlon 64 X2 4800+
RAM: 3 Gb
Motherboard: ASRock 939A790GMH
Graphics: ATI RS780D

$ cat /etc/*ease
LSB_VERSION=
DISTRIB_ID=RosaDesktop.Fresh
DISTRIB_RELEASE=2012.1
DISTRIB_CODENAME=belka
DISTRIB_DESCRIPTION="ROSA Desktop.Fresh 2012.1"
ROSA Desktop Fresh R3 release 2012.1 for i586
ROSA Desktop Fresh R3 release 2012.1 for i586
ROSA Desktop Fresh R3 release 2012.1 for i586
NAME="ROSA Desktop Fresh"
VERSION="Free 2012.1 Desktop"
ID=rosa
VERSION_ID=2012.1
PRETTY_NAME="ROSA Desktop Fresh Free 2012.1 Desktop"
ANSI_COLOR="1;43"
CPE_NAME="cpe:/o:rosa:rosalinux:2012.1"
HOME_URL="http://www.rosalinux.com/"
BUG_REPORT_URL="https://bugs.rosalinux.com/"
ROSA Desktop Fresh R3 release 2012.1 for i586
ROSA Desktop Fresh R3 release 2012.1 for i586
ROSA Desktop Fresh R3 release 2012.1 for i586
ROSA Desktop Fresh R3 release 2012.1 for i586
Comment 1 Alexander Burmashev 2014-05-26 12:00:10 MSD
Try booting in single user mode and removing external ( and not accessible at boot time ) entries from /etc/fstab
Comment 2 Evgeniy 2014-05-26 12:04:14 MSD
(In reply to comment #1)
> Try booting in single user mode and removing external ( and not accessible
> at boot time ) entries from /etc/fstab

Please, provide me with the information how to do that in ROSA Desktop.
Comment 3 Alexander Burmashev 2014-05-26 12:12:11 MSD
in grub2 press E to enter edit mode, add single to boot options and press F10.
You should be booted to root prompt with filesystem access.
Comment 4 Evgeniy 2014-05-26 13:09:12 MSD
I fixed fstab with the use of single mode (wrong ntfs-3g parameters, I don't know exactly if it were the parameters by default or I changed them after installation).
Comment 5 Konstantin Vlasov 2014-05-26 13:55:49 MSD
(In reply to comment #4)
> I fixed fstab with the use of single mode (wrong ntfs-3g parameters, I don't
> know exactly if it were the parameters by default or I changed them after
> installation).

Could you please specify which parameters were used before you fixed them (the wrong ones), and which ones you specified yourself? I'll try to check the installer, whether it is its problem or not.
Comment 6 Evgeniy 2014-05-26 14:00:28 MSD
before: defaults 1 2
fixed: rw,nosuid,nodev,allow_other 0 0

I have another problem that bothering me =)))). The installation again doesn't boot. Single mode doesn't help at all. I think the problem is in Radeon drivers. If I'm able to get additional information, I'll post a bugreport.
Comment 7 Konstantin Vlasov 2014-05-26 16:49:01 MSD
(In reply to comment #6)
> before: defaults 1 2
> fixed: rw,nosuid,nodev,allow_other 0 0

Thanks. Unfortunately, I don't see why it could cause any problem, sorry. I tested in a virtual machine and in my case the parameters were "default 0 0", system booted successfully (and mounted the partition with "rw,nosuid,nodev,relatime,user_id=0,group_id=0,allow_other,blksize=4096"). These numbers should not affect mounting, but just in case I also tested with "defaults 1 2", still no problems. Probably, it was some local temporary problem...
Comment 8 Denis Silakov 2016-01-28 17:32:16 MSK
Not sure if we can get more useful info from this particular bug. We have a more general bug 302 concerning boot failures in case of wrong fstab records.