Bug 4053 - Can not launch Gpodder
: Can not launch Gpodder
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: Fresh
: x86_64 Linux
: Normal normal
: ---
Assigned To: Stanislav Fomin
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-05-24 01:23 MSD by dr_2013
Modified: 2015-04-21 00:01 MSD (History)
3 users (show)

See Also:
RPM Package: gpodder-3.2.0-1-rosa2012.1.noarch
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dr_2013 2014-05-24 01:23:59 MSD
Description of problem:
I'm unable to  start Gpodder. This is program output:
** (process:8440): WARNING **: Trying to register gtype 'GMountMountFlags' as enum when in fact it is of type 'GFlags'

** (process:8440): WARNING **: Trying to register gtype 'GDriveStartFlags' as enum when in fact it is of type 'GFlags'

** (process:8440): WARNING **: Trying to register gtype 'GSocketMsgFlags' as enum when in fact it is of type 'GFlags'
1400879785.746062 [gpodder.sync] WARNING: Could not find eyeD3
1400879786.506493 [gpodder.log] ERROR: Uncaught exception: Traceback (most recent call last):
  File "/usr/bin/gpodder", line 175, in <module>
    main()
  File "/usr/bin/gpodder", line 170, in main
    main.main(options)
  File "/usr/lib/python2.7/site-packages/gpodder/gtkui/main.py", line 3535, in main
    gp = gPodder(bus_name, core.Core(UIConfig, model_class=Model))
  File "/usr/lib/python2.7/site-packages/gpodder/gtkui/main.py", line 120, in __init__
    BuilderWidget.__init__(self, None)
  File "/usr/lib/python2.7/site-packages/gpodder/gtkui/interface/common.py", line 38, in __init__
    GtkBuilderWidget.__init__(self, gpodder.ui_folders, gpodder.textdomain, **kwargs)
  File "/usr/lib/python2.7/site-packages/gpodder/gtkui/base.py", line 66, in __init__
    self.new()
  File "/usr/lib/python2.7/site-packages/gpodder/gtkui/main.py", line 210, in new
    self.channels = self.model.get_podcasts()
  File "/usr/lib/python2.7/site-packages/gpodder/model.py", line 1393, in get_podcasts
    self.children = self.db.load_podcasts(podcast_factory)
  File "/usr/lib/python2.7/site-packages/gpodder/dbsqlite.py", line 156, in load_podcasts
    cur = self.cursor()
  File "/usr/lib/python2.7/site-packages/gpodder/dbsqlite.py", line 100, in cursor
    return self.db.cursor()
  File "/usr/lib/python2.7/site-packages/gpodder/dbsqlite.py", line 94, in db
    schema.upgrade(self._db, self.database_file)
  File "/usr/lib/python2.7/site-packages/gpodder/schema.py", line 185, in upgrade
    assert version == CURRENT_VERSION
AssertionError

Traceback (most recent call last):
  File "/usr/bin/gpodder", line 175, in <module>
    main()
  File "/usr/bin/gpodder", line 170, in main
    main.main(options)
  File "/usr/lib/python2.7/site-packages/gpodder/gtkui/main.py", line 3535, in main
    gp = gPodder(bus_name, core.Core(UIConfig, model_class=Model))
  File "/usr/lib/python2.7/site-packages/gpodder/gtkui/main.py", line 120, in __init__
    BuilderWidget.__init__(self, None)
  File "/usr/lib/python2.7/site-packages/gpodder/gtkui/interface/common.py", line 38, in __init__
    GtkBuilderWidget.__init__(self, gpodder.ui_folders, gpodder.textdomain, **kwargs)
  File "/usr/lib/python2.7/site-packages/gpodder/gtkui/base.py", line 66, in __init__
    self.new()
  File "/usr/lib/python2.7/site-packages/gpodder/gtkui/main.py", line 210, in new
    self.channels = self.model.get_podcasts()
  File "/usr/lib/python2.7/site-packages/gpodder/model.py", line 1393, in get_podcasts
    self.children = self.db.load_podcasts(podcast_factory)
  File "/usr/lib/python2.7/site-packages/gpodder/dbsqlite.py", line 156, in load_podcasts
    cur = self.cursor()
  File "/usr/lib/python2.7/site-packages/gpodder/dbsqlite.py", line 100, in cursor
    return self.db.cursor()
  File "/usr/lib/python2.7/site-packages/gpodder/dbsqlite.py", line 94, in db
    schema.upgrade(self._db, self.database_file)
  File "/usr/lib/python2.7/site-packages/gpodder/schema.py", line 185, in upgrade
    assert version == CURRENT_VERSION
AssertionError



Version-Release number of selected component (if applicable):
Version: 3.2.0-1-rosa2012.1

How reproducible:


Steps to Reproduce:
1. Install Gpodder (urpmi gpodder)
2. Launch Gpodder (execute gpodder command).
Comment 1 FirstLevel 2014-05-26 09:05:29 MSD
Please could Ypu add some more information.
Please give me the output of such commands:
uname -a
cat /etc/release
rpm -qa | grep gpodder
lspcidrake
Could You create new test user and check the problem with new user account?
Comment 2 dr_2013 2014-05-26 11:55:43 MSD
uname -a:
3.10.34-nrj-desktop-3rosa #1 SMP PREEMPT Fri Apr 18 20:11:49 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

cat /etc/release:
ROSA Desktop Fresh R3 release 2012.1 for x86_64

rpm -qa | grep gpodder:
gpodder-3.2.0-1-rosa2012.1.noarch

lspcidrake:
atl1c           : Qualcomm Atheros|AR8131 Gigabit Ethernet [NETWORK_ETHERNET] (rev: c0)
Card:NVIDIA GeForce 8 series and later (nouveau/nvidia-current): NVIDIA Corporation|G94 [GeForce 9600 GT] [DISPLAY_VGA] (rev: a1)
i2c_i801        : Intel Corporation|NM10/ICH7 Family SMBus Controller [SERIAL_SMBUS] (rev: 01)
ata_piix        : Intel Corporation|NM10/ICH7 Family SATA Controller [IDE mode] [STORAGE_IDE] (rev: 01)
piix            : Intel Corporation|82801G (ICH7 Family) IDE Controller [STORAGE_IDE] (rev: 01)
leds_ss4200     : Intel Corporation|82801GB/GR (ICH7 Family) LPC Interface Bridge [BRIDGE_ISA] (rev: 01)
unknown         : Intel Corporation|82801 PCI Bridge [BRIDGE_PCI] (rev: e1)
ehci_pci        : Intel Corporation|NM10/ICH7 Family USB2 EHCI Controller [SERIAL_USB] (rev: 01)
uhci_hcd        : Intel Corporation|NM10/ICH7 Family USB UHCI Controller #4 [SERIAL_USB] (rev: 01)
uhci_hcd        : Intel Corporation|NM10/ICH7 Family USB UHCI Controller #3 [SERIAL_USB] (rev: 01)
uhci_hcd        : Intel Corporation|NM10/ICH7 Family USB UHCI Controller #2 [SERIAL_USB] (rev: 01)
uhci_hcd        : Intel Corporation|NM10/ICH7 Family USB UHCI Controller #1 [SERIAL_USB] (rev: 01)
shpchp          : Intel Corporation|NM10/ICH7 Family PCI Express Port 2 [BRIDGE_PCI] (rev: 01)
shpchp          : Intel Corporation|NM10/ICH7 Family PCI Express Port 1 [BRIDGE_PCI] (rev: 01)
snd_hda_intel   : Intel Corporation|NM10/ICH7 Family High Definition Audio Controller [MULTIMEDIA_AUDIO_DEV] (rev: 01)
shpchp          : Intel Corporation|82G33/G31/P35/P31 Express PCI Express Root Port [BRIDGE_PCI] (rev: 10)
unknown         : Intel Corporation|82G33/G31/P35/P31 Express DRAM Controller [BRIDGE_HOST] (rev: 10)
hid_generic     :   USB Keyboard
hid_generic     :   USB Keyboard
hid_a4tech      : A4Tech USB Mouse
Comment 3 dr_2013 2014-05-26 11:58:01 MSD
(In reply to comment #1)
> Please could Ypu add some more information.
> Please give me the output of such commands:
> uname -a
> cat /etc/release
> rpm -qa | grep gpodder
> lspcidrake
> Could You create new test user and check the problem with new user account?

Under new user all is fine.
Comment 4 FirstLevel 2014-05-26 13:08:49 MSD
(In reply to comment #3)
> (In reply to comment #1)
> > Please could Ypu add some more information.
> > Please give me the output of such commands:
> > uname -a
> > cat /etc/release
> > rpm -qa | grep gpodder
> > lspcidrake
> > Could You create new test user and check the problem with new user account?
> 
> Under new user all is fine.

Do You have newly installed R3 or this system is any previous release (R1 or R2) and You update it?
Comment 5 dr_2013 2014-05-27 11:12:27 MSD
(In reply to comment #4)
> (In reply to comment #3)
> > (In reply to comment #1)
> > > Please could Ypu add some more information.
> > > Please give me the output of such commands:
> > > uname -a
> > > cat /etc/release
> > > rpm -qa | grep gpodder
> > > lspcidrake
> > > Could You create new test user and check the problem with new user account?
> > 
> > Under new user all is fine.
> 
> Do You have newly installed R3 or this system is any previous release (R1 or
> R2) and You update it?

I was using Crunchbang previously.
Comment 6 FirstLevel 2014-05-27 14:58:13 MSD
(In reply to comment #5)
> (In reply to comment #4)
> > (In reply to comment #3)
> > > (In reply to comment #1)
> > > > Please could Ypu add some more information.
> > > > Please give me the output of such commands:
> > > > uname -a
> > > > cat /etc/release
> > > > rpm -qa | grep gpodder
> > > > lspcidrake
> > > > Could You create new test user and check the problem with new user account?
> > > 
> > > Under new user all is fine.
> > 
> > Do You have newly installed R3 or this system is any previous release (R1 or
> > R2) and You update it?
> 
> I was using Crunchbang previously.
I mean another thing. Is You installation is clean installation of R3 or it is upgrade from R2?
Comment 7 Denis Silakov 2014-05-27 15:02:51 MSD
... or did you reuse /home from Crunchbang? If yes, then it is likely that gpodder ran into a conflict with old user settings.
Comment 8 FirstLevel 2014-05-27 15:05:15 MSD
(In reply to comment #5)
> (In reply to comment #4)
> > (In reply to comment #3)
> > > (In reply to comment #1)
> > > > Please could Ypu add some more information.
> > > > Please give me the output of such commands:
> > > > uname -a
> > > > cat /etc/release
> > > > rpm -qa | grep gpodder
> > > > lspcidrake
> > > > Could You create new test user and check the problem with new user account?
> > > 
> > > Under new user all is fine.
> > 
> > Do You have newly installed R3 or this system is any previous release (R1 or
> > R2) and You update it?
> 
> I was using Crunchbang previously.

Also please could You provide output of command
ls -al ~
from problem user.
Comment 9 dr_2013 2014-06-01 23:23:25 MSD
(In reply to comment #8)
> (In reply to comment #5)
> > (In reply to comment #4)
> > > (In reply to comment #3)
> > > > (In reply to comment #1)
> > > > > Please could Ypu add some more information.
> > > > > Please give me the output of such commands:
> > > > > uname -a
> > > > > cat /etc/release
> > > > > rpm -qa | grep gpodder
> > > > > lspcidrake
> > > > > Could You create new test user and check the problem with new user account?
> > > > 
> > > > Under new user all is fine.
> > > 
> > > Do You have newly installed R3 or this system is any previous release (R1 or
> > > R2) and You update it?
> > 
> > I was using Crunchbang previously.
> 
> Also please could You provide output of command
> ls -al ~
> from problem user.

Pastebin: http://pastebin.com/nGAWUjTu
I've already deleted old directory with Gpodder config.
Comment 10 dr_2013 2014-06-01 23:24:58 MSD
(In reply to comment #6)
> (In reply to comment #5)
> > (In reply to comment #4)
> > > (In reply to comment #3)
> > > > (In reply to comment #1)
> > > > > Please could Ypu add some more information.
> > > > > Please give me the output of such commands:
> > > > > uname -a
> > > > > cat /etc/release
> > > > > rpm -qa | grep gpodder
> > > > > lspcidrake
> > > > > Could You create new test user and check the problem with new user account?
> > > > 
> > > > Under new user all is fine.
> > > 
> > > Do You have newly installed R3 or this system is any previous release (R1 or
> > > R2) and You update it?
> > 
> > I was using Crunchbang previously.
> I mean another thing. Is You installation is clean installation of R3 or it
> is upgrade from R2?

Fresh installation. I was using Crunchbang & openSUSE previously.
Comment 11 FirstLevel 2014-06-02 11:39:57 MSD
I see the same bug in Mageia (https://bugs.mageia.org/show_bug.cgi?id=13193) and there is upstream bug https://bugs.gpodder.org/show_bug.cgi?id=1618
Comment 12 FirstLevel 2014-10-08 17:09:27 MSD
Please check the problem for our new release
http://mirror.rosalab.ru/rosa/rosa2014.1/iso/ROSA.Fresh.R4/
Comment 13 FirstLevel 2014-10-08 17:10:06 MSD
I could not reproduce this problem in 2014.1 release
Comment 14 dr_2013 2015-01-14 10:49:54 MSK
And again the same problem but this time in ROSA Desktop Fresh R5.

Errors message:

1421217814.346733 [gpodder.sync] WARNING: Could not find eyeD3
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 14: reading configurations from ~/.fonts.conf is deprecated. please move it to /home/dima/.config/fontconfig/fonts.conf manually
1421217814.549667 [gpodder.log] ERROR: Uncaught exception: Traceback (most recent call last):
  File "/usr/bin/gpodder", line 175, in <module>
    main()
  File "/usr/bin/gpodder", line 170, in main
    main.main(options)
  File "/usr/lib/python2.7/site-packages/gpodder/gtkui/main.py", line 3535, in main
    gp = gPodder(bus_name, core.Core(UIConfig, model_class=Model))
  File "/usr/lib/python2.7/site-packages/gpodder/gtkui/main.py", line 120, in __init__
    BuilderWidget.__init__(self, None)
  File "/usr/lib/python2.7/site-packages/gpodder/gtkui/interface/common.py", line 38, in __init__
    GtkBuilderWidget.__init__(self, gpodder.ui_folders, gpodder.textdomain, **kwargs)
  File "/usr/lib/python2.7/site-packages/gpodder/gtkui/base.py", line 66, in __init__
    self.new()
  File "/usr/lib/python2.7/site-packages/gpodder/gtkui/main.py", line 210, in new
    self.channels = self.model.get_podcasts()
  File "/usr/lib/python2.7/site-packages/gpodder/model.py", line 1393, in get_podcasts
    self.children = self.db.load_podcasts(podcast_factory)
  File "/usr/lib/python2.7/site-packages/gpodder/dbsqlite.py", line 156, in load_podcasts                                   
    cur = self.cursor()                                                                                                     
  File "/usr/lib/python2.7/site-packages/gpodder/dbsqlite.py", line 100, in cursor                                         
    return self.db.cursor()                                                                                               
  File "/usr/lib/python2.7/site-packages/gpodder/dbsqlite.py", line 94, in db                                           
    schema.upgrade(self._db, self.database_file)                                                                        
  File "/usr/lib/python2.7/site-packages/gpodder/schema.py", line 185, in upgrade                                      
    assert version == CURRENT_VERSION                                                                              
AssertionError                                                                                                   
                                                                                                                
Traceback (most recent call last):
  File "/usr/bin/gpodder", line 175, in <module>
    main()
  File "/usr/bin/gpodder", line 170, in main
    main.main(options)
  File "/usr/lib/python2.7/site-packages/gpodder/gtkui/main.py", line 3535, in main
    gp = gPodder(bus_name, core.Core(UIConfig, model_class=Model))
  File "/usr/lib/python2.7/site-packages/gpodder/gtkui/main.py", line 120, in __init__
    BuilderWidget.__init__(self, None)
  File "/usr/lib/python2.7/site-packages/gpodder/gtkui/interface/common.py", line 38, in __init__
    GtkBuilderWidget.__init__(self, gpodder.ui_folders, gpodder.textdomain, **kwargs)
  File "/usr/lib/python2.7/site-packages/gpodder/gtkui/base.py", line 66, in __init__
    self.new()
  File "/usr/lib/python2.7/site-packages/gpodder/gtkui/main.py", line 210, in new
    self.channels = self.model.get_podcasts()
  File "/usr/lib/python2.7/site-packages/gpodder/model.py", line 1393, in get_podcasts
    self.children = self.db.load_podcasts(podcast_factory)
  File "/usr/lib/python2.7/site-packages/gpodder/dbsqlite.py", line 156, in load_podcasts
    cur = self.cursor()
  File "/usr/lib/python2.7/site-packages/gpodder/dbsqlite.py", line 100, in cursor
    return self.db.cursor()
  File "/usr/lib/python2.7/site-packages/gpodder/dbsqlite.py", line 94, in db
    schema.upgrade(self._db, self.database_file)
  File "/usr/lib/python2.7/site-packages/gpodder/schema.py", line 185, in upgrade
    assert version == CURRENT_VERSION
AssertionError
Comment 15 Stanislav Fomin 2015-01-14 19:00:58 MSK
У меня запустилось. 
Вы сможете повторить баг на чистой системе?
Comment 16 dr_2013 2015-01-14 21:05:11 MSK
(In reply to comment #15)
> У меня запустилось. 
> Вы сможете повторить баг на чистой системе?

В каком смысле на чистой? Если удалить каталог ~/gPodder, то программа запускается. Вот только без сделанных ранее настроек, списка подкастов и т.п.
Comment 17 Denis Silakov 2015-03-12 18:02:30 MSK
Вполне возможно, что проблема была вызвана несовместимостью конфигов от разных версий. У нас был очень старый gpodder и он мог просто не понять конфиги от более нового.

Сейчас gpodder обновили до 3.8.3 (последняя версия на данный момент), скоро новая версия должна будет приехать с обновлениями. Попробуйте обновиться и попробовать его запустить.
Comment 18 Denis Silakov 2015-04-21 00:01:45 MSD
Optimistically closing this one as fixed. Feel free to reopen if you still experience issues with gpodder.