Bug 4052 - Unable to load dynamic library '/usr/lib64/php/extensions/eaccelerator.so'
: Unable to load dynamic library '/usr/lib64/php/extensions/eaccelerator.so'
Status: RESOLVED WORKSFORME
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-05-24 01:14 MSD by dr_2013
Modified: 2015-01-19 22:56 MSK (History)
1 user (show)

See Also:
RPM Package: php-eaccelerator
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dr_2013 2014-05-24 01:14:25 MSD
Description of problem:

Receiving next message after installing task-lamp-php and/or php-eaccelerator package when invoking PHP intrepretator:

PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/php/extensions/eaccelerator.so' - /usr/lib64/php/extensions/eaccelerator.so: cannot open shared object file: No such file or directory in Unknown on line 0


Version-Release number of selected component (if applicable):
Version: 0.9.6.1git20120725.
Release: 12-rosa2012.1.

How reproducible:

Steps to Reproduce:
1. Install php-eaccelerator package.
2. Execute php command in terminal.
Comment 1 dr_2013 2014-05-24 01:15:57 MSD
There is no eaccelerator.so file in /usr/lib64/php/extensions/. Library is located in /usr/lib/php/extensions/
Comment 2 Denis Silakov 2014-05-26 14:05:17 MSD
It looks like 32bit version of php-eaccelerator is being installed. 32bit version provides .so file in /usr/lib/php/extensions/, 64bit version - in /usr/lib64/php/extensions/.
Comment 3 dr_2013 2014-05-27 11:21:31 MSD
(In reply to comment #2)
> It looks like 32bit version of php-eaccelerator is being installed. 32bit
> version provides .so file in /usr/lib/php/extensions/, 64bit version - in
> /usr/lib64/php/extensions/.

Yes, you are right. I just reinstalled task-lamp-php-2012.1-1-rosa2012.1.noarch package and php-eaccelerator x86_64 was installed but problem still exists.
Comment 4 Denis Silakov 2014-10-20 11:36:23 MSD
Does this problem occur if you install Desktop Fresh R4 from scratch?
Comment 5 Denis Silakov 2015-01-14 19:21:25 MSK
Marking as "works for me" for now. Feel free to reopen if you are able to reproduce the issue on the fresh installation.
Comment 6 dr_2013 2015-01-14 21:08:33 MSK
In ROSA Desktop Fresh R5 release 2014.1 x86_64:

[eAccelerator] This build of "eAccelerator" was compiled for PHP version 5.5.18. Rebuild it for your PHP version (5.5.19) or download precompiled binaries.
Comment 7 Denis Silakov 2015-01-19 22:56:02 MSK
Oops, indeed. The package has been rebuilt.