Bug 4020 - Login Failed
: Login Failed
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-05-10 16:08 MSD by Serdar Ateş
Modified: 2014-10-15 23:48 MSD (History)
4 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
I choose highlighted section and click ok (157.97 KB, image/png)
2014-05-17 18:56 MSD, Serdar Ateş
Details
and than click yes (133.85 KB, image/png)
2014-05-17 18:57 MSD, Serdar Ateş
Details
and download and install drivers (139.68 KB, image/png)
2014-05-17 18:58 MSD, Serdar Ateş
Details
and select automatically start the graphical interface (Xorg) upon booting and click yes (138.79 KB, image/png)
2014-05-17 19:00 MSD, Serdar Ateş
Details
Click yes (124.35 KB, image/png)
2014-05-17 19:01 MSD, Serdar Ateş
Details
And ok (147.56 KB, image/png)
2014-05-17 19:06 MSD, Serdar Ateş
Details
After restart (611.68 KB, image/png)
2014-05-17 19:07 MSD, Serdar Ateş
Details
and this is the last screen (611.68 KB, image/png)
2014-05-17 19:10 MSD, Serdar Ateş
Details
grub (391 bytes, text/plain)
2014-05-22 23:01 MSD, Serdar Ateş
Details
Xorg.0.log (6.22 KB, text/x-log)
2014-05-26 20:41 MSD, Serdar Ateş
Details
Xorg.0.log.old (75.35 KB, application/octet-stream)
2014-05-26 20:42 MSD, Serdar Ateş
Details
xorg.conf (1.04 KB, text/plain)
2014-05-31 12:41 MSD, Serdar Ateş
Details
Journalctl (123.96 KB, text/x-log)
2014-06-17 20:41 MSD, Serdar Ateş
Details
Panic occured (1.12 MB, image/jpeg)
2014-10-04 00:23 MSD, Serdar Ateş
Details
dmesg (60.92 KB, application/octet-stream)
2014-10-07 14:28 MSD, Serdar Ateş
Details
Xorg.0.log (33.69 KB, text/x-log)
2014-10-07 14:29 MSD, Serdar Ateş
Details
journalctl.log (132.21 KB, text/x-log)
2014-10-07 14:30 MSD, Serdar Ateş
Details
Choose a driver (13.35 KB, image/png)
2014-10-15 23:48 MSD, Serdar Ateş
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Serdar Ateş 2014-05-10 16:08:04 MSD
Description of problem:
I'm unable to login to the system. After the boot splash screen, a black screen comes and lots of things write and end of the screen this words are write "Failed to start wait for plymouth boot screen to quit" and nothing happen, ever time this screen comes. 
   If you ask how this happen good question; I use ROSA without any problem but I buy a new laptop and install the ROSA there every things works good installation complete without any problem, after login I install the ATI driver from the "set-up the graphical server" ok it's finish, but after restart the system, system is gone not open, I install the system several times and try different things but nothing every thins work good until the install ATI graphic card driver
   My graphic card is ATI Radeon HD 7670M, and I choose Radeon HD 6400 and later (radeon/fglrx) option in the set-up the graphical server (is it wrong but default it comes?).
I cannot use the system please help! 

Version-Release number of selected component (if applicable):

How reproducible:

Every time I attempt to start ROSA

Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2014-05-12 10:13:00 MSD
What release of ROSA do You use?
All works well after installation until You install proprietary ATI drivers. Am I right?
Comment 2 Serdar Ateş 2014-05-12 21:13:57 MSD
I use ROSA Fresh R3 64bit.
Yes you right until the installation of the Ati driver...
Comment 3 Serdar Ateş 2014-05-12 21:14:44 MSD
Also R2 has same problem.
Comment 4 FirstLevel 2014-05-13 09:05:02 MSD
1. Please could You give me output of such commands
uname -a
urpmq --list-media active
urpmq --list-url
lspcidrake

2.Could You attach all screens of "set-up the graphical server" when You install proprietary driver.
Comment 5 Serdar Ateş 2014-05-13 19:02:42 MSD
So I need to reinstall ROSA R3 and give You information ok, but it's take few time collect the infornations.
Comment 6 Vladimir Potapov 2014-05-15 05:58:53 MSD
(In reply to comment #5)
> So I need to reinstall ROSA R3 and give You information ok, but it's take
> few time collect the infornations.

Enter to the system with ctrl+alt+F2 and delete xorg.conf to default load.
Comment 7 Serdar Ateş 2014-05-15 08:53:51 MSD
This is the good news, thank You! I will do it and feedback, now I'm far away from pc, I'm in the military at now when I come back home I will do it.
Comment 8 Serdar Ateş 2014-05-17 18:56:27 MSD
Created attachment 2882 [details]
I choose highlighted section and click ok
Comment 9 Serdar Ateş 2014-05-17 18:57:14 MSD
Created attachment 2883 [details]
and than click yes
Comment 10 Serdar Ateş 2014-05-17 18:58:03 MSD
Created attachment 2884 [details]
and download and install drivers
Comment 11 Serdar Ateş 2014-05-17 19:00:28 MSD
Created attachment 2885 [details]
and select automatically start the graphical interface (Xorg) upon booting and click yes
Comment 12 Serdar Ateş 2014-05-17 19:01:15 MSD
Created attachment 2886 [details]
Click yes
Comment 13 Serdar Ateş 2014-05-17 19:06:43 MSD
Created attachment 2887 [details]
And ok
Comment 14 Serdar Ateş 2014-05-17 19:07:55 MSD
Created attachment 2888 [details]
After restart
Comment 15 Serdar Ateş 2014-05-17 19:10:33 MSD
Created attachment 2889 [details]
and this is the last screen
Comment 16 Serdar Ateş 2014-05-17 19:11:23 MSD
[serdar@serdar-350V5C ~]$ uname -a
Linux serdar-350V5C 3.10.34-nrj-desktop-3rosa #1 SMP PREEMPT Fri Apr 18 20:11:49 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

[serdar@serdar-350V5C ~]$ urpmq --list-media active
main
main updates
Main32
Main32 Updates
contrib
contrib updates
non-free
non-free updates
Non-free32
Non-free32 Updates
restricted
restricted updates
Restricted32
Restricted32 Updates

[serdar@serdar-350V5C ~]$ urpmq --list-url
main http://mirror.rosalab.ru/rosa/rosa2012.1/repository/x86_64/media/main/release
main updates http://mirror.rosalab.ru/rosa/rosa2012.1/repository/x86_64/media/main/updates
main testing http://mirror.rosalab.ru/rosa/rosa2012.1/repository/x86_64/media/main/testing
Main32 http://mirror.rosalab.ru/rosa/rosa2012.1/repository/i586/media/main/release
Main32 Updates http://mirror.rosalab.ru/rosa/rosa2012.1/repository/i586/media/main/updates
main32 testing http://mirror.rosalab.ru/rosa/rosa2012.1/repository/i586/media/main/testing
contrib http://mirror.rosalab.ru/rosa/rosa2012.1/repository/x86_64/media/contrib/release
contrib updates http://mirror.rosalab.ru/rosa/rosa2012.1/repository/x86_64/media/contrib/updates
non-free http://mirror.rosalab.ru/rosa/rosa2012.1/repository/x86_64/media/non-free/release
non-free updates http://mirror.rosalab.ru/rosa/rosa2012.1/repository/x86_64/media/non-free/updates
Non-free32 http://mirror.rosalab.ru/rosa/rosa2012.1/repository/i586/media/non-free/release
Non-free32 Updates http://mirror.rosalab.ru/rosa/rosa2012.1/repository/i586/media/non-free/updates
restricted http://mirror.rosalab.ru/rosa/rosa2012.1/repository/x86_64/media/restricted/release
restricted updates http://mirror.rosalab.ru/rosa/rosa2012.1/repository/x86_64/media/restricted/updates
Restricted32 http://mirror.rosalab.ru/rosa/rosa2012.1/repository/i586/media/restricted/release
Restricted32 Updates http://mirror.rosalab.ru/rosa/rosa2012.1/repository/i586/media/restricted/updates


[serdar@serdar-350V5C ~]$ lspcidrake
ath9k           : Qualcomm Atheros|AR9485 Wireless Network Adapter [NETWORK_OTHER] (rev: 01)
r8169           : Realtek Semiconductor Co., Ltd.|RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [NETWORK_ETHERNET] (rev: 09)
Card:ATI Radeon HD 6400 and later (radeon/fglrx): Advanced Micro Devices, Inc. [AMD/ATI]|Thames [Radeon HD 7500M/7600M Series] [DISPLAY_VGA]
i2c_i801        : Intel Corporation|7 Series/C210 Series Chipset Family SMBus Controller [SERIAL_SMBUS] (rev: 04)
ahci            : Intel Corporation|7 Series Chipset Family 6-port SATA Controller [AHCI mode] [STORAGE_SATA] (rev: 04)
lpc_ich         : Intel Corporation|HM76 Express Chipset LPC Controller [BRIDGE_ISA] (rev: 04)
ehci_pci        : Intel Corporation|7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 [SERIAL_USB] (rev: 04)
shpchp          : Intel Corporation|7 Series/C210 Series Chipset Family PCI Express Root Port 2 [BRIDGE_PCI] (rev: c4)
shpchp          : Intel Corporation|7 Series/C210 Series Chipset Family PCI Express Root Port 1 [BRIDGE_PCI] (rev: c4)
snd_hda_intel   : Intel Corporation|7 Series/C210 Series Chipset Family High Definition Audio Controller [MULTIMEDIA_AUDIO_DEV] (rev: 04)
ehci_pci        : Intel Corporation|7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 [SERIAL_USB] (rev: 04)
mei             : Intel Corporation|7 Series/C210 Series Chipset Family MEI Controller #1 [COMMUNICATION_OTHER] (rev: 04)
xhci_hcd        : Intel Corporation|7 Series/C210 Series Chipset Family USB xHCI Host Controller [SERIAL_USB] (rev: 04)
i915            : Intel Corporation|3rd Gen Core processor Graphics Controller [DISPLAY_VGA] (rev: 09)
shpchp          : Intel Corporation|Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port [BRIDGE_PCI] (rev: 09)
unknown         : Intel Corporation|3rd Gen Core processor DRAM Controller [BRIDGE_HOST] (rev: 09)
hub             : Linux 3.10.34-nrj-desktop-3rosa xhci_hcd|xHCI Host Controller [Hub|Unused|Full speed (or root) hub]
hub             : Linux 3.10.34-nrj-desktop-3rosa xhci_hcd|xHCI Host Controller [Hub|Unused|Full speed (or root) hub]
usbhid          : Avago Technologies, Pte.|USB Optical Mouse [Human Interface Device|Boot Interface Subclass|Mouse]
hub             : Linux 3.10.34-nrj-desktop-3rosa ehci_hcd|EHCI Host Controller [Hub|Unused|Full speed (or root) hub]
hub             : Intel Corp.|Integrated Rate Matching Hub [Hub|Unused|Full speed (or root) hub]
hub             : Linux 3.10.34-nrj-desktop-3rosa ehci_hcd|EHCI Host Controller [Hub|Unused|Full speed (or root) hub]
hub             : Intel Corp.|Integrated Rate Matching Hub [Hub|Unused|Full speed (or root) hub]
rts5139         : Generic|USB2.0-CRW
ath3k           : Atheros Communications|Bluetooth USB Host Controller [Wireless|Radio Frequency|Bluetooth]
uvcvideo        : Generic|WebCam SC-13HDL11939N [Video|Video Control]
hid_generic     : USB Optical Mouse
Comment 17 FirstLevel 2014-05-19 10:29:38 MSD
I see that You have two video adapters (I think You have laptop with two video adapters):
Card:ATI Radeon HD 6400 and later (radeon/fglrx): Advanced Micro Devices, Inc. [AMD/ATI]|Thames [Radeon HD 7500M/7600M Series] [DISPLAY_VGA]

i915            : Intel Corporation|3rd Gen Core processor Graphics Controller [DISPLAY_VGA] (rev: 09)

Could You select Your primary videocard in BIOS?

I think You should do such steps.
1. Install ROSA.
2. Enable ATI videocard in BIOS (if it is disabled)
3. Use XFdrake to set up ATI videocard. DON'T REBOOT!
4. From root execute command
amdconfig --initial -f
5. Reboot Your system
Comment 18 FirstLevel 2014-05-19 10:31:51 MSD
Instead of reinstall the system You could try to remove xorg.conf (http://bugs.rosalinux.ru/show_bug.cgi?id=4020#c6)
Comment 19 Eugene Shatokhin 2014-05-19 10:59:55 MSD
Also, please attach /etc/default/grub as it is after you have installed the proprietary drivers. Let's see if 'nomodeset' is in the kernel options there.

There should be a line like this there:
GRUB_CMDLINE_LINUX_DEFAULT='splash=silent logo.nologo nomodeset'

If the proprietary video drivers are installed, 'nomodeset' should be present. 

If it is not, then please add 'nomodeset' to the kernel options at boot time and see if the system boots OK.
Comment 20 Serdar Ateş 2014-05-19 11:16:03 MSD
Yes I have laptop, and two graphic card You right.
Ok I will check the bios I hope there is a option. But why I cannot use both craphic card, because it produced for the two process one is the for performance process other one which is intel for the normal daily using.
For example on the windows 7 it use one of the graphic card  and another one stay disabled and system decide to eneble and disable graphic cards. In the ROSA is there any technology like this?
Comment 21 Serdar Ateş 2014-05-19 12:03:26 MSD
Ok I will chack nomodset
Comment 22 FirstLevel 2014-05-19 14:10:57 MSD
(In reply to comment #20)
> Yes I have laptop, and two graphic card You right.
> Ok I will check the bios I hope there is a option. But why I cannot use both
> craphic card, because it produced for the two process one is the for
> performance process other one which is intel for the normal daily using.
> For example on the windows 7 it use one of the graphic card  and another one
> stay disabled and system decide to eneble and disable graphic cards. In the
> ROSA is there any technology like this?

You can use vgaswitcheroo for switching between videocards.
Comment 23 Serdar Ateş 2014-05-19 16:16:32 MSD
I thought this dual video card cause this problem, first I install ATI drivers but after restart system start with intel graphic card and ATI driver crashing with intel card and cause this, what You think? For this reason I ask is there any technology to decide selection video card and its own driver in ROSA
Comment 24 FirstLevel 2014-05-20 13:46:43 MSD
(In reply to comment #23)
> I thought this dual video card cause this problem, first I install ATI
> drivers but after restart system start with intel graphic card and ATI
> driver crashing with intel card and cause this, what You think? For this
> reason I ask is there any technology to decide selection video card and its
> own driver in ROSA

I has answered that You coul use vgaswitcheroo mechanism. For example, look at these articles
https://help.ubuntu.com/community/HybridGraphics
http://www.linuxquestions.org/questions/slackware-14/how-to-switch-between-graphics-processors-using-vga-switcheroo-4175437338/
Comment 25 Serdar Ateş 2014-05-22 23:00:07 MSD
No there is no option in the boot about the graphic card Ati or Intel.
I delete xorg.conf and I enter system without any problem, and nomodeset write there which you tell me the adress.
So now? what is next step? there is no option selection graphic card and nomodeset exist.
Comment 26 Serdar Ateş 2014-05-22 23:01:02 MSD
Created attachment 2902 [details]
grub
Comment 27 Andrey Ponomarenko 2014-05-23 12:15:12 MSD
Please try to login after boot hanging via the Ctrl+Alt+{F2,F3,...} and attach your log files /var/log/Xorg.0.log, /var/log/Xorg.0.log.old and log of the `sudo journalctl -ab` command.

Thanks.
Comment 28 Serdar Ateş 2014-05-26 20:41:56 MSD
Created attachment 2932 [details]
Xorg.0.log
Comment 29 Serdar Ateş 2014-05-26 20:42:52 MSD
Created attachment 2933 [details]
Xorg.0.log.old
Comment 30 Eugene Shatokhin 2014-05-27 11:10:41 MSD
(In reply to comment #29)
> Created attachment 2933 [details]
> Xorg.0.log.old

Please, provide also the output of `sudo journalctl -ab` (collect it after the problem occurs) as Andrey suggested above as well as /etc/X11/xorg.conf, if present.

It seems from Xorg.0.log that the proprietary driver did not detect the device for some reason. The system log ('journalctl -ab') might sched some light on that problem.
Comment 31 Andrey Ponomarenko 2014-05-29 11:16:15 MSD
Serdar, please attach also output of `lspci -vnn` command.

Thank you.
Comment 32 Serdar Ateş 2014-05-31 12:21:59 MSD
Sorry for the late answers, my military service is not finish yet, I will come home only holidays, sorry for this situation...
here is the lspci -vnn output

[serdar@serdar-350V5C ~]$ lspci -vnn
00:00.0 Host bridge [0600]: Intel Corporation 3rd Gen Core processor DRAM Controller [8086:0154] (rev 09)
        Subsystem: Samsung Electronics Co Ltd Device [144d:c0d8]
        Flags: bus master, fast devsel, latency 0
        Capabilities: <access denied>

00:01.0 PCI bridge [0604]: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port [8086:0151] (rev 09) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
        I/O behind bridge: 00003000-00003fff
        Memory behind bridge: c0200000-c02fffff
        Prefetchable memory behind bridge: 00000000e0000000-00000000efffffff
        Capabilities: <access denied>
        Kernel driver in use: pcieport
        Kernel modules: shpchp

00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
        Subsystem: Samsung Electronics Co Ltd Device [144d:c0d8]
        Flags: fast devsel, IRQ 16
        Memory at bfc00000 (64-bit, non-prefetchable) [size=4M]
        Memory at d0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at 4000 [size=64]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: <access denied>
        Kernel modules: i915

00:14.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller [8086:1e31] (rev 04) (prog-if 30 [XHCI])
        Subsystem: Samsung Electronics Co Ltd Device [144d:c0d8]
        Flags: bus master, medium devsel, latency 0, IRQ 43
        Memory at c0300000 (64-bit, non-prefetchable) [size=64K]
        Capabilities: <access denied>
        Kernel driver in use: xhci_hcd
        Kernel modules: xhci_hcd

00:16.0 Communication controller [0780]: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 [8086:1e3a] (rev 04)
        Subsystem: Samsung Electronics Co Ltd Device [144d:c0d8]
        Flags: bus master, fast devsel, latency 0, IRQ 44
        Memory at c031a000 (64-bit, non-prefetchable) [size=16]
        Capabilities: <access denied>
        Kernel driver in use: mei_me
        Kernel modules: mei_me

00:1a.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 [8086:1e2d] (rev 04) (prog-if 20 [EHCI])
        Subsystem: Samsung Electronics Co Ltd Device [144d:c0d8]
        Flags: bus master, medium devsel, latency 0, IRQ 16
        Memory at c0318000 (32-bit, non-prefetchable) [size=1K]
        Capabilities: <access denied>
        Kernel driver in use: ehci-pci
        Kernel modules: ehci_pci

00:1b.0 Audio device [0403]: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller [8086:1e20] (rev 04)
        Subsystem: Samsung Electronics Co Ltd Device [144d:c0d8]
        Flags: bus master, fast devsel, latency 0, IRQ 45
        Memory at c0310000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel

00:1c.0 PCI bridge [0604]: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 [8086:1e10] (rev c4) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
        I/O behind bridge: 00002000-00002fff
        Memory behind bridge: c0100000-c01fffff
        Capabilities: <access denied>
        Kernel driver in use: pcieport
        Kernel modules: shpchp

00:1c.1 PCI bridge [0604]: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 [8086:1e12] (rev c4) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=03, subordinate=03, sec-latency=0
        Memory behind bridge: c0000000-c00fffff
        Capabilities: <access denied>
        Kernel driver in use: pcieport
        Kernel modules: shpchp

00:1d.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 [8086:1e26] (rev 04) (prog-if 20 [EHCI])
        Subsystem: Samsung Electronics Co Ltd Device [144d:c0d8]
        Flags: bus master, medium devsel, latency 0, IRQ 23
        Memory at c0317000 (32-bit, non-prefetchable) [size=1K]
        Capabilities: <access denied>
        Kernel driver in use: ehci-pci
        Kernel modules: ehci_pci

00:1f.0 ISA bridge [0601]: Intel Corporation HM76 Express Chipset LPC Controller [8086:1e59] (rev 04)
        Subsystem: Samsung Electronics Co Ltd Device [144d:c0d8]
        Flags: bus master, medium devsel, latency 0
        Capabilities: <access denied>
        Kernel driver in use: lpc_ich
        Kernel modules: lpc_ich

00:1f.2 SATA controller [0106]: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] [8086:1e03] (rev 04) (prog-if 01 [AHCI 1.0])
        Subsystem: Samsung Electronics Co Ltd Device [144d:c0d8]
        Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 41
        I/O ports at 40b0 [size=8]
        I/O ports at 40a0 [size=4]
        I/O ports at 4090 [size=8]
        I/O ports at 4080 [size=4]
        I/O ports at 4060 [size=32]
        Memory at c0316000 (32-bit, non-prefetchable) [size=2K]
        Capabilities: <access denied>
        Kernel driver in use: ahci

00:1f.3 SMBus [0c05]: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller [8086:1e22] (rev 04)
        Subsystem: Samsung Electronics Co Ltd Device [144d:c0d8]
        Flags: medium devsel, IRQ 18
        Memory at c0315000 (64-bit, non-prefetchable) [size=256]
        I/O ports at 4040 [size=32]
        Kernel modules: i2c_i801

01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Thames [Radeon HD 7500M/7600M Series] [1002:6840] (prog-if 00 [VGA controller])
        Subsystem: Samsung Electronics Co Ltd Device [144d:c0d8]
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at e0000000 (64-bit, prefetchable) [size=256M]
        Memory at c0220000 (64-bit, non-prefetchable) [size=128K]
        I/O ports at 3000 [size=256]
        Expansion ROM at c0200000 [disabled] [size=128K]
        Capabilities: <access denied>
        Kernel driver in use: fglrx_pci
        Kernel modules: radeon, fglrx

02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 09)
        Subsystem: Samsung Electronics Co Ltd Device [144d:c0d8]
        Flags: bus master, fast devsel, latency 0, IRQ 42
        I/O ports at 2000 [size=256]
        Memory at c0104000 (64-bit, prefetchable) [size=4K]
        Memory at c0100000 (64-bit, prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: r8169
        Kernel modules: r8169

03:00.0 Network controller [0280]: Qualcomm Atheros AR9485 Wireless Network Adapter [168c:0032] (rev 01)
        Subsystem: Samsung Electronics Co Ltd Device [144d:4105]
        Flags: bus master, fast devsel, latency 0, IRQ 17
        Memory at c0000000 (64-bit, non-prefetchable) [size=512K]
        Expansion ROM at c0080000 [disabled] [size=64K]
        Capabilities: <access denied>
        Kernel driver in use: ath9k
        Kernel modules: ath9k
Comment 33 Serdar Ateş 2014-05-31 12:41:44 MSD
Created attachment 2942 [details]
xorg.conf
Comment 34 Serdar Ateş 2014-05-31 12:56:03 MSD
Ok I get the output of the "journalctl -ab" but how to copy them to here? or is they are saved somewhere? like a log file to get all them.
Comment 35 Andrey Ponomarenko 2014-06-03 15:32:28 MSD
Thank you, Serdar.

In order to save the log of journalctl please type:

$> journalctl -ab > journalctl.log 2>&1

Then please attach journalctl.log file to this bug.
Comment 36 Andrey Ponomarenko 2014-06-11 14:00:19 MSD
The journalctl command should be run with administrator privileges:

$> sudo journalctl -ab > journalctl.log 2>&1
Comment 37 Serdar Ateş 2014-06-11 19:07:24 MSD
Ok I did it but I couldn't find where it's located? I check log file but couldn't find?
Comment 38 Andrey Ponomarenko 2014-06-17 16:07:37 MSD
The log file journalctl.log should be located in the same directory where you've run the journalctl command.
Comment 39 Serdar Ateş 2014-06-17 18:30:03 MSD
I launch it when the black screen comes so when system hang out, I push ctrl + alt + f2,f3 and type my login name and password and get su rights and type journalctl -ab everythings happening in the black screen before the login screen and I don't see any enviroment such as folder, directory etc...
Comment 40 Eugene Shatokhin 2014-06-17 19:08:35 MSD
(In reply to comment #39)
> I launch it when the black screen comes so when system hang out, I push ctrl
> + alt + f2,f3 and type my login name and password and get su rights and type
> journalctl -ab everythings happening in the black screen before the login
> screen and I don't see any enviroment such as folder, directory etc...

'pwd' command will show the current directory. 

That said, if you logged in as your user, the currect directory should be your home directory by default. If as root - it will be /root directory. 

Hope this helps.
Comment 41 Serdar Ateş 2014-06-17 19:11:47 MSD
Oh! yes logical! I check it today...
Comment 42 Serdar Ateş 2014-06-17 20:41:03 MSD
Created attachment 2958 [details]
Journalctl
Comment 43 Serdar Ateş 2014-06-17 20:41:59 MSD
Yes I found it in my home directory...
Comment 44 Andrey Ponomarenko 2014-06-30 14:26:44 MSD
Serdar, we have one more request to you. Please load your PC probe after the system hang:

1) Type ctrl+alt+f2/f3 and enter the terminal;
2) Type the following commands:

$> wget http://hw.rosalinux.ru/downloads/hw-probe/rosa2012.1/hw-probe-0.2-1-rosa2012.1.x86_64.rpm
$> sudo urpmi hw-probe-0.2-1-rosa2012.1.x86_64.rpm
$> sudo hw-probe -all -upload -id serdar-laptop

Thank you!
Comment 45 Serdar Ateş 2014-07-22 23:46:45 MSD
Finally I finish military service and come back home... I found alternative solution to my problem, this is installing official drivers. I download official package from ATI official site and install it and all ROSA login without problem and working good performance...
Comment 46 Eugene Shatokhin 2014-07-23 12:03:48 MSD
(In reply to comment #45)
> Finally I finish military service and come back home... I found alternative
> solution to my problem, this is installing official drivers. I download
> official package from ATI official site and install it and all ROSA login
> without problem and working good performance...

Interesting. What exactly did you install? Which version?
Comment 47 Serdar Ateş 2014-07-24 10:00:47 MSD
http://support.amd.com/en-us/download/desktop?os=Linux%20x86_64#amd-catalyst-packages
here is the link
version 14.4
I download it and extract file, after double click to extracted file it work such as .rpm file and a installation wizard comes, next next... and installation finish I restart computer and it works. It also install Catalyst Control Center.
Comment 48 Eugene Shatokhin 2014-07-24 10:34:08 MSD
(In reply to comment #47)
> version 14.4
> I download it and extract file, after double click to extracted file it work
> such as .rpm file and a installation wizard comes, next next... and
> installation finish I restart computer and it works. It also install
> Catalyst Control Center.

I see. At the same time, we have updated that driver to 14.x in our repositories too.

Perhaps, there were some issues with the previous version.
Comment 49 Serdar Ateş 2014-07-26 18:53:30 MSD
I see. Thank you for everything everyone.
Comment 50 Serdar Ateş 2014-07-26 19:04:06 MSD
By the way, are they same drivers or is there any differences? Supporting, automatic update etc.?
Comment 51 Eugene Shatokhin 2014-07-28 10:25:06 MSD
(In reply to comment #50)
> By the way, are they same drivers or is there any differences? Supporting,
> automatic update etc.?

The binaries in our packages are the same as those from AMD web site (we get them from there). If there are any differences, it might be in some files with settings, not sure about that.

The drivers from our repository support automatic updates, as usual. The drivers from AMD web site - well, I don't know.

If you choose to use the drivers from our repository in the future (you don't have to though), you will need to uninstall the drivers you have how first. Apart from that, it should be OK.
Comment 52 Serdar Ateş 2014-08-01 22:02:21 MSD
Well, as a result where do I find this proprietary drivers? Or how to reach repositories? I search Rosa software manager but could'nt find it...
Comment 53 Eugene Shatokhin 2014-08-04 10:41:58 MSD
(In reply to comment #52)
> Well, as a result where do I find this proprietary drivers? Or how to reach
> repositories? I search Rosa software manager but could'nt find it...

The drivers are in our "non-free updates" repository which should be already enabled by default.

Here it is, by the way:
http://mirror.rosalab.ru/rosa/rosa2012.1/repository/x86_64/non-free/updates/

The needed packages are dkms-fglrx, fglrx-control-center, x11-driver-video-fglrx. The current version is 14.10.1006.1001.

It is recommended to use XFdrake: it will install the appropriate packages for you and will prepare the needed system settings.

If XFdrake still installs the old packages with fglrx (version 13.x), please check if "non-free" and "non-free updates" repositories are enabled (see if there is "ignore" in the appropriate sections of /etc/urpmi/urpmi.cfg).
Comment 54 Serdar Ateş 2014-10-03 02:23:48 MSD
When I use the proprietary driver ROSA didn't shut down or restart correctly black screen comes and these are write there and system freeze

[ 162.562553] Kernel panic - not syncing: Attempted to kill init! exitcode=0x0000000b
[ 162.562553]
[ 162.568107] drm_kms_helper: panic occurred, switching back to text console
 After when I uninstall driver shutdown correctly or restart
Any idea?
Comment 55 Eugene Shatokhin 2014-10-03 11:27:17 MSD
(In reply to comment #54)
> When I use the proprietary driver ROSA didn't shut down or restart correctly
> black screen comes and these are write there and system freeze
> Any idea?

Which kernel are you using now? 3.10.x or 3.14.x?
Comment 56 Eugene Shatokhin 2014-10-03 14:18:01 MSD
Besides, does the problem happen each time you restart the system if fglrx is installed?

If the problem happens again, could you take a photo of the screen with kernel panic and post it here? It may show some useful info (stack trace, etc.)
Comment 57 Serdar Ateş 2014-10-04 00:23:14 MSD
Created attachment 3295 [details]
Panic occured
Comment 58 Serdar Ateş 2014-10-04 00:23:39 MSD
Yes its happen always, now I use 3.10.34 its looking latest kernel in my system there is no 3.14 update...
Comment 59 Eugene Shatokhin 2014-10-06 11:26:59 MSD
Thanks for the info. Well, it looks like there were some other kernel errors before this panic, although it is unclear yet what went wrong.

Could you try kernel 3.14 and the updated graphics software and see, if the problem still happens? To do so, you can add 2 repositories and perform a software update. 

# urpmi.addmedia kernel-3.14 http://abf-downloads.rosalinux.ru/kernels_3_14x_personal/repository/rosa2012.1/x86_64/main/release/

# urpmi.addmedia graphics-test http://abf-downloads.rosalinux.ru/x11_backports_personal/repository/rosa2012.1/x86_64/main/release/

# urpmi --auto-update

If the kernel 3.14.x has not been installed automatically then, you can install it manually:

# urpmi kernel-nrj-desktop-latest kernel-nrj-desktop-devel-latest

If urpmi issues warnings about a "conflict" between mesa packages for i586 and x86_64, you can ignore it.

Then, execute 'sync' just in case, reboot and see what happens. 

Of course, it would be wise to backup the important data first, before the updates. Won't hurt anyway.
Comment 60 Serdar Ateş 2014-10-07 12:23:47 MSD
Ok I install both media and update them, now I use kernel 3.14. after I download latest driver from Amd website which is 14.10 but its couldn't recognize my system and setup not start I delete it and try to install from "Set up the graphical server" option in settings, Its also download 14.10 but much less size and install but after reboot system system back to the previous error which is "Failed to start wait for plymouth boot screen to quit" 

I don't understand same driver but in repository didn't work? 

but website driver no longer work...
Comment 61 Eugene Shatokhin 2014-10-07 13:06:13 MSD
(In reply to comment #60)
> I don't understand same driver but in repository didn't work? 

The drivers are no longer the same. As far as I know, AMD currently offers fglrx 14.30 as a part of Catalyst 14.9, but we have fglrx 14.10 at the moment. We are working on the release of ROSA Fresh R4 now. After that we will prepare the updates of the proprietary drivers (and will be encouraging users to migrate from ROSA Fresh R3 to R4).

Anyway, we generally do not recommend using the drivers from the AMD's web site directly.

Now to the problem. 

1. Does the updated system work OK with the opensource driver?

2. After you install the proprietary drivers via "Set up the graphical server" or XFdrake, which exactly packages are installed? I mean what does 'rpm -qa | grep fglrx' show?

3. After the reboot, if the graphics does not start, please go to a text console (ctrl-alt-f2), log in there. 

What does 'cat /proc/cmdline' show?

4. What does 'lsmod | grep fglrx' show?

5. Please also save /var/log/Xorg.0.log and the output of 'journalctl -ab' and 'dmesg' somewhere and attach all that to this to this bug again.

Some problem with configuration, may be.
Comment 62 Serdar Ateş 2014-10-07 14:27:47 MSD
Fresh R4! good news... 

1: Yes updated system works fine without any problem with opensource (native, default) drivers

2: Here is the rpm -qa | grep fglrx

[serdar@serdar-350V5C ~]$ rpm -qa | grep fglrx
dkms-fglrx-14.10.1006.1001-2-rosa2012.1.x86_64
fglrx-control-center-14.10.1006.1001-2-rosa2012.1.x86_64
x11-driver-video-fglrx-14.10.1006.1001-2-rosa2012.1.x86_64

3: cat /proc/cmdline

[serdar@serdar-350V5C ~]$ cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-3.14.19-nrj-desktop-1rosa root=UUID=36ab2049-c0f1-4ee2-af66-4b489ccdca8d ro splash=silent logo.nologo resume=UUID=9a716614-019e-4f82-8923-05e598169fbc

4: lsmod | grep fglrx
[serdar@serdar-350V5C ~]$ lsmod | grep fglrx
fglrx                8811251  0 
amd_iommu_v2           19097  1 fglrx
button                 13890  2 i915,fglrx
Comment 63 Serdar Ateş 2014-10-07 14:28:54 MSD
Created attachment 3301 [details]
dmesg
Comment 64 Serdar Ateş 2014-10-07 14:29:19 MSD
Created attachment 3302 [details]
Xorg.0.log
Comment 65 Serdar Ateş 2014-10-07 14:30:06 MSD
Created attachment 3303 [details]
journalctl.log
Comment 66 Serdar Ateş 2014-10-07 16:28:06 MSD
I saw something I use this kernel,

kernel-nrj-desktop-3.14.19-1rosa - Linux Kernel for desktop use with x86_64​   

this is about desktop, but there is also for the laptops which is not installed

kernel-nrj-laptop-3.14.19-1rosa - Linux Kernel for laptop use with x86_64​

and I'm using laptop, is this ok? there is a trick?
Comment 67 Eugene Shatokhin 2014-10-07 16:42:29 MSD
(In reply to comment #66)
> I saw something I use this kernel,
> 
> kernel-nrj-desktop-3.14.19-1rosa - Linux Kernel for desktop use with x86_64​
> 
> 
> this is about desktop, but there is also for the laptops which is not
> installed
> 
> kernel-nrj-laptop-3.14.19-1rosa - Linux Kernel for laptop use with x86_64​
> 
> and I'm using laptop, is this ok? there is a trick?

You can use either of these but it should not affect the graphics. 
The laptop-oriented kernel should (theoretically) result in less power consumption than the -desktop one. The actual gain is yet to be measured though.
Comment 68 Eugene Shatokhin 2014-10-07 17:05:20 MSD
Could you also upload info about your hardware and system configuration to our database? 

Please download http://hw.rosalinux.ru/downloads/hw-probe/rosa2012.1/hw-probe-0.7.1-1-rosa2012.1.x86_64.rpm, then install it with 'urpmi <path_to_hw-probe_rpm>'.

Then, when you use fglrx and the graphics does not start, login to the text console as before and run the following:

sudo hw-probe -all -upload -id serdar-350V5C

What does this command output?

More info about hw-probe:
http://hw.rosalinux.ru/index.php?show=check
Comment 69 Serdar Ateş 2014-10-07 18:42:29 MSD
Here is the info
http://hw.rosalinux.ru/index.php?probeU=83db4e989c
Comment 70 Serdar Ateş 2014-10-07 18:45:22 MSD
Ooh I see, thank you for information about kernel
Comment 71 Andrey Ponomarenko 2014-10-09 12:13:39 MSD
Serdar,

Thank you for the probe. Now we are able to fix the issue.

Please follow these steps to setup hybrid graphics:

1) Load your system in VESA graphics mode (add "nomodeset" boot option on start).

2) Run the following commands:

sudo amdconfig --initial
sudo grub2-cfg-mod --del nomodeset
sudo grub2-cfg-mod --add radeon.modeset=0
sudo update-grub2
sudo update-alternatives --set gl_conf /etc/ld.so.conf.d/GL/ati.conf

And reboot. Your system should start on the fglrx driver. You can check this by running the fgl_glxgears program.

According to the probe: http://hw.rosalinux.ru/index.php?probe=83db4e989c

Thank you.
Comment 72 Serdar Ateş 2014-10-11 13:45:11 MSD
before I try your solution I download R4 and make clean installation, and immediately install the graphic driver and I see some new options there "Set up the graphical server" ask me first which would I install VESA or Radeon driver and I select Radeon and nothing download just finish the installation before it download additional drivers... and restart system and ok fine now...

Im not sure I did correct things because it finish easily installing driver?

Should I try your suggestion
(In reply to comment #71)
> Serdar,
> 
> Thank you for the probe. Now we are able to fix the issue.
> 
> Please follow these steps to setup hybrid graphics:
> 
> 1) Load your system in VESA graphics mode (add "nomodeset" boot option on
> start).
> 
> 2) Run the following commands:
> 
> sudo amdconfig --initial
> sudo grub2-cfg-mod --del nomodeset
> sudo grub2-cfg-mod --add radeon.modeset=0
> sudo update-grub2
> sudo update-alternatives --set gl_conf /etc/ld.so.conf.d/GL/ati.conf
> 
> And reboot. Your system should start on the fglrx driver. You can check this
> by running the fgl_glxgears program.
> 
> According to the probe: http://hw.rosalinux.ru/index.php?probe=83db4e989c
> 
> Thank you.
Comment 73 Andrey Ponomarenko 2014-10-15 16:57:16 MSD
Serdar,

We have added support for AMD+Intel hybrid graphics in the XFdrake version 115. Just install new version of XFdrake, run it, select "Proprietary (fglrx), setup hybrid graphics" entry and reboot.

More info: http://bugs.rosalinux.ru/show_bug.cgi?id=4522

i586:
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2305490/i586/main/release/

x86_64:
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2305491/x86_64/main/release/

Thank you.
Comment 74 Andrey Ponomarenko 2014-10-15 16:58:57 MSD
In order to test hybrid graphics run fgl_glxgears program.
Comment 75 Serdar Ateş 2014-10-15 23:46:45 MSD
Ohh! Thats the what I need, thank you very much.

This was the missing part of my installation... in the picture before you give me the link there is no proprietary option and I choose just "free (radeon)" but now I have missing option and I install it and I can use 3D graphic needed software without error... Thank you for all,

warm regards...
Comment 76 Serdar Ateş 2014-10-15 23:48:21 MSD
Created attachment 3339 [details]
Choose a driver