Bug 401 - urpm-reposync incorrectly resolves dependencies incorrectly
: urpm-reposync incorrectly resolves dependencies incorrectly
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-19 12:29 MSD by Anton Kirilenko
Modified: 2012-06-29 12:30 MSD (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anton Kirilenko 2012-06-19 12:29:30 MSD
Description of problem:
While resolving dependencies, urpm-reposync resolves  mandriva-release-One in some cases, and  mandriva-release-Flash in others, which conflict.

Version-Release number of selected component:
urpm-tools-2.0-4
Comment 1 Anton Kirilenko 2012-06-19 12:43:06 MSD
advisory: 
1) The dependency resolving in urpm-reposync was strongly remastered, lots of errors disappeared.
2) Added command line options to prevent updating/downgrading kernels.
3) By default reposync tries to save packages even if they are not in the repository anymore
4) If there is a lack of repositories enabled (no repositories for correct architecture) - you will be warned
5) Add DISTEPOCH support to repomanage

https://abf.rosalinux.ru/build_lists/575567

New version of urpm-reposync have been tested a lot privately by the developer itself and by some other people. Urpm-repomanage has some insignificant changes. Other tools were not affected.
Comment 2 Alexander Burmashev 2012-06-19 12:45:32 MSD
In order to publish update to the official repo, the procedure should be changed slightly:

1) Update package in official import git repo ( branch rosa2012lts )
2) Build both archs to the official repo 
3) Paste links to buildlists to the update request
Comment 4 Vladimir Potapov 2012-06-19 15:30:29 MSD
Please, add information for
1) reproduce fixed bugs on current version of ROSA.
2) see new features after update

Vladimir Potapov
QA Team
Comment 5 Anton Kirilenko 2012-06-19 18:19:03 MSD
In fact, the old version of urpm-reposync is a giant bug itself and it's almost useless. The new version of urpm-reposync has about 20% of old code and 80% of new code (it's almost new tool not connected to the old one). This bug report contains only one bug I've met earlier, it have happen some times. I can't reproduce it now (I don't remember the environment), but it does not matter. I don't want to look for bugs in the old dead code anymore.

As a matter of fact, the package in rosa2012lts/main/release is bugged a lot, but the new version contains lots of enchantments and can not be placed to updates... I don't know how to handle the situation. I think, QA may test the new version without comparison to the old one. How to test: execute it with different options, on different systems with different repositories enabled.
Comment 6 Vladimir Potapov 2012-06-20 18:05:05 MSD
Details sent to Anton Kirilenko by e-mail
Comment 7 Alexander Burmashev 2012-06-25 14:02:51 MSD
This package was published without proper QA check due to some bug.