Bug 4007 - grub.d 10_linux swapon: cpmmand not found
: grub.d 10_linux swapon: cpmmand not found
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-04-29 15:43 MSD by Fabiano Kuller
Modified: 2014-05-21 00:24 MSD (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments
grub.d 10_linux swapon: cpmmand not found (168.99 KB, image/png)
2014-04-29 15:43 MSD, Fabiano Kuller
Details
Kcm_grub2 (157.36 KB, image/png)
2014-04-29 17:32 MSD, Fabiano Kuller
Details
failed to activate swap (1.06 MB, image/jpeg)
2014-05-20 22:24 MSD, Fabiano Kuller
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabiano Kuller 2014-04-29 15:43:32 MSD
Created attachment 2862 [details]
grub.d 10_linux swapon: cpmmand not found

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 Alexander Burmashev 2014-04-29 16:02:01 MSD
rpm -qa |grep util-linux
Comment 2 Denis Silakov 2014-04-29 16:38:38 MSD
The thing is that swapon is in /sbin and it seems that grub2 configurator doesn't find it when launched from kcm_grub2. And I am able to reproduce the issue, just change anyghint in kcm_grub2, press "Apply" and in the resulting window press "Details".
Comment 3 Fabiano Kuller 2014-04-29 17:32:22 MSD
Created attachment 2863 [details]
Kcm_grub2
Comment 4 Denis Silakov 2014-05-14 13:46:25 MSD
Ok, I have prepared a fix that should fix the issues. Now 10_linux will launch /sbin/swapon and /sbin/blkid directly.

Advisory:
Fix grub2 configuration scripts to correctly run when launched from kcm-grub2.

Build lists:
https://abf.io/build_lists/1862456
https://abf.io/build_lists/1862457
Comment 5 Vladimir Potapov 2014-05-14 18:21:36 MSD
The update route to extended testing
Comment 6 Vladimir Potapov 2014-05-20 17:35:29 MSD
grub2-2.00-46
http://abf-downloads.rosalinux.ru/rosa2012.1/container/1862456/i586/main/release/
http://abf-downloads.rosalinux.ru/rosa2012.1/container/1862457/x86_64/main/release/
*************************** Advisory *************************
Fix grub2 configuration scripts to correctly run when launched from kcm-grub2.
**************************************************************
QA Verified
Comment 7 Fabiano Kuller 2014-05-20 21:33:43 MSD
(In reply to comment #6)
> grub2-2.00-46
> http://abf-downloads.rosalinux.ru/rosa2012.1/container/1862456/i586/main/
> release/
> http://abf-downloads.rosalinux.ru/rosa2012.1/container/1862457/x86_64/main/
> release/
> *************************** Advisory *************************
> Fix grub2 configuration scripts to correctly run when launched from
> kcm-grub2.
> **************************************************************
> QA Verified



In kcm_grub2 resolved, but the message persists remains in the boot swapon command not found.
Comment 8 Denis Silakov 2014-05-20 22:18:49 MSD
(In reply to comment #7)
> (In reply to comment #6)
> > grub2-2.00-46
> > http://abf-downloads.rosalinux.ru/rosa2012.1/container/1862456/i586/main/
> > release/
> > http://abf-downloads.rosalinux.ru/rosa2012.1/container/1862457/x86_64/main/
> > release/
> > *************************** Advisory *************************
> > Fix grub2 configuration scripts to correctly run when launched from
> > kcm-grub2.
> > **************************************************************
> > QA Verified
> 
> 
> 
> In kcm_grub2 resolved, but the message persists remains in the boot swapon
> command not found.

Hm, sorry, not clear to me - what do you mean under 'boot'? You see some message when your machine boots?
Comment 9 Fabiano Kuller 2014-05-20 22:24:43 MSD
Created attachment 2892 [details]
failed to activate swap

message when my machine boot
Comment 10 Fabiano Kuller 2014-05-20 22:25:48 MSD
(In reply to comment #8)
> (In reply to comment #7)
> > (In reply to comment #6)
> > > grub2-2.00-46
> > > http://abf-downloads.rosalinux.ru/rosa2012.1/container/1862456/i586/main/
> > > release/
> > > http://abf-downloads.rosalinux.ru/rosa2012.1/container/1862457/x86_64/main/
> > > release/
> > > *************************** Advisory *************************
> > > Fix grub2 configuration scripts to correctly run when launched from
> > > kcm-grub2.
> > > **************************************************************
> > > QA Verified
> > 
> > 
> > 
> > In kcm_grub2 resolved, but the message persists remains in the boot swapon
> > command not found.
> 
> Hm, sorry, not clear to me - what do you mean under 'boot'? You see some
> message when your machine boots?

Add screen of the message when your machine boot
Comment 11 Denis Silakov 2014-05-21 00:02:50 MSD
Do you really have swap on /dev/sda3?

Actually this looks like a separate issue; I would suggest to publish a fix from this bug and file a searate bug to proceed with this boot error.
Comment 12 Fabiano Kuller 2014-05-21 00:11:01 MSD
(In reply to comment #11)
> Do you really have swap on /dev/sda3?
> 
> Actually this looks like a separate issue; I would suggest to publish a fix
> from this bug and file a searate bug to proceed with this boot error.

(In reply to comment #11)
> Do you really have swap on /dev/sda3?
> 
> Actually this looks like a separate issue; I would suggest to publish a fix
> from this bug and file a searate bug to proceed with this boot error.



I really swap / dev/sda3, following the result of blkid command will open a new bug

/ dev/sda1: UUID = "2887-EDDC" TYPE = "vfat" PARTUUID = "4504ba7e-6fbf-48e2-bc47-10dbe7dd8624"
/ dev/sda2: UUID = "2cd0100e-823d-44c9-ab96-05728f86b72a" TYPE = "ext4" PARTUUID = "6ebb804b-CB15-41c5-a7c2-5581c9e245c0"
/ dev/sda3: UUID = "a074af23-386f-4f61-9333-8e72ac135077" TYPE = "f57f6fe0-750c-4f34-b55d-d853a2bbdf8a" "swap" PARTUUID =
/ dev/sda4: UUID = "eee4f40d-1f73-49b3-baca-c8b76ab4d553" TYPE = "ext4"

Thanks.