Bug 4004 - There is no printer displayed in the gedit Print dialog
: There is no printer displayed in the gedit Print dialog
Status: RESOLVED DUPLICATE of bug 4635
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-04-27 16:41 MSD by Rolf Pedersen
Modified: 2015-06-16 19:21 MSD (History)
3 users (show)

See Also:
RPM Package: gedit-3.8.3-1.src.rpm
ISO-related:
Bad POT generating:
Upstream:


Attachments
screenshot of gedit print dialog window (136.56 KB, image/png)
2014-04-27 16:41 MSD, Rolf Pedersen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rolf Pedersen 2014-04-27 16:41:54 MSD
Created attachment 2858 [details]
screenshot of gedit print dialog window

My printer is Brother MFC-685CW and I use the Brother Linux drivers for a long time.  In other apps, Seamonkey suite, okular, gwenview, flpsed... printing works.  The print dialog window for gedit shows no printer, no print to file, no printer options, see attached.  I don't see anything in the Preferences, don't know how this came about.  Thanks.
Comment 1 FirstLevel 2014-04-28 13:27:08 MSD
Plase could You provide output of such commands:
cat /etc/release
uname -a
lpq
Comment 2 Rolf Pedersen 2014-04-28 16:16:22 MSD
[rolf@localhost ~]$ cat /etc/release
ROSA Desktop Fresh R2 release 2012.1 for x86_64
[rolf@localhost ~]$ uname -a
Linux localhost.localdomain 3.13.11-nrjQL-desktop-0rosa #1 SMP PREEMPT Thu Apr 24 20:32:04 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
[rolf@localhost ~]$ lpq
MFC685CW is ready
no entries
[rolf@localhost ~]$
Comment 3 FirstLevel 2014-04-28 22:01:40 MSD
Please could You do the such steps:
1. Open konsole from user
2. Start gedit from konsole
3. Press Cttrl-P or Print button
4. Close gedit
5. Give me output from konsole
Comment 4 Rolf Pedersen 2014-04-28 22:59:37 MSD
As you say.  Once gedit opened, I pressed the print icon, which opened the dialog without printer(s).  I closed the dialog, then gedit.  konsole output follows:

[rolf@localhost ~]$ gedit

(gedit:14446): Gtk-WARNING **: Theme parsing error: menu.css:88:11: '' is not a valid color name

(gedit:14446): Gtk-WARNING **: Theme parsing error: menu.css:93:11: '' is not a valid color name
GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.

** (gedit:14446): WARNING **: Could not load Peas repository: Typelib file for namespace 'Peas', version '1.0' not found

** (gedit:14446): WARNING **: Could not load PeasGtk repository: Typelib file for namespace 'PeasGtk', version '1.0' not found

** (gedit:14446): WARNING **: Could not load theme icon user-bookmarks-symbolic: Icon 'user-bookmarks-symbolic' not present in theme

** (gedit:14446): WARNING **: Could not load theme icon user-home-symbolic: Icon 'user-home-symbolic' not present in theme

** (gedit:14446): WARNING **: Could not load theme icon drive-harddisk-symbolic: Icon 'drive-harddisk-symbolic' not present in theme
[rolf@localhost ~]$
Comment 5 FirstLevel 2014-05-30 14:32:01 MSD
The problem is actual for ROSA 2012.1 Fresh R3.
I have also tested Fedora 20: gedit see the installed printer.
Comment 6 Rolf Pedersen 2014-08-18 06:50:51 MSD
$ cat /etc/release 
ROSA release 2012.0 (LTS) for x86_64

I made a new installation from ROSA.MARATHON.X1.EE.x86_64.iso, re-using /home and various other data partitions.  Now, gedit-2.30.4-2.1-rosa.lts2012.0.x86_64 shows a proper print dialog and prints from my printer.
Comment 7 FirstLevel 2015-04-17 12:16:17 MSD
Case is actual for Fresh R5 and RED X2
Comment 8 Denis Silakov 2015-06-16 19:21:44 MSD

*** This bug has been marked as a duplicate of bug 4635 ***