Bug 3986 - firefox was updated to correctly apply default settings [UPDATE REQUEST]
: firefox was updated to correctly apply default settings [UPDATE REQUEST]
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-04-21 10:41 MSD by Alexander Burmashev
Modified: 2014-04-21 14:25 MSD (History)
1 user (show)

See Also:
RPM Package: firefox
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Burmashev 2014-04-21 10:41:43 MSD
firefox was updated to correctly apply default settings
Comment 1 Alexander Burmashev 2014-04-21 10:46:05 MSD
Our latest firefox was not applying our default settings. I fixed it.

Advisory:
In order to adress issue with applying default settings i moved all config settings firefoxlibdir/firefox.cfg.

Buildlists:
https://abf.rosalinux.ru/build_lists/1798894
https://abf.rosalinux.ru/build_lists/1798893


Additional info:
to test run old firefox WITHOUT default settings ( remove .mozilla  from your home dir ) and check default behaviour ( start page and firstrun ). Then remove .mozilla from your home dir, update to new firefox and run it. It should be started with a proper start page and without first run page.
IMPORTANT: This changes can be easily seen only on FF first run. Do not forget to remove .mozilla dir before starting or test from new user each time. Please also note that .mozilla dir contains all user data, including bookmarks and stored passwords.
Comment 2 Vladimir Potapov 2014-04-21 14:22:47 MSD
firefox-28.0-2
http://abf-downloads.rosalinux.ru/rosa2012.1/container/1798893/i586/main/release/
http://abf-downloads.rosalinux.ru/rosa2012.1/container/1798894/x86_64/main/release/
*************************** Advisory *************************
In order to adress issue with applying default settings i moved all config settings firefoxlibdir/firefox.cfg
**************************************************************
QA Verified