Bug 3971 - [UPDATE REQUEST] kdegames4
: [UPDATE REQUEST] kdegames4
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-04-15 19:10 MSD by Arkady L. Shane
Modified: 2014-04-24 11:36 MSD (History)
5 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
alexander.petryakov: qa_verified+
kuzma.kazygashev: secteam_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arkady L. Shane 2014-04-15 19:10:00 MSD
Advisory:

Added depend to kajongg:

Requires: kmahjongglib = %{epoch}:%{version}-%{release}

For i586 I think that is a test bug, it should install successfully.

Buildlists:
https://abf.rosalinux.ru/build_lists/1792762
https://abf.rosalinux.ru/build_lists/1792763
Comment 1 Vladimir Potapov 2014-04-17 18:57:01 MSD
Arkady, kajongg work without update. What is bug?
Comment 2 Alexander Petryakov 2014-04-18 02:30:35 MSD
After update I am got error:
$ kajongg
started the local kajongg server: pid=30450 kajonggserver --local --db=/home/sasha/.kde4/share/apps/kajongg/local.db
local server listening on UNIX socket /home/sasha/.kajonggserver/socket
calling kajongg server on UNIX socket /home/sasha/.kajonggserver/socket: Query: variant type None not implemented for field max(id)
Comment 3 Arkady L. Shane 2014-04-21 13:15:34 MSD
(In reply to comment #1)
> Arkady, kajongg work without update. What is bug?

kajongg does not start without kmahjongglib


(In reply to comment #2)
> After update I am got error:
> $ kajongg
> started the local kajongg server: pid=30450 kajonggserver --local
> --db=/home/sasha/.kde4/share/apps/kajongg/local.db
> local server listening on UNIX socket /home/sasha/.kajonggserver/socket
> calling kajongg server on UNIX socket /home/sasha/.kajonggserver/socket:
> Query: variant type None not implemented for field max(id)

Hm. I have not get these messages. Does kajongg work?
Comment 4 Alexander Petryakov 2014-04-22 00:24:36 MSD
Yes, kajongg has started. Then I pressed button "Play" and got error.
Comment 5 Arkady L. Shane 2014-04-22 15:02:17 MSD
Ok. This is issue with new databases. Fixed in these builds:

https://abf.rosalinux.ru/build_lists/1800244
https://abf.rosalinux.ru/build_lists/1800245
Comment 6 Alexander Petryakov 2014-04-24 01:18:16 MSD
kajongg
https://abf.rosalinux.ru/build_lists/1800244
https://abf.rosalinux.ru/build_lists/1800245
************** Advisory **************
Added depend to kajongg:

Requires: kmahjongglib = %{epoch}:%{version}-%{release}
**************************************
QA Verified