Bug 3940 - [UPDATE REQUEST] qt5 5.0.2 -> 5.2.1
: [UPDATE REQUEST] qt5 5.0.2 -> 5.2.1
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-04-07 17:56 MSD by Andrey Bondrov
Modified: 2014-04-11 09:51 MSD (History)
2 users (show)

See Also:
RPM Package: qt5
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
andrey.bondrov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Bondrov 2014-04-07 17:56:25 MSD
We need to update Qt5 in Marathon.
Comment 1 Andrey Bondrov 2014-04-07 18:48:17 MSD
Advisory: "New version 5.2.1"

https://abf.rosalinux.ru/build_lists/1747760
https://abf.rosalinux.ru/build_lists/1747761

Also requires xkbcomp update (sync it with 2012.1):
https://abf.rosalinux.ru/build_lists/1747677
https://abf.rosalinux.ru/build_lists/1747678

P.S. This update is important for Chrome distro development.
Comment 2 Vladimir Potapov 2014-04-08 16:43:20 MSD
The update route to extended testing
Comment 3 Postnikov Dmitry 2014-04-10 02:30:53 MSD
1. After install qt5-designer and reboot, i at the start of any browser is switched off the network, and in log "kernel r8169 0000:03:0.0: eth0: link up"
Helped only reboot and not start any browser.
If i "systemctl restart NetworkManager.service", then not work dhclient.

2. In qt5-designer start path "/usr/lib64/qt5/bin/designer", but in rosa-designer-qt5.desktop file "Exec=/usr/lib/bin/designer" and "TryExec=/usr/lib/bin/designer".
This only in 64bit version.
If i manual from konsole start from /usr/lib64/bin/designer - all normal work.

3. After install qt5-designer SimpleWelcome not show Icon. And don't search on Alt+F2.
Comment 4 Vladimir Potapov 2014-04-10 03:18:34 MSD
(In reply to comment #3)
> 1. After install qt5-designer and reboot, i at the start of any browser is
> switched off the network, and in log "kernel r8169 0000:03:0.0: eth0: link
> up"
> Helped only reboot and not start any browser.
> If i "systemctl restart NetworkManager.service", then not work dhclient.
> 
> 2. In qt5-designer start path "/usr/lib64/qt5/bin/designer", but in
> rosa-designer-qt5.desktop file "Exec=/usr/lib/bin/designer" and
> "TryExec=/usr/lib/bin/designer".
> This only in 64bit version.
> If i manual from konsole start from /usr/lib64/bin/designer - all normal
> work.
> 
> 3. After install qt5-designer SimpleWelcome not show Icon. And don't search
> on Alt+F2.

Hm. Do rollback the system restore it?
Comment 5 Postnikov Dmitry 2014-04-10 10:31:38 MSD
(In reply to comment #4)
> (In reply to comment #3)
> > 1. After install qt5-designer and reboot, i at the start of any browser is

> Hm. Do rollback the system restore it?

Why? What does it mean? Anyway to fix designer necessary, because the startup path is not correct, and no icons.
I will try.
Comment 6 Postnikov Dmitry 2014-04-10 10:44:00 MSD
I delete qt5-designer and dep-pkg, and all normal work. So still a problem in qt5.
Comment 7 Vladimir Potapov 2014-04-10 12:45:54 MSD
Hm. Only rosa-imagewriter use qt5 in Marathon... It's regression? If you install old qt5-designer, the bug exist?
Comment 8 Postnikov Dmitry 2014-04-10 13:12:19 MSD
(In reply to comment #7)
> Hm. Only rosa-imagewriter use qt5 in Marathon... It's regression? If you
> install old qt5-designer, the bug exist?

With old qt5 is OK.
It is regression in new qt5.
Comment 9 Postnikov Dmitry 2014-04-10 15:14:21 MSD
Changed the system and everything works fine. Reinstall qt5 several times. All works. Strange, apparently was a glitch I have, local.
Comment 10 Andrey Bondrov 2014-04-10 15:44:02 MSD
Build lists with fixed .desktop files are coming very soon, perhaps in a hour.
Comment 11 Andrey Bondrov 2014-04-10 16:31:14 MSD
(In reply to comment #10)
> Build lists with fixed .desktop files are coming very soon, perhaps in a
> hour.

https://abf.rosalinux.ru/build_lists/1787062
https://abf.rosalinux.ru/build_lists/1787063
Comment 12 Postnikov Dmitry 2014-04-10 19:23:23 MSD
(In reply to comment #11)
> (In reply to comment #10)
> > Build lists with fixed .desktop files are coming very soon, perhaps in a
> > hour.
> 
> https://abf.rosalinux.ru/build_lists/1787062
> https://abf.rosalinux.ru/build_lists/1787063

All work OK. No problem.
Comment 13 Vladimir Potapov 2014-04-11 03:32:34 MSD
qt5-5.2.1-2
http://abf-downloads.rosalinux.ru/rosa2012lts/container/1787063/x86_64/contrib/release/
http://abf-downloads.rosalinux.ru/rosa2012lts/container/1787063/x86_64/contrib/release/

xkbcomp-1.2.4-2
http://abf-downloads.rosalinux.ru/rosa2012lts/container/1747677/i586/main/release/
http://abf-downloads.rosalinux.ru/rosa2012lts/container/1747678/x86_64/main/release/
********************** Advisory **************************
New version 5.2.1.  Also requires xkbcomp update (sync it with 2012.1)
**********************************************************
QA Verified