Bug 3912 - [UPDATE REQUEST] ModemManager 1.0.0 -> 1.2.0
: [UPDATE REQUEST] ModemManager 1.0.0 -> 1.2.0
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-04-01 12:56 MSD by Andrey Bondrov
Modified: 2014-04-03 12:45 MSD (History)
4 users (show)

See Also:
RPM Package: modemmanager
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments
mm1-old.txt (9.98 KB, text/plain)
2014-04-01 23:36 MSD, Postnikov Dmitry
Details
mm1-new.txt (10.37 KB, text/plain)
2014-04-01 23:37 MSD, Postnikov Dmitry
Details
mm1-new-connect.txt (5.50 KB, text/plain)
2014-04-01 23:38 MSD, Postnikov Dmitry
Details
mm2-new.txt (10.17 KB, text/plain)
2014-04-02 11:53 MSD, Postnikov Dmitry
Details
mm2-new-connect.txt (13.06 KB, text/plain)
2014-04-02 11:55 MSD, Postnikov Dmitry
Details
lsusb-v.txt (6.01 KB, text/plain)
2014-04-03 09:13 MSD, FirstLevel
Details
new-mm-plug-modem.txt (5.72 KB, text/plain)
2014-04-03 09:14 MSD, FirstLevel
Details
new-mm-second-connect-to-bee-unsuccessfull.txt (7.97 KB, text/plain)
2014-04-03 09:14 MSD, FirstLevel
Details
new-mm-setup-connect-to-bee-first-time.txt (12.01 KB, text/plain)
2014-04-03 09:14 MSD, FirstLevel
Details
new-mm-unplug-and-plug-again-and-connect-to-bee.txt (21.00 KB, text/plain)
2014-04-03 09:15 MSD, FirstLevel
Details
plug-modem-old-mm.txt (6.09 KB, text/plain)
2014-04-03 09:15 MSD, FirstLevel
Details
second-connect-to-bee-unsuccessfull-old-mm.txt (7.83 KB, text/plain)
2014-04-03 09:15 MSD, FirstLevel
Details
setup-modem-and-connect-to-bee-old-mm.txt (13.68 KB, text/plain)
2014-04-03 09:16 MSD, FirstLevel
Details
unplug-and-plug-modem-again-and-connect-old-mm.txt (19.21 KB, text/plain)
2014-04-03 09:16 MSD, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Bondrov 2014-04-01 12:56:12 MSD
New version of ModemManager was released.
Comment 2 Postnikov Dmitry 2014-04-01 23:36:43 MSD
Created attachment 2748 [details]
mm1-old.txt

This part log where i insert modem with OLD modemmanager.
Comment 3 Postnikov Dmitry 2014-04-01 23:37:19 MSD
Created attachment 2749 [details]
mm1-new.txt

This part log where i insert modem with NEW modemmanager.
Comment 4 Postnikov Dmitry 2014-04-01 23:38:06 MSD
Created attachment 2750 [details]
mm1-new-connect.txt

This part log where i connect modem with NEW modemmanager. Connection failed.
Comment 5 Andrey Bondrov 2014-04-02 02:07:53 MSD
Can you please check if you have new qmi-tools package installed? I guess it's not because I see:

error spawning qmi-proxy: Failed to execute child process "/usr/lib64/qmi-proxy" (No such file or directory)
Comment 6 Postnikov Dmitry 2014-04-02 11:53:10 MSD
Created attachment 2751 [details]
mm2-new.txt

I manual install qmi-tools and insert modem. This part log where i insert modem.
Comment 7 Postnikov Dmitry 2014-04-02 11:55:32 MSD
Created attachment 2752 [details]
mm2-new-connect.txt

This part log where i connect modem with gsm operator.
All work OK. No problem.

But we must make qmi-tools was set automatically when you update modemmanager.
Comment 8 Andrey Bondrov 2014-04-02 12:37:39 MSD
New build lists for MM (added qmi-tools to Requires):

https://abf.rosalinux.ru/build_lists/1733057
https://abf.rosalinux.ru/build_lists/1733058

For libqmi and libmbim old build lists are fine.
Comment 9 FirstLevel 2014-04-02 22:19:48 MSD
(In reply to comment #8)
> New build lists for MM (added qmi-tools to Requires):
> 
> https://abf.rosalinux.ru/build_lists/1733057
> https://abf.rosalinux.ru/build_lists/1733058
> 
> For libqmi and libmbim old build lists are fine.

I have tried to install new modemmanager (from this container) but an error occured during the update
[root@fresh64 ~]# urpmi --auto-update
источник «main» уже обновлён
источник «main updates» уже обновлён
источник «Main32» уже обновлён
источник «Main32 Updates» уже обновлён
источник «contrib» уже обновлён
источник «contrib updates» уже обновлён
источник «non-free» уже обновлён
источник «non-free updates» уже обновлён
источник «Non-free32» уже обновлён
источник «Non-free32 Updates» уже обновлён
источник «restricted» уже обновлён
источник «restricted updates» уже обновлён
источник «Restricted32» уже обновлён
источник «Restricted32 Updates» уже обновлён
источник «3912» уже обновлён
Пакеты lib64gio2.0_0-2.36.3-4-rosa2012.1.x86_64, lib64gobject2.0_0-2.36.3-4-rosa2012.1.x86_64, lib64glib2.0_0-2.36.3-4-rosa2012.1.x86_64, glibc-2.15-8-rosa2012.1.x86_64, systemd-208-28-rosa2012.1.x86_64, lib64gudev1.0_0-208-28-rosa2012.1.x86_64 уже установлен
Не удаётся установить запрошенный пакет:
modemmanager-1.2.0-3-rosa2012.1.x86_64 (из-за неудовлетворённости libqmi-glib.so.1()(64bit))
Продолжить установку? (Y/n)
Comment 10 Postnikov Dmitry 2014-04-02 23:38:44 MSD
(In reply to comment #9)
> (In reply to comment #8)
> > New build lists for MM (added qmi-tools to Requires):
> > 
> > https://abf.rosalinux.ru/build_lists/1733057
> > https://abf.rosalinux.ru/build_lists/1733058
> > 
> > For libqmi and libmbim old build lists are fine.
> 
> I have tried to install new modemmanager (from this container) but an error
> occured during the update
> [root@fresh64 ~]# urpmi --auto-update
> источник «main» уже обновлён
> источник «main updates» уже обновлён
> источник «Main32» уже обновлён
> источник «Main32 Updates» уже обновлён
> источник «contrib» уже обновлён
> источник «contrib updates» уже обновлён
> источник «non-free» уже обновлён
> источник «non-free updates» уже обновлён
> источник «Non-free32» уже обновлён
> источник «Non-free32 Updates» уже обновлён
> источник «restricted» уже обновлён
> источник «restricted updates» уже обновлён
> источник «Restricted32» уже обновлён
> источник «Restricted32 Updates» уже обновлён
> источник «3912» уже обновлён
> Пакеты lib64gio2.0_0-2.36.3-4-rosa2012.1.x86_64,
> lib64gobject2.0_0-2.36.3-4-rosa2012.1.x86_64,
> lib64glib2.0_0-2.36.3-4-rosa2012.1.x86_64, glibc-2.15-8-rosa2012.1.x86_64,
> systemd-208-28-rosa2012.1.x86_64, lib64gudev1.0_0-208-28-rosa2012.1.x86_64
> уже установлен
> Не удаётся установить запрошенный пакет:
> modemmanager-1.2.0-3-rosa2012.1.x86_64 (из-за неудовлетворённости
> libqmi-glib.so.1()(64bit))
> Продолжить установку? (Y/n)

You need add container "libqmi" and "libmbim" from Comment 1.
And try update.
Comment 11 FirstLevel 2014-04-03 09:13:10 MSD
Ok. My experiments with ZTE MF 180 with Beeline.
lsusb -v for my modem lsusb-v.txt

OLD ModemManager.
1. Plug modem - plug-modem-old-mm.txt
2. Set up connection and firts dial in to bee - setup-modem-and-connect-to-bee-old-mm.txt
First connect - is successfull
3. I diconnect (not unplug) and try to connect second time - second-connect-to-bee-unsuccessfull-old-mm.txt
Second and other attempts is unsuccessfull without unplug modem.
4. I have unplug modem, plug it again and connect to bee - unplug-and-plug-modem-again-and-connect-old-mm.txt
This attempt is succesfull


NEW ModemManager
1. Plug modem - new-mm-plug-modem.txt
2. Set up and connect to bee - new-mm-setup-connect-to-bee-first-time.txt
First connect - is successfull
3. I diconnect (not unplug) and try to connect second time - new-mm-second-connect-to-bee-unsuccessfull.txt
Second and other attempts is unsuccesfull without unplug modem.
4. I have unplug modem, plug it again and connect to bee  - new-mm-unplug-and-plug-again-and-connect-to-bee.txt
This attempt is succesfull

No changes for my modem with new modem manager
Comment 12 FirstLevel 2014-04-03 09:13:30 MSD
Created attachment 2754 [details]
lsusb-v.txt
Comment 13 FirstLevel 2014-04-03 09:14:09 MSD
Created attachment 2755 [details]
new-mm-plug-modem.txt
Comment 14 FirstLevel 2014-04-03 09:14:30 MSD
Created attachment 2756 [details]
new-mm-second-connect-to-bee-unsuccessfull.txt
Comment 15 FirstLevel 2014-04-03 09:14:52 MSD
Created attachment 2757 [details]
new-mm-setup-connect-to-bee-first-time.txt
Comment 16 FirstLevel 2014-04-03 09:15:13 MSD
Created attachment 2758 [details]
new-mm-unplug-and-plug-again-and-connect-to-bee.txt
Comment 17 FirstLevel 2014-04-03 09:15:32 MSD
Created attachment 2759 [details]
plug-modem-old-mm.txt
Comment 18 FirstLevel 2014-04-03 09:15:50 MSD
Created attachment 2760 [details]
second-connect-to-bee-unsuccessfull-old-mm.txt
Comment 19 FirstLevel 2014-04-03 09:16:08 MSD
Created attachment 2761 [details]
setup-modem-and-connect-to-bee-old-mm.txt
Comment 20 FirstLevel 2014-04-03 09:16:26 MSD
Created attachment 2762 [details]
unplug-and-plug-modem-again-and-connect-old-mm.txt
Comment 21 Andrey Bondrov 2014-04-03 10:38:45 MSD
(In reply to comment #11)
> No changes for my modem with new modem manager

Well, no regressions then. It's fine for now.