Bug 3890 - [UPDATE REQUEST] networkmanager 0.9.8.2 -> 0.9.8.8
: [UPDATE REQUEST] networkmanager 0.9.8.2 -> 0.9.8.8
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-29 10:46 MSK by Andrey Bondrov
Modified: 2014-04-01 12:04 MSD (History)
3 users (show)

See Also:
RPM Package: networkmanager
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments
dd9.png (214.27 KB, image/png)
2014-03-30 14:57 MSD, Postnikov Dmitry
Details
dd10.png (175.82 KB, image/png)
2014-03-30 15:23 MSD, Postnikov Dmitry
Details
dd11.png (355.64 KB, image/png)
2014-03-30 15:26 MSD, Postnikov Dmitry
Details
dd12.png (201.10 KB, image/png)
2014-03-30 23:44 MSD, Postnikov Dmitry
Details
dd14.png (320.13 KB, image/png)
2014-03-30 23:58 MSD, Postnikov Dmitry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Bondrov 2014-03-29 10:46:08 MSK
New version of NetworkManager was released, it's needed for Plasma-NM update.
Comment 1 Andrey Bondrov 2014-03-29 10:46:48 MSK
Advisory: "New bugfix version 0.9.8.8"

https://abf.rosalinux.ru/build_lists/1726475
https://abf.rosalinux.ru/build_lists/1726476
Comment 2 Vladimir Potapov 2014-03-29 12:33:05 MSK
The update route to extended testing
Comment 3 Postnikov Dmitry 2014-03-30 11:43:53 MSD
I see new line in log:
===============
[root@mindlife-k64 pastordi]# journalctl -a | grep CONNECT
марта 30 11:20:35 mindlife-k64 NetworkManager[4395]: <info> NetworkManager state is now CONNECTING
марта 30 11:20:37 mindlife-k64 NetworkManager[4395]: <info> NetworkManager state is now CONNECTED_GLOBAL
марта 30 11:26:57 mindlife-k64 NetworkManager[10214]: <info> NetworkManager state is now CONNECTING
марта 30 11:26:58 mindlife-k64 NetworkManager[10214]: <info> NetworkManager state is now CONNECTED_GLOBAL
[root@mindlife-k64 pastordi]#
==============

Do CONNECTING_GLOBAL and CONNECTING is this name variable? Maybe want to display value of a variable?
Comment 4 Andrey Bondrov 2014-03-30 12:08:24 MSD
(In reply to comment #3)
> I see new line in log:
> ===============
> Do CONNECTING_GLOBAL and CONNECTING is this name variable? Maybe want to
> display value of a variable?

I guess they are already values. The variable is state. So it's fine already.
Comment 5 Postnikov Dmitry 2014-03-30 14:57:36 MSD
Created attachment 2740 [details]
dd9.png

When I put a static IP address/DNS/Gateway in NM is written, "No gateway".
This NO regression, but ugly.
Comment 6 Postnikov Dmitry 2014-03-30 15:19:22 MSD
I checked work:

1. With static and dynamic IP/DNS/gatway addresses LAN+WLAN
2. With enable/disable LAN+WLAN
3. With sleep LAN+WLAN
4. With restart NM service
5. With nmcli/nm-tool

All this work OK.

But! Work with WWAN bad.
Comment 7 Postnikov Dmitry 2014-03-30 15:23:58 MSD
Created attachment 2741 [details]
dd10.png

6. WWAN don't automatically seach gsm network
7. Only manual mod connected. Then i  crean in NM new WWAN profile gsm operator.
8. After manual connected, in NM show no correct data. (Correct only IP & Gataway)
Comment 8 Postnikov Dmitry 2014-03-30 15:26:20 MSD
Created attachment 2742 [details]
dd11.png

9. Also in general display NM connected status is correct, but in details status not correct. (See p.8)
Comment 9 Andrey Bondrov 2014-03-30 17:08:23 MSD
Looks like all this stuff is related to knetworkmanager. As we plan to switch to plasma-nm very soon (maybe for R3), perhaps we shouldn't care much about obsolete knetworkmanager.
Comment 10 Postnikov Dmitry 2014-03-30 18:28:15 MSD
(In reply to comment #9)
> Looks like all this stuff is related to knetworkmanager. As we plan to
> switch to plasma-nm very soon (maybe for R3), perhaps we shouldn't care much
> about obsolete knetworkmanager.

Then we have to make a radical decision: remove KNetworkManager and tested Plasma-nm together with NetworkManager. I honestly haven't even seen Plasma-nm.
Comment 11 Andrey Bondrov 2014-03-30 20:23:31 MSD
(In reply to comment #10)
> (In reply to comment #9)
> Then we have to make a radical decision: remove KNetworkManager and tested
> Plasma-nm together with NetworkManager. I honestly haven't even seen
> Plasma-nm.

Plasma-nm got a major update some time ago and new version requires new NetworkManager, that's why I started this NM update at all. 

So _if_ there are no regressions (or only very minor ones), just known old ugly behaviour, we better push this update to make work on plasma-nm migration easier.
Comment 12 Postnikov Dmitry 2014-03-30 20:45:35 MSD
(In reply to comment #11)
> (In reply to comment #10)
> > (In reply to comment #9)
> > Then we have to make a radical decision: remove KNetworkManager and tested
> > Plasma-nm together with NetworkManager. I honestly haven't even seen
> > Plasma-nm.
> 
> Plasma-nm got a major update some time ago and new version requires new
> NetworkManager, that's why I started this NM update at all. 
> 
> So _if_ there are no regressions (or only very minor ones), just known old
> ugly behaviour, we better push this update to make work on plasma-nm
> migration easier.

Regression only one, in comment 7 p.6
Comment 13 Andrey Bondrov 2014-03-30 20:55:08 MSD
(In reply to comment #12)
> > So _if_ there are no regressions (or only very minor ones), just known old
> > ugly behaviour, we better push this update to make work on plasma-nm
> > migration easier.
> 
> Regression only one, in comment 7 p.6

Meanwhile I found that Akdengi pushed latest knetworkmanager update to git but not to Main/Updates.

I tried to build it with latest NM, please test if it works better:

https://abf.rosalinux.ru/build_lists/1727138
https://abf.rosalinux.ru/build_lists/1727139
Comment 14 Postnikov Dmitry 2014-03-30 23:44:41 MSD
Created attachment 2743 [details]
dd12.png

(In reply to comment #13)
> (In reply to comment #12)
> > > So _if_ there are no regressions (or only very minor ones), just known old
> > > ugly behaviour, we better push this update to make work on plasma-nm
> > > migration easier.
> > 
> > Regression only one, in comment 7 p.6
> 
> Meanwhile I found that Akdengi pushed latest knetworkmanager update to git
> but not to Main/Updates.
> 
> I tried to build it with latest NM, please test if it works better:
> 
> https://abf.rosalinux.ru/build_lists/1727138
> https://abf.rosalinux.ru/build_lists/1727139


No! even worse displaying data became in LAN and WLAN.
Comment 15 Postnikov Dmitry 2014-03-30 23:58:59 MSD
Created attachment 2744 [details]
dd14.png

In WWAN connected automatically search gsm operator, but also stat data is bad.
Comment 16 Andrey Bondrov 2014-03-31 02:24:12 MSD
Maybe ModemManager update will make things better, I'll try it little later.
Comment 17 Andrey Bondrov 2014-03-31 08:40:36 MSD
Let's see if ModemManager update helps.

libqmi:
https://abf.rosalinux.ru/build_lists/1727333
https://abf.rosalinux.ru/build_lists/1727334

ModemManager:
https://abf.rosalinux.ru/build_lists/1727339
https://abf.rosalinux.ru/build_lists/1727340

If this update doesn't help itself, we'll try to rebuild new NetworkManager against new ModemManager.
Comment 18 Vladimir Potapov 2014-03-31 10:29:12 MSD
(In reply to comment #17)
> Let's see if ModemManager update helps.
> 
> libqmi:
> https://abf.rosalinux.ru/build_lists/1727333
> https://abf.rosalinux.ru/build_lists/1727334
As I see, the package not exists in repo and don't set up as update
Comment 19 Vladimir Potapov 2014-03-31 10:31:14 MSD
(In reply to comment #18)
> (In reply to comment #17)
> > Let's see if ModemManager update helps.
> > 
> > libqmi:
> > https://abf.rosalinux.ru/build_lists/1727333
> > https://abf.rosalinux.ru/build_lists/1727334
> As I see, the package not exists in repo and don't set up as update
P.S. Sorry, it's linked to MM
Comment 20 Andrey Bondrov 2014-03-31 11:01:22 MSD
BTW, if new MM works fine with old NM, we can publish it before issues with new NM are resolved. This will make things little easier.
Comment 21 Postnikov Dmitry 2014-04-01 00:35:24 MSD
In General the final verdict:
1. I'am reinstal NEW NM and all work, including WWAN
2. I'am reinstal new system with new NM. All work with WWAN.

Apparently when first test was some glitch NM.

Leave only new NM:
> https://abf.rosalinux.ru/build_lists/1726475
> https://abf.rosalinux.ru/build_lists/1726476
Comment 22 Andrey Bondrov 2014-04-01 02:22:58 MSD
Can we publish everything then? I mean NM, MM and KNM updates?
Comment 23 Postnikov Dmitry 2014-04-01 10:20:36 MSD
(In reply to comment #22)
> Can we publish everything then? I mean NM, MM and KNM updates?

Publish ONLY the NetworkManager from there:

> https://abf.rosalinux.ru/build_lists/1726475
> https://abf.rosalinux.ru/build_lists/1726476
Comment 24 Vladimir Potapov 2014-04-01 10:34:05 MSD
networkmanager-0.9.8.8-1
http://abf-downloads.rosalinux.ru/rosa2012.1/container/1726475/i586/main/release/
http://abf-downloads.rosalinux.ru/rosa2012.1/container/1726476/x86_64/main/release/
************************ Advisory ************************
New bugfix version 0.9.8.8
**********************************************************
QA Verified
Comment 25 Andrey Bondrov 2014-04-01 11:59:55 MSD
(In reply to comment #23)
> (In reply to comment #22)
> > Can we publish everything then? I mean NM, MM and KNM updates?
> 
> Publish ONLY the NetworkManager from there:

Can you please check other packages then? Especially ModemManager update.
Comment 26 Postnikov Dmitry 2014-04-01 12:04:22 MSD
(In reply to comment #25)
> (In reply to comment #23)
> > (In reply to comment #22)
> > > Can we publish everything then? I mean NM, MM and KNM updates?
> > 
> > Publish ONLY the NetworkManager from there:
> 
> Can you please check other packages then? Especially ModemManager update.

New ModemManager don't work with new NM and with old NM. ModemManager can't connect to gsm operator. OLD ModemManager work OK with any NM.