Bug 3880 - lightdm 1.8.5 accept any password as correct
: lightdm 1.8.5 accept any password as correct
Status: RESOLVED INVALID
Product: Desktop Bugs
Classification: ROSA Desktop
Component: LXDE Edition
: Fresh
: All Linux
: Highest critical
: ---
Assigned To: Aleksandr Kazantcev
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-26 13:29 MSK by Eugene Budanov
Modified: 2014-04-04 18:17 MSD (History)
1 user (show)

See Also:
RPM Package: lightdm-1.8.5-4
ISO-related:
Bad POT generating:
Upstream:


Attachments
Journal log (4.62 KB, application/octet-stream)
2014-03-26 19:28 MSK, Eugene Budanov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Budanov 2014-03-26 13:29:16 MSK
Yesterday I found that LightDM accept any password as correct and allow to login in system.
Comment 1 Eugene Budanov 2014-03-26 19:28:20 MSK
Created attachment 2730 [details]
Journal log
Comment 2 Alexander Burmashev 2014-04-03 18:26:26 MSD
i was able to reproduce the issue and built new lightd to contrib.
Since package is from contrib i take a risk to mark this bug resolved fixed, feel free to reopen it, in case problem is not gone.
Comment 3 Eugene Budanov 2014-04-04 17:39:25 MSD
Fix not work for me, same problem after updating LightDM.
Comment 4 Alexander Burmashev 2014-04-04 17:46:03 MSD
attach please your /etc/pam.d/lightdm
Comment 5 Eugene Budanov 2014-04-04 18:17:28 MSD
/etc/pam.d/lightdm
#%PAM-1.0
auth       required    pam_env.so
auth       required    pam_permit.so
account    required    pam_nologin.so
account    include     system-auth
password   include     system-auth
session    required    pam_loginuid.so
session    optional    pam_console.so
session    optional    pam_keyinit.so force revoke
session    required    pam_namespace.so
session    include     system-auth