Bug 3878 - Latest update for pulseaudio (5.0) make KDE always crash
: Latest update for pulseaudio (5.0) make KDE always crash
Status: RESOLVED WONTFIX
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: High critical
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-25 22:35 MSK by Giovanni Mariani
Modified: 2014-06-24 18:58 MSD (History)
2 users (show)

See Also:
RPM Package: pulseaudio-5.0-2.src.rpm
ISO-related:
Bad POT generating:
Upstream:


Attachments
Snippet fro system log after a crash (1.19 KB, text/plain)
2014-03-25 22:40 MSK, Giovanni Mariani
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Giovanni Mariani 2014-03-25 22:35:56 MSK
Description of problem:
I'm booting the PC in text mode (the old init3) and running KDE from the command-line with "startx".
After updating pulseaudio to the latest version from main/updates, I'm no more able to launch KDE: every time I get an error message about ksmserver and a return to the text prompt. There are always 3 core files in the user home dir.
In .xsession-errors there are some lines about kded crash.

Renaming the .kde4 dir does not help, nor using a fresh new user.

Reinstalling the old pulseaudio packages (thanks urpmi.recover) solves the problem.

Version-Release number of selected component (if applicable):
pulseaudio-5.0-2

How reproducible:
Always

Steps to Reproduce:
1. Boot in text console
2. Launch KDE
3. Update pulseaudio to the new release
4. Restart KDE
5. Watch the splash screen appears and then KDE stop and return to the textual login prompt.
Comment 1 Giovanni Mariani 2014-03-25 22:40:39 MSK
Created attachment 2729 [details]
Snippet fro system log after a crash

The crash appears to be in kdeinit4.
Comment 2 Postnikov Dmitry 2014-03-26 15:13:12 MSK
Now "startx" is OLD command. In Rosa uses systemd. 
Try command: systemctl start kdm
Comment 3 Giovanni Mariani 2014-03-26 18:20:12 MSK
(In reply to comment #2)
> Now "startx" is OLD command. In Rosa uses systemd. 
> Try command: systemctl start kdm
Thank you for the advice...
I will try this way

However, I would argue that a such change in the distro behavior needs to be prominently announced, because the combo "init3 + startx" is not really a rare one. Otherwise the users could be end up with a non-working setup and no clue about why that is happening or about how to fix it...
Comment 4 Andrey Bondrov 2014-03-27 08:12:20 MSK
(In reply to comment #0)
> Reinstalling the old pulseaudio packages (thanks urpmi.recover) solves the
> problem.

I suggest to get old SRPMs and try to update them to 5.0 yourself. Maybe new version of pulseaudio package has more changes then just tarball update. Unfortunately, PulseAudio maintainer no longer works for ROSA since this week, so I cannot even ask him what and why he did. So someone should investigate it.
Comment 5 Giovanni Mariani 2014-03-27 13:32:51 MSK
(In reply to comment #4)
> (In reply to comment #0)
> > Reinstalling the old pulseaudio packages (thanks urpmi.recover) solves the
> > problem.
> 
> I suggest to get old SRPMs and try to update them to 5.0 yourself. Maybe new
> version of pulseaudio package has more changes then just tarball update.
> Unfortunately, PulseAudio maintainer no longer works for ROSA since this
> week, so I cannot even ask him what and why he did. So someone should
> investigate it.

It was the next item in my TODO list...
and already I gave a quick look at the new srpm to find the differences.
When I will have the time, I will do it.
Stay tuned.
Comment 6 Giovanni Mariani 2014-06-24 18:58:57 MSD
(In reply to comment #5)
> (In reply to comment #4)
> > (In reply to comment #0)
> > > Reinstalling the old pulseaudio packages (thanks urpmi.recover) solves the
> > > problem.
> > 
> > I suggest to get old SRPMs and try to update them to 5.0 yourself. Maybe new
> > version of pulseaudio package has more changes then just tarball update.
> > Unfortunately, PulseAudio maintainer no longer works for ROSA since this
> > week, so I cannot even ask him what and why he did. So someone should
> > investigate it.
> 
> It was the next item in my TODO list...
> and already I gave a quick look at the new srpm to find the differences.
> When I will have the time, I will do it.
> Stay tuned.

Redoing the srpms and building it really solves the problem...
closing.