Bug 3877 - [UPDATE REQUEST] drakxtools-14.46-5, draklive-install-1.44-4
: [UPDATE REQUEST] drakxtools-14.46-5, draklive-install-1.44-4
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-25 18:44 MSK by Konstantin Vlasov
Modified: 2014-04-19 02:27 MSD (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin Vlasov 2014-03-25 18:44:06 MSK
Installer: Added optional creating a swap file if no swap partition is present.

How to test:
1) Select custom partitioning.
2) Create the desired partitioning scheme and make sure there are no swap-formatted partitions are present on your hard disk.
3) Continue installation.
4) A confirmation dialog will be displayed that warns about missing swap partitions and (now) suggests to use a swap file with user-configured size.
5) After installation and booting into the installed system, there should be a /swap file present which is used for swapping.
Comment 1 Konstantin Vlasov 2014-03-25 18:45:29 MSK
https://abf.rosalinux.ru/build_lists/1724332
https://abf.rosalinux.ru/build_lists/1724333

https://abf.rosalinux.ru/build_lists/1724314
https://abf.rosalinux.ru/build_lists/1724315

Advisory: Added optional creating a swap file in the installer if no swap partition is present.
Comment 2 Postnikov Dmitry 2014-03-25 19:27:02 MSK
Swap file wiil be created OK and work. But setting in /etc/fstab:
======
//swap swap swap defaults 0 0
=====
no correct (IMHO).

Maybe line setting:
====
/swap none swap defaults 0 0
====
Comment 3 Postnikov Dmitry 2014-03-25 19:33:06 MSK
(In reply to comment #2)
> Swap file wiil be created OK and work. But setting in /etc/fstab:
> ======
> //swap swap swap defaults 0 0
> =====
> no correct (IMHO).
> 
> Maybe line setting:
> ====
> /swap none swap defaults 0 0
> ====

and parameter "resume=" in Grub2 menu is clear.
Maybe need "resume=/dev/sdX" where /swapfile is present?
Comment 4 Postnikov Dmitry 2014-03-25 19:48:35 MSK
Without swap partition and without swap file also normal installing and work.
Comment 5 Konstantin Vlasov 2014-03-25 20:30:25 MSK
(In reply to comment #2)
> //swap swap swap defaults 0 0
> =====
> no correct (IMHO).

Several forward slashes are equivalent to one slash, so this path works correctly. Aesthetically, it would be nice to have a single slash, but I haven't figured out yet how to fix it.

(In reply to comment #3)
> and parameter "resume=" in Grub2 menu is clear.
> Maybe need "resume=/dev/sdX" where /swapfile is present?

Strange, I cannot reproduce this. When I tested I got the following line:

linux  /boot/vmlinuz-3.10.27-nrj-desktop-1rosa root=UUID=b78260fd-5848-4cfa-86a0-a1de10436646 ro  splash=silent logo.nologo resume=UUID=b78260fd-5848-4cfa-86a0-a1de10436646 resume_offset=34816

What ISO did you use for testing, and what partition configuration?
Comment 6 Postnikov Dmitry 2014-03-25 22:09:44 MSK
(In reply to comment #5)
> (In reply to comment #2)
> > //swap swap swap defaults 0 0
> > =====
> > no correct (IMHO).
> 
> Several forward slashes are equivalent to one slash, so this path works
> correctly. Aesthetically, it would be nice to have a single slash, but I
> haven't figured out yet how to fix it.
> 
> (In reply to comment #3)
> > and parameter "resume=" in Grub2 menu is clear.
> > Maybe need "resume=/dev/sdX" where /swapfile is present?
> 
> Strange, I cannot reproduce this. When I tested I got the following line:
> 
> linux  /boot/vmlinuz-3.10.27-nrj-desktop-1rosa
> root=UUID=b78260fd-5848-4cfa-86a0-a1de10436646 ro  splash=silent logo.nologo
> resume=UUID=b78260fd-5848-4cfa-86a0-a1de10436646 resume_offset=34816
> 
> What ISO did you use for testing, and what partition configuration?

I record screencast where "resume=" is clear and doubled slash.
http://yadi.sk/d/9dIEAZc1LCpkE
Comment 7 Konstantin Vlasov 2014-03-26 20:05:46 MSK
You are using too old an image (2748). It contains grub2-2.00-39, while support for file swapping was added in 2.00-40 (and improved in later versions). Please, re-test with the recent images, e.g. 3034:
https://abf.rosalinux.ru/platforms/rosa2012.1/products/25/product_build_lists/3034
(or you can still use an old image, but then you should perform a full update before starting installation).
Comment 8 Konstantin Vlasov 2014-03-27 18:05:28 MSK
(In reply to comment #2)
> //swap swap swap defaults 0 0

In the meantime, I fixed the double slashes; the updated containers:

https://abf.rosalinux.ru/build_lists/1725399
https://abf.rosalinux.ru/build_lists/1725400

https://abf.rosalinux.ru/build_lists/1724314
https://abf.rosalinux.ru/build_lists/1724315

(draklive-install containers did not change)

Advisory: Added optional creating a swap file in the installer if no swap partition is present.
Comment 9 Postnikov Dmitry 2014-03-27 23:20:37 MSK
(In reply to comment #8)
> (In reply to comment #2)
> > //swap swap swap defaults 0 0
> 
> In the meantime, I fixed the double slashes; the updated containers:
> 
> https://abf.rosalinux.ru/build_lists/1725399
> https://abf.rosalinux.ru/build_lists/1725400
> 
> https://abf.rosalinux.ru/build_lists/1724314
> https://abf.rosalinux.ru/build_lists/1724315
> 
> (draklive-install containers did not change)
> 
> Advisory: Added optional creating a swap file in the installer if no swap
> partition is present.

All work OK with iso image 3034. All fixed.
Comment 10 Vladimir Potapov 2014-03-28 09:55:13 MSK
drakxtools-14.46-6
http://abf-downloads.rosalinux.ru/rosa2012.1/container/1725399/i586/main/release/
http://abf-downloads.rosalinux.ru/rosa2012.1/container/1725400/x86_64/main/release/

draklive-install-1.44-4
http://abf-downloads.rosalinux.ru/rosa2012.1/container/1724314/i586/main/release/
http://abf-downloads.rosalinux.ru/rosa2012.1/container/1724315/x86_64/main/release/
************************* Advisory ********************
Added optional creating a swap file in the installer if no swap partition is present.
*******************************************************
QA Verified