Bug 3871 - [UPDATE REQUEST] mpd to release 0.18.9
: [UPDATE REQUEST] mpd to release 0.18.9
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-22 23:25 MSK by Giovanni Mariani
Modified: 2014-04-14 12:26 MSD (History)
4 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Giovanni Mariani 2014-03-22 23:25:26 MSK
New release.
Comment 1 Giovanni Mariani 2014-03-22 23:27:45 MSK
Advisory:
- New release 0.18.9
- Updated Source0 and URL tags
- Updated BReqs list to enable more format support (from Mageia)
  and enabled them in the configure options
- Added S100 to silence many (useless or wrong) rpmlint warnings

https://abf.rosalinux.ru/build_lists/1718460
https://abf.rosalinux.ru/build_lists/1718461
Comment 2 Vladimir Potapov 2014-03-24 10:52:16 MSK
mpd-0.18.9-1
http://abf-downloads.rosalinux.ru/rosa2012.1/container/1718460/i586/main/release/
http://abf-downloads.rosalinux.ru/rosa2012.1/container/1718461/x86_64/main/release/
************************* Advisory *************************
- New release 0.18.9
************************ ChangeLog *************************
 Updated Source0 and URL tags
- Updated BReqs list to enable more format support
  and enabled them in the configure options
- Added S100 to silence many (useless or wrong) rpmlint warnings
*************************************************************
QA Verified
Comment 3 Giovanni Mariani 2014-03-29 14:25:26 MSK
Advisory:
Updated to correct broken install according to
http://upstream-tracker.org/repoclosure_reports/2012_desktop/i586/main/report.html
and
http://upstream-tracker.org/repoclosure_reports/2012_desktop/x86_64/main/report.html.

A stupid cut-and-paste error in the configure option list managed to make mpd always depend upon the lame package from Restricted repo, while that was supposed to happen only for PLF-enabled builds.
Please test without the Restricted repo enabled.

Packages:
https://abf.rosalinux.ru/build_lists/1726174
https://abf.rosalinux.ru/build_lists/1726175


BTW, how can I make a PLF build with ABF?
Comment 4 Alexander Burmashev 2014-03-29 14:27:24 MSK
You need to edit <package name>-restricted project, which already has plf set to enabled.
Comment 5 Andrey Bondrov 2014-03-29 14:43:09 MSK
Yes, just sync 

https://abf.rosalinux.ru/import/mpd/tree/rosa2012.1

with

https://abf.rosalinux.ru/import/mpd-restricted/tree/rosa2012.1

and then make sure build_plf is set to 0 in mpd project and to 1 in mpd-restricted project.
Comment 6 Vladimir Potapov 2014-04-01 13:12:19 MSD
I wait containers with restricted version...
Comment 7 Giovanni Mariani 2014-04-02 12:18:48 MSD
(In reply to comment #6)
> I wait containers with restricted version...
Sorry, Vladimir...
I will be a little busy until next Friday.
As soon as I will have the time, I will do.
Comment 8 Andrey Bondrov 2014-04-02 13:37:55 MSD
(In reply to comment #6)
> I wait containers with restricted version...

Done:

https://abf.rosalinux.ru/build_lists/1733110
https://abf.rosalinux.ru/build_lists/1733111
Comment 9 Alexander Petryakov 2014-04-03 07:39:18 MSD
http://mirror.rosalab.ru/rosa/rosa2012.1/repository/x86_64/media/restricted/updates/mpd-0.18.9-2plf-plf2012.1.x86_64.rpm
mpd-0.18.9-2plf-plf2012.1.x86_64.rpm               24-Mar-2014 12:04              244217
http://abf-downloads.rosalinux.ru/rosa2012.1/container/1733111/x86_64/restricted/release/mpd-0.18.9-2plf-plf2012.1.x86_64.rpm
mpd-0.18.9-2plf-plf2012.1.x86_64.rpm               02-Apr-2014 09:26              244549
i guess mpd-restricted already published or need rise build number
Comment 10 Andrey Bondrov 2014-04-03 08:11:25 MSD
(In reply to comment #9)
> i guess mpd-restricted already published or need rise build number

Yeah, looks like both Main & Restricted builds need that.

Main:
https://abf.rosalinux.ru/build_lists/1739127
https://abf.rosalinux.ru/build_lists/1739128

Restricted:
https://abf.rosalinux.ru/build_lists/1739129
https://abf.rosalinux.ru/build_lists/1739130
Comment 11 Vladimir Potapov 2014-04-04 15:56:27 MSD
mpd-0.18.9-3
http://abf-downloads.rosalinux.ru/rosa2012.1/container/1739127/i586/main/release/
http://abf-downloads.rosalinux.ru/rosa2012.1/container/1739128/x86_64/main/release/

mpd-0.18.9-3plf
http://abf-downloads.rosalinux.ru/rosa2012.1/container/1739129/i586/restricted/release/
http://abf-downloads.rosalinux.ru/rosa2012.1/container/1739130/x86_64/restricted/release/
******************************** Advisory ***************************
- New release 0.18.9
- Updated Source0 and URL tags
- Updated BReqs list to enable more format support (from Mageia)
  and enabled them in the configure options
- Added S100 to silence many (useless or wrong) rpmlint warnings
*********************************************************************
QA Verified