Bug 3855 - Move implementation of auto-selection from urpmi executable to urpm perl modules
: Move implementation of auto-selection from urpmi executable to urpm perl modules
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: unspecified
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks: 3695
  Show dependency treegraph
 
Reported: 2014-03-19 11:36 MSK by Denis Silakov
Modified: 2014-03-24 10:35 MSK (History)
2 users (show)

See Also:
RPM Package: urpmi
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Silakov 2014-03-19 11:36:22 MSK
In bug #3695 we came to conclusion that current location of "smart" auto-selection functions directly in uromi executable is not convinient, since it doesn't allow other applications (e.g., Software Center) to reuse them.

The idea is to move these functionality to one of urpm modules.
Comment 1 Denis Silakov 2014-03-19 11:41:24 MSK
Advisory:
Reworked internal implementation of package auto-selection mechanism. Now this functionality can be used outside urpmi itself. More particular, urpm/select.pm module has a new function, get_best_choice(), which returns the index of best package in the array of packages given to it.

Note for testers: for ordinary users, this update shouldn't have any visible changes. But we need to ensure that there are no regressions.

Build lists:
https://abf.io/build_lists/1709909
https://abf.io/build_lists/1709910
Comment 2 Vladimir Potapov 2014-03-20 16:51:39 MSK
urpmi-6.71-56
http://abf-downloads.rosalinux.ru/rosa2012.1/container/1709909/i586/main/release/
http://abf-downloads.rosalinux.ru/rosa2012.1/container/1709910/x86_64/main/release/
********************** Advisory *********************
Reworked internal implementation of package auto-selection mechanism. Now this functionality can be used outside urpmi itself. More particular, urpm/select.pm module has a new function, get_best_choice(), which returns the index of best package in the array of packages given to it.

******************************************************
QA Verified
Comment 3 Denis Silakov 2014-03-21 12:28:10 MSK
While Alex is offline, I have published the packages, since these updates are needed by SC developers.

But I don't have permissions to set the 'published' flag in the bug:)