Bug 3849 - [UPDATE REQUEST] firefox, firefox-l10n, nss, nspr, sqlite3
: [UPDATE REQUEST] firefox, firefox-l10n, nss, nspr, sqlite3
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-14 12:28 MSK by Arkady L. Shane
Modified: 2014-03-25 10:23 MSK (History)
5 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
alexander.petryakov: qa_verified+
danila.leontiev: secteam_verified+
alex.burmashev: published+


Attachments
FF menu before update (167.39 KB, image/png)
2014-03-19 22:26 MSK, Alexander Petryakov
Details
FF-after-update (217.11 KB, image/png)
2014-03-19 22:28 MSK, Alexander Petryakov
Details
ss (212.23 KB, image/png)
2014-03-20 06:06 MSK, Vladimir Potapov
Details
Update error (6.96 KB, text/x-log)
2014-03-20 20:50 MSK, Alexander Petryakov
Details

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Alexander Petryakov 2014-03-17 00:36:13 MSK
After update, browser don't open any page
Comment 2 Arkady L. Shane 2014-03-17 16:59:56 MSK
Is lib64freebl3 (or libfreebl3) installed? I think problem in it.
Comment 3 Arkady L. Shane 2014-03-18 22:08:36 MSK
New nss with proper depends:

https://abf.rosalinux.ru/build_lists/1709554
https://abf.rosalinux.ru/build_lists/1709555
Comment 4 Alexander Petryakov 2014-03-19 22:26:11 MSK
Created attachment 2713 [details]
FF menu before update
Comment 5 Alexander Petryakov 2014-03-19 22:28:04 MSK
Created attachment 2714 [details]
FF-after-update

Firefox not translated after update
Please, see attachments
Comment 6 Vladimir Potapov 2014-03-20 06:06:19 MSK
Created attachment 2716 [details]
ss

I don't confirm this issue
Comment 7 Arkady L. Shane 2014-03-20 11:54:24 MSK
About translation. This problem is connected with libfreebl. If you remove .mozilla everything will be fixed.

Also if update old firefox version with new nss packages issue is absent.


But please wait. I've already build new Fifefox.
Comment 9 Alexander Petryakov 2014-03-20 20:50:55 MSK
Created attachment 2719 [details]
Update error

файл /usr/bin/shlibsign из устанавливаемого пакета nss-shlibsign-3.15.4-2.i586 конфликтует с файлом из пакета nss-3.14-0.i586
Comment 10 Arkady L. Shane 2014-03-21 09:31:07 MSK
Ok. another update if nss:

https://abf.rosalinux.ru/build_lists/1711035
https://abf.rosalinux.ru/build_lists/1711036
Comment 11 Alexander Petryakov 2014-03-23 23:42:53 MSK
Firefox 24.4.0 x86_64 - has error
firefox: symbol lookup error: /usr/lib64/firefox-24.4.0/libxul.so: undefined symbol: PR_SetCurrentThreadName
Comment 12 Arkady L. Shane 2014-03-24 13:01:57 MSK
Did you update nss and nspr?

Please, place here output of:

rpm -qa | egrep "nss|nspr|sqlite"
Comment 13 Alexander Petryakov 2014-03-24 17:50:30 MSK
This my mistake, after install on clean system the error has not repeated.
firefox-24.4.0-2.src.rpm
firefox-l10n-24.4.0-1
nspr-4.10.3-1
sqlite3-3.7.17-1
nss-3.15.4-3
************** Advisory **************
Update Firefox to 24.3.0
**************************************
QA Verified
Comment 14 Denis Silakov 2014-03-24 19:56:33 MSK
*** Bug 3084 has been marked as a duplicate of this bug. ***
Comment 15 Denis Silakov 2014-03-24 20:02:20 MSK
*** Bug 3204 has been marked as a duplicate of this bug. ***
Comment 16 Denis Silakov 2014-03-24 20:56:54 MSK
*** Bug 3520 has been marked as a duplicate of this bug. ***