Bug 3841 - Encrypted LVM installation installer failure
: Encrypted LVM installation installer failure
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-07 21:05 MSK by Mike Dev
Modified: 2014-03-26 17:23 MSK (History)
1 user (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
Error screenshot (57.10 KB, image/png)
2014-03-07 21:05 MSK, Mike Dev
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Dev 2014-03-07 21:05:28 MSK
Created attachment 2697 [details]
Error screenshot

Description of problem:
Installer fails with encrypted LVM installation.

Version-Release number of selected component (if applicable):


How reproducible:
Always.

Steps to Reproduce:
1. Start installation process from ROSA.FRESH.KDE.R2.x86_64.iso
2. Create new partition, choose type Linux LVM, check Encryption
3. Click OK, see error: Undefined subroutine &fs::dmcrypt::save_crypttab_called.

OR

1. Start installation process from ROSA.FRESH.KDE.R2.x86_64.iso
2. Create new partition, choose type Linux LVM
3. Create VG and then try to create an encrypted volume on it
3. Click OK, see error: Undefined subroutine &fs::dmcrypt::save_crypttab_called.
Comment 1 Konstantin Vlasov 2014-03-11 13:47:08 MSK
A similar issue has already been fixed in our repositories. Could you please check with the following test image?
https://abf.rosalinux.ru/platforms/rosa2012.1/products/25/product_build_lists/2852
Comment 2 Mike Dev 2014-03-25 21:20:48 MSK
Hi, Konstantin!

I confirm that in first scenario the issue is resolved (at least for me), and in second scenario an encryption option is now disabled (which I believe is the right thing).

Thanks.
Comment 3 Konstantin Vlasov 2014-03-26 17:23:10 MSK
OK, I'm closing the bug then. Thanks for confirming the fix.