Bug 3840 - [UPDATE REQUEST] draklive-install-1.43-2
: [UPDATE REQUEST] draklive-install-1.43-2
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
https://abf.rosalinux.ru/import/drakl...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-07 19:14 MSK by Konstantin Vlasov
Modified: 2014-03-13 22:03 MSK (History)
2 users (show)

See Also:
RPM Package: draklive-install
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin Vlasov 2014-03-07 19:14:05 MSK
A bug was fixed in draklive-install. Steps to reproduce:
1. Select custom partitioning, configure set of partitions, assign mount points.
2. Click on the partition you chose for root, click "Mount".
3. Continue installation.
4. After a couple of advertisement slides, installation fails.

The problem was, the partitions mounted manually by user became unmounted before copying started, and all the data were copied to the wrong location (a regular subdirectory instead of the mounted partition). In case of root partition, destination was located within the RAM drive of the booted live system, so it was quickly overflowed, not to mention that files were not written to the hard disk.
Comment 1 Konstantin Vlasov 2014-03-07 19:15:04 MSK
https://abf.rosalinux.ru/build_lists/1683444
https://abf.rosalinux.ru/build_lists/1683445

Advisory: Fixed failing installation when user mounted one or more destination partitions.
Comment 2 Vladimir Potapov 2014-03-13 19:01:02 MSK
draklive-install-1.43-2
http://abf-downloads.rosalinux.ru/rosa2012.1/container/1683444/i586/main/release/
http://abf-downloads.rosalinux.ru/rosa2012.1/container/1683445/x86_64/main/release/
************************ Advisory ****************
Fixed failing installation when user mounted one or more destination partitions.
**************************************************
QA Verified
Comment 3 Konstantin Vlasov 2014-03-13 20:11:23 MSK
Sorry, I've just found a regression in this update. Please, don't publish it. I'm preparing a new update for the installer, and with it I'll provide a fix for this bug as well.