Bug 3836 - [UPDATE REQUEST] KDE 4.11.4 -> 4.12.3
: [UPDATE REQUEST] KDE 4.11.4 -> 4.12.3
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-05 15:46 MSK by Andrey Bondrov
Modified: 2014-03-15 02:15 MSK (History)
2 users (show)

See Also:
RPM Package: various
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
andrey.bondrov: published+


Attachments
ff2.png (286.73 KB, image/png)
2014-03-07 18:47 MSK, Postnikov Dmitry
Details
ff3.png (129.07 KB, image/png)
2014-03-07 22:44 MSK, Postnikov Dmitry
Details
ff5.png (337.51 KB, image/png)
2014-03-08 13:41 MSK, Postnikov Dmitry
Details
ff6.png (396.21 KB, image/png)
2014-03-08 19:33 MSK, Postnikov Dmitry
Details
ff7.png (378.71 KB, image/png)
2014-03-08 21:39 MSK, Postnikov Dmitry
Details
ff8.png (313.60 KB, image/png)
2014-03-10 00:19 MSK, Postnikov Dmitry
Details
ff9.png (257.74 KB, image/png)
2014-03-10 00:57 MSK, Postnikov Dmitry
Details
krita (139.47 KB, image/png)
2014-03-10 11:27 MSK, Vladimir Potapov
Details
ff10.png (251.69 KB, image/png)
2014-03-10 17:05 MSK, Postnikov Dmitry
Details
ff12.png (374.36 KB, image/png)
2014-03-10 17:54 MSK, Postnikov Dmitry
Details
ff13.png (525.23 KB, image/png)
2014-03-10 23:48 MSK, Postnikov Dmitry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Bondrov 2014-03-05 15:46:19 MSK
It's time to switch from KDE 4.11.x to KDE 4.12.x. Please test KDE 4.12.3 & KDE Workspace 4.11.7:

http://abf-downloads.rosalinux.ru/kde4_backports_personal/repository/rosa2012.1/
Comment 1 Vladimir Potapov 2014-03-07 08:09:54 MSK
The update route to extended testing
Comment 2 Postnikov Dmitry 2014-03-07 18:38:24 MSK
1. The game Kbreakout has white screen.
2. Applet plasma-applet-pastebin no text past to server, only img past.
Comment 3 Andrey Bondrov 2014-03-07 18:44:33 MSK
(In reply to comment #2)
> 1. The game Kbreakout has white screen.

Should be fixed now.
Comment 4 Postnikov Dmitry 2014-03-07 18:47:08 MSK
Created attachment 2696 [details]
ff2.png

3. The game kajongg also no work.
Comment 5 Postnikov Dmitry 2014-03-07 22:44:00 MSK
Created attachment 2698 [details]
ff3.png

4. В режиме "Нетбук" фон черного цвета.
5. Игруха Kblocks тоже не пашет.
Comment 6 Andrey Bondrov 2014-03-08 03:37:17 MSK
kblocks seems to work fine for me. 

kajongg doesn't work indeed, I'll investigate why.
Comment 7 Postnikov Dmitry 2014-03-08 13:41:29 MSK
Created attachment 2699 [details]
ff5.png

6. Kmail when you first start and configure a customer account, nothing shows. After restarting program begins to show letters.
7. Kmail poorly with encoding windows-1251. Settings are set to windows-1251, however, letter in this encoding is not readable.
8. In Kmail the same letter can be deleted, and it will appear in the "Trash".
9. In Kmail in folder "All email" don't delete letters.
Comment 8 Postnikov Dmitry 2014-03-08 14:06:47 MSK
10. DragonPlayer Not losing many video formats. For example, .mpeg, .avi, .mp4. Although other players (ROMP, VLC) these video files normally lose.
===================
Mar  8 14:01:47 mindlife2-k64r2 kernel: [12820.187525] multiqueue0:src[18936]: segfault at 7fcd7a346470 ip 00007fcdca4008db sp 00007fcda23b18e8 error 6 in libc-2.15.so[7fcdca2ba000+1ae000]
Mar  8 14:01:47 mindlife2-k64r2 systemd-coredump[20395]: Process 18433 (multiqueue0:src) dumped core.
Mar  8 14:02:14 mindlife2-k64r2 kernel: [12847.549440] traps: source:src[20914] general protection ip:7f2271253b55 sp:7f2244b60690 error:0 in libc-2.15.so[7f22711d7000+1ae000]
Mar  8 14:02:14 mindlife2-k64r2 systemd-coredump[20926]: Process 20403 (source:src) dumped core.
Mar  8 14:03:38 mindlife2-k64r2 systemd-coredump[22850]: Process 20933 (multiqueue3:src) dumped core.
===================
Comment 9 Postnikov Dmitry 2014-03-08 19:33:16 MSK
Created attachment 2700 [details]
ff6.png

11. KphotoAlbum arguing that the version of mplayer not 2.
12. KphotoAlbum begin master start don't translate in russian and some of settings in program properties, also without translation.
Comment 10 Postnikov Dmitry 2014-03-08 21:39:58 MSK
Created attachment 2701 [details]
ff7.png

13. KwikDisk don't unmount ntfs partition mounted.
Comment 11 Postnikov Dmitry 2014-03-10 00:19:44 MSK
Created attachment 2702 [details]
ff8.png

14. Don't install Calligra.
Comment 12 Postnikov Dmitry 2014-03-10 00:44:30 MSK
15. If i'am install Kwebdev4, i has installed only Kommander (without Quanta, Kimagemap etc.)
16. Kommander don't start.
Comment 13 Postnikov Dmitry 2014-03-10 00:57:36 MSK
Created attachment 2703 [details]
ff9.png

17. Krita don't installing.
Comment 14 Vladimir Potapov 2014-03-10 11:27:11 MSK
Created attachment 2704 [details]
krita

Hm, krita correct install from konsole and work. (KDE R2 x64)
Comment 15 Vladimir Potapov 2014-03-10 11:37:26 MSK
(In reply to comment #11)
> Created attachment 2702 [details]
> ff8.png
> 
> 14. Don't install Calligra.
I don't confirm it. Calligra correct install from GUI on my x64. Check sources and rpm database.
Comment 16 Andrey Bondrov 2014-03-10 15:16:16 MSK
(In reply to comment #12)
> 15. If i'am install Kwebdev4, i has installed only Kommander (without
> Quanta, Kimagemap etc.)
> 16. Kommander don't start.

Well, for me it installs everything it should install:

- kdewebdev4-4.11.4-1-rosa2012.1.x86_64
- kfilereplace-4.11.4-1-rosa2012.1.x86_64
- kimagemapeditor-4.11.4-1-rosa2012.1.x86_64
- klinkstatus-4.11.4-1-rosa2012.1.x86_64
- kommander-4.11.4-1-rosa2012.1.x86_64
- lib64klinkstatuscommon4-4.11.4-1-rosa2012.1.x86_64
- lib64kommandercore4-4.11.4-1-rosa2012.1.x86_64
- lib64krossui4-4.11.4-1-rosa2012.1.x86_64
- lib64tidy0.99_0-20090904-7-rosa2012.1.x86_64
- tidy-20090904-7-rosa2012.1.x86_64

Kommander seems to work but it's obsolete application and it's really hard to find .kmdr scripts for it nowadays.
Comment 17 Andrey Bondrov 2014-03-10 16:23:47 MSK
(In reply to comment #6)
> kajongg doesn't work indeed, I'll investigate why.

Should be fixed now.
Comment 18 Postnikov Dmitry 2014-03-10 17:05:18 MSK
Created attachment 2705 [details]
ff10.png

18. "Установка удаление программ" don't start SECOND time.

Reproduce:

a) Open "Параметры системы"
b) Start "Установка удаление программ"
c) Close "Установка удаление программ"
d) In "Параметры системы" click green arrow (back) and second start "Установка удаление программ"
e) Show error.
Comment 19 Postnikov Dmitry 2014-03-10 17:08:05 MSK
(In reply to comment #14)
> Created attachment 2704 [details]
> krita
> 
> Hm, krita correct install from konsole and work. (KDE R2 x64)

(In reply to comment #15)
> (In reply to comment #11)
> > Created attachment 2702 [details]
> > ff8.png
> > 
> > 14. Don't install Calligra.
> I don't confirm it. Calligra correct install from GUI on my x64. Check
> sources and rpm database.

Disable "Contrib" repo and check install Krita and Calligra. They should be installed without enabled "Contrib" repository.
Comment 20 Vladimir Potapov 2014-03-10 17:31:10 MSK
(In reply to comment #18)
> Created attachment 2705 [details]
> ff10.png
> 
> 18. "Установка удаление программ" don't start SECOND time.
> 
> Reproduce:
> 
> a) Open "Параметры системы"
> b) Start "Установка удаление программ"
> c) Close "Установка удаление программ"
> d) In "Параметры системы" click green arrow (back) and second start
> "Установка удаление программ"
> e) Show error.
This is very old bug, it's showed periodically, random.
Comment 21 Andrey Bondrov 2014-03-10 17:48:18 MSK
(In reply to comment #19)
> Disable "Contrib" repo and check install Krita and Calligra. They should be
> installed without enabled "Contrib" repository.

No, Calligra (including Krita) is in Contrib repository, not in Main. So if you disable Contrib, rebuilt Calligra from KDE4 Backports repository won't install because if missing dependencies (which are in Contrib and don't require rebuild against new versions of KDE).
Comment 22 Postnikov Dmitry 2014-03-10 17:54:37 MSK
Created attachment 2706 [details]
ff12.png

(In reply to comment #21)
> (In reply to comment #19)
> > Disable "Contrib" repo and check install Krita and Calligra. They should be
> > installed without enabled "Contrib" repository.
> 
> No, Calligra (including Krita) is in Contrib repository, not in Main. So if
> you disable Contrib, rebuilt Calligra from KDE4 Backports repository won't
> install because if missing dependencies (which are in Contrib and don't
> require rebuild against new versions of KDE).

(In reply to comment #0)
> It's time to switch from KDE 4.11.x to KDE 4.12.x. Please test KDE 4.12.3 &
> KDE Workspace 4.11.7:
> 
> http://abf-downloads.rosalinux.ru/kde4_backports_personal/repository/
> rosa2012.1/

Hm... but Calligra and Krita is present in TEST repository.
See attach.
Comment 23 Andrey Bondrov 2014-03-10 18:25:37 MSK
(In reply to comment #22)
> Hm... but Calligra and Krita is present in TEST repository.
> See attach.

Yes. Because they depend on some KDE libs and require to be rebuilt against new KDE.

If people who use Calligra enable KDE4 Backports repository, their Calligra (which is in Contrib) will stop working after KDE update. So it's a must to rebuild Calligra itself too. In fact, I just don't see much sense in either moving whole Calligra (including dependencies) to Main or adding whole Calligra to KDE4 Backports.
Comment 24 Postnikov Dmitry 2014-03-10 18:44:29 MSK
19. TimeFrame does not disappear when running any programs.

Screencast: http://yadi.sk/d/B-XzuJlGKG6UM
Comment 25 Andrey Bondrov 2014-03-10 19:03:10 MSK
(In reply to comment #24)
> 19. TimeFrame does not disappear when running any programs.
> 
> Screencast: http://yadi.sk/d/B-XzuJlGKG6UM

Well, it's really unlikely to be a regression with new KDE but I guess this should be fixed anyway. I'll take a look when I have some time for this.
Comment 26 Postnikov Dmitry 2014-03-10 23:48:02 MSK
Created attachment 2707 [details]
ff13.png

20. Amarok don't connect and don't update Jamendo.com db. Magnatune and Lastfm all normal update db.
Comment 27 Postnikov Dmitry 2014-03-11 11:39:54 MSK
(In reply to comment #1)
> The update route to extended testing

***********************
Extended testing report
***********************
In general, system is stable. In addition to these trifles.
Comment 28 Vladimir Potapov 2014-03-13 11:44:43 MSK
**************** Advisory *****************
New KDE version
*******************************************
QA Verified