Bug 3834 - [UPDATE REQUEST] drakxtools-14.45, draklive-install-1.43
: [UPDATE REQUEST] drakxtools-14.45, draklive-install-1.43
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-05 13:51 MSK by Konstantin Vlasov
Modified: 2014-03-06 14:55 MSK (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin Vlasov 2014-03-05 13:51:54 MSK
drakxtools and draklive-install were updated to support automatic installation. Please, test for regressions.

P.S. If you wish to test the autoinstallation function itself, a custom ISO image is required (file /etc/sysconfig/autoinstall must be present in the file system). Here is such image with autoinstallation enabled:
https://abf.rosalinux.ru/platforms/rosa2012.1/products/78/product_build_lists/2860

WARNING! Installing from this image will automatically destroy ALL the data on your hard disk, without any questions!
Comment 1 Konstantin Vlasov 2014-03-05 13:52:49 MSK
drakxtools:
https://abf.rosalinux.ru/build_lists/1680738
https://abf.rosalinux.ru/build_lists/1680739

draklive-install:
https://abf.rosalinux.ru/build_lists/1680765
https://abf.rosalinux.ru/build_lists/1680766

Advisory: Automatic installation feature was implemented.
Comment 2 Vladimir Potapov 2014-03-05 13:55:58 MSK
(In reply to comment #0)
> WARNING! Installing from this image will automatically destroy ALL the data
> on your hard disk, without any questions!
Oh. How to test the feature (I have deisk with 5 test system)? 
Only in virtualbox?
Comment 3 Konstantin Vlasov 2014-03-05 14:17:09 MSK
My main concern is absence of regressions in normal scenarios, without auto-installation (it is designed for custom images only, which should be tested separately anyway).

But if you wish to test the auto-installation feature as well, you will need a separate machine without any important operating systems or other data on it. Or a virtual machine, yes.

You may also test it on a real machine with two hard disks: only the first one will be erased and repartitioned, the other disks will remain intact. But still you'll have to be VERY careful, because the installer might think that the "first" disk is not what you thought it would be… Better to plug a new disk and unplug all the other disks which contain data you wouldn't like to lose.
Comment 4 Vladimir Potapov 2014-03-06 14:28:19 MSK
drakxtools-14.45-1
http://abf-downloads.rosalinux.ru/rosa2012.1/container/1680738/i586/main/release/
http://abf-downloads.rosalinux.ru/rosa2012.1/container/1680739/x86_64/main/release/
draklive-install-1.43-1
http://abf-downloads.rosalinux.ru/rosa2012.1/container/1680765/i586/main/release/
http://abf-downloads.rosalinux.ru/rosa2012.1/container/1680766/x86_64/main/release/
**************************** Advisory ***********************
Automatic installation feature was implemented.
*************************************************************
QA Verified