Bug 380 - Thunderbird` help don`t work
: Thunderbird` help don`t work
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: Alexander Burmashev
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-14 14:31 MSD by Vladimir Potapov
Modified: 2012-11-12 12:29 MSK (History)
4 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
alexander.petryakov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Potapov 2012-06-14 14:31:38 MSD
Description of problem:
In 2012 LTS Thunderbird` help don`t work

Steps to Reproduce:
1.Run thunderbird
2.Press F1
Comment 1 Denis Silakov 2012-06-14 16:33:58 MSD
This is likely caused by the same reason as bug #196 - Thunderbird doesn't pick up necessary file associations. Probably we should just rebuild it with "--enable-gio".
Comment 2 Alexander Burmashev 2012-06-14 16:37:37 MSD
As far as i can see it is already built with it
https://abf.rosalinux.ru/import/mozilla-thunderbird/blob/rosa2012lts/mozilla-thunderbird.spec
Comment 3 Denis Silakov 2012-06-19 12:50:35 MSD
Indeed, Thunderbird already uses gio.

It seems that when opening help page, Thunderbird looks for "x-scheme-handler/http" association which is not set anywhere in out mime databases.

For me it helps to add the following lines to the /use/share/applications/mimeapps.list file (owned by shared-mime-info package):

x-scheme-handler/http=firefox.desktop;
x-scheme-handler/https=firefox.desktop;
Comment 4 Denis Silakov 2012-06-19 12:52:40 MSD
*** Bug 196 has been marked as a duplicate of this bug. ***
Comment 5 Denis Silakov 2012-07-16 16:03:20 MSD
Probably the most correct way to fix this would be to add "x-scheme-handler/http" and "x-scheme-handler/https" to firefox.desktop file. After firefox installation/update these associations will appear in the mime database.
Comment 6 Denis Silakov 2012-07-18 16:21:57 MSD
*** Bug 473 has been marked as a duplicate of this bug. ***
Comment 7 Denis Silakov 2012-10-02 16:16:37 MSD
Advisory: 
'Help' in Thunderbird didn't launch web browser since no browser was associated with "x-scheme-handler/http" and "x-scheme-handler/https" mime types.

This fix associates Firefox with these types.

Build lists:
https://abf.rosalinux.ru/build_lists/743967
https://abf.rosalinux.ru/build_lists/743968
Comment 8 Alexander Petryakov 2012-10-04 09:54:56 MSD
firefox-10.0.7-2
************** Advisory **************
'Help' in Thunderbird didn't launch web browser since no browser was associated with "x-scheme-handler/http" and "x-scheme-handler/https" mime types.

This fix associates Firefox with these types.

**************************************
QA Verified