Bug 3784 - conntrack-tools were updated to 1.4.2 version
: conntrack-tools were updated to 1.4.2 version
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-18 12:36 MSK by Alexander Burmashev
Modified: 2014-03-13 12:58 MSK (History)
1 user (show)

See Also:
RPM Package: conntrack-tools
ISO-related:
Bad POT generating:
Upstream:
alexander.petryakov: qa_verified+
alex.burmashev: published+


Attachments
Ulogd.conf after install (7.29 KB, text/plain)
2014-03-07 09:21 MSK, Alexander Petryakov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Burmashev 2014-02-18 12:36:51 MSK
conntrack-tools were update to 1.4.2 version
Comment 1 Alexander Burmashev 2014-02-18 12:47:25 MSK
Advisory:
conntrack-tools were updated to 1.4.2 version.
Clemence Faure (2):
      conntrack: introduce -l option to filter by labels
      conntrack: fix reporting of unknown arguments

Florian Westphal (5):
      conntrackd: fix compiler warnings
      include: kill unused PLD_* macros
      conntrack: add connlabel format attribute
      conntrackd: support replication of connlabels
      conntrack: fix -L format output

James Guthrie (1):
      conntrackd: fix parsing of non-abbreviated IPv6 address in config file

Pablo Neira Ayuso (11):
      build: requires libnetfilter_conntrack >= 1.0.3
      conntrack: fix timestamps when microseconds are less than 100000
      tests: cthelper: remove test infrastructure from this tree
      cthelper: add IPv6 support
      cthelper: helpers may not use private information area
      conntrackd: cache: fix hashing based on IPv6 address
      conntrackd: deprecate `Family' in configuration file
      conntrackd: fix crash with IPv6 expectation in the filtering code
      conntrackd: simplify expectation filtering
      cthelper: fix IPv6 address and mask in newly created expectations
      conntrack-tools 1.4.2 release
This version also adds the user-space helper infrastructure, which includes the RPC portmapper (to support NFSv3) and Oracle*TNS helpers, support to dump the "dying" and "unconfirmed" list via ctnetlink. A deadlock due to wrong nested signal blocking was resolved.

Buildlists:
https://abf.rosalinux.ru/build_lists/1644890
https://abf.rosalinux.ru/build_lists/1644890

Also all required libraries were updated as well as some new added:
libmnl
https://abf.rosalinux.ru/build_lists/1644435
https://abf.rosalinux.ru/build_lists/1644436
libnfnetlink
https://abf.rosalinux.ru/build_lists/1644453
https://abf.rosalinux.ru/build_lists/1644452
libnetfilter_conntrack
https://abf.rosalinux.ru/build_lists/1644459
https://abf.rosalinux.ru/build_lists/1644458
libnetfilter_acct
https://abf.rosalinux.ru/build_lists/1644467
https://abf.rosalinux.ru/build_lists/1644466
libnetfilter_cttimeout
https://abf.rosalinux.ru/build_lists/1644475
https://abf.rosalinux.ru/build_lists/1644476
libnetfilter_queue
https://abf.rosalinux.ru/build_lists/1644480
https://abf.rosalinux.ru/build_lists/1644479
libnetfilter_cthelper
https://abf.rosalinux.ru/build_lists/1644885
https://abf.rosalinux.ru/build_lists/1644886

All required packages were rebuild on new libraries:
netsniff-ng
https://abf.rosalinux.ru/build_lists/1644880
https://abf.rosalinux.ru/build_lists/1644604
iptables
https://abf.rosalinux.ru/build_lists/1644597
https://abf.rosalinux.ru/build_lists/1644596
ipset
https://abf.rosalinux.ru/build_lists/1644599
https://abf.rosalinux.ru/build_lists/1644598
daq
https://abf.rosalinux.ru/build_lists/1644601
https://abf.rosalinux.ru/build_lists/1644600
ipstate
https://abf.rosalinux.ru/build_lists/1644603
https://abf.rosalinux.ru/build_lists/1644602
ulogd
https://abf.rosalinux.ru/build_lists/1644606
https://abf.rosalinux.ru/build_lists/1644607
Comment 2 Alexander Petryakov 2014-02-24 23:42:09 MSK
Container for i586 is absent. only exists for x64_86 (https://abf.rosalinux.ru/build_lists/1644890)
Comment 4 Alexander Burmashev 2014-02-25 01:04:20 MSK
Fixed the containers.
And here are the proper conntrack-tools buildlists:
https://abf.rosalinux.ru/build_lists/1644890
https://abf.rosalinux.ru/build_lists/1644889
Comment 6 Alexander Burmashev 2014-02-26 00:57:59 MSK
fixed
Comment 7 Alexander Petryakov 2014-02-26 23:06:28 MSK
https://abf.rosalinux.ru/build_lists/1644598 - Путь до контейнера - is empty too
Sorry
Comment 8 Alexander Petryakov 2014-02-26 23:28:57 MSK
please rise release number for 
libnetfilter_cttimeout1-1.0.0-2-rosa2012.1.i586 already exists
Comment 9 Alexander Burmashev 2014-02-26 23:47:03 MSK
Fixed containers path
libnetfilter_cttimeout1 is rebuilt with a higher release
https://abf.rosalinux.ru/build_lists/1669084
https://abf.rosalinux.ru/build_lists/1669083

Failed test should not be treated as a error, just ignore it.
Comment 10 Alexander Petryakov 2014-02-27 01:24:07 MSK
please rise release number for 
libnetfilter_acct1-1.0.0-1
iptables-1.4.15-6
ipset-6.19-1
daq-1.1.1-1
iptstate-2.2.5-1
ulogd-2.0.0-1
already exists

Different release number for netsniff-ng (i586 & x86_64) 
https://abf.rosalinux.ru/build_lists/1644880 
https://abf.rosalinux.ru/build_lists/1644604
Comment 12 Alexander Petryakov 2014-02-27 08:42:12 MSK
Alexander netsniff-ng-0.5.7-1 is not ok 0.5.7-1 already exists
http://mirror.yandex.ru/rosa/rosa2012.1/repository/i586/contrib/updates/netsniff-ng-0.5.7-1-rosa2012.1.i586.rpm
Comment 13 Alexander Burmashev 2014-02-28 00:26:38 MSK
Ok, i see, thanks.
Release up:
https://abf.rosalinux.ru/build_lists/1674194
https://abf.rosalinux.ru/build_lists/1674195
Comment 14 Alexander Petryakov 2014-03-02 00:19:17 MSK
what about iptables-1.4.15-6 this release already exists?
Comment 16 Alexander Petryakov 2014-03-02 08:13:07 MSK
The Field "Путь до контейнера" - is empty.
Comment 17 Alexander Burmashev 2014-03-02 18:30:52 MSK
fixed
Comment 18 Alexander Petryakov 2014-03-02 23:45:33 MSK
Alexander sorry, but I don't see ulogd
Comment 20 Alexander Petryakov 2014-03-03 23:53:21 MSK
ulogd don't start

Mar  3 23:50:29 FR-amd64 ulogd[5465]: Starting ulogd: [ ОШИБКА ]#015[ ОШИБКА ]
Mar  3 23:50:29 FR-amd64 systemd[1]: ulogd.service: control process exited, code=exited status=1
Mar  3 23:50:29 FR-amd64 systemd[1]: Failed to start LSB: start and stop ulogd.
Mar  3 23:50:29 FR-amd64 systemd[1]: Unit ulogd.service entered failed state.
Comment 21 Alexander Burmashev 2014-03-03 23:55:37 MSK
Was it working prior to update ? 
BTW, i think i will fix it anyway, it just may help.
Comment 22 Alexander Petryakov 2014-03-04 08:21:58 MSK
Sorry, Alexander is my mistake I not correctly interpreted tag "newpackage".
p.s. ulogd-2.0.0-1 - have this error too.
Comment 23 Alexander Burmashev 2014-03-05 16:41:15 MSK
I highly suspect that the problem is that ulogd is not properly configured.
Comment 24 Alexander Burmashev 2014-03-05 16:45:52 MSK
Attach please your /etc/ulogd.conf
Comment 25 Alexander Petryakov 2014-03-07 09:21:08 MSK
Created attachment 2695 [details]
Ulogd.conf after install
Comment 26 Alexander Burmashev 2014-03-07 11:46:56 MSK
add
stack=log1:NFLOG,base1:BASE,ifi1:IFINDEX,ip2str1:IP2STR,print1:PRINTPKT,emu1:LOGEMU
right before
# this is a stack for logging packet send by system via LOGEMU
and ulogd should be working.
Comment 27 Alexander Petryakov 2014-03-07 17:05:40 MSK
I can confirm that ulogd started after added stack=log1:NFLOG,base1:BASE,ifi1:IFINDEX,ip2str1:IP2STR,print1:PRINTPKT,emu1:LOGEMU
Comment 28 Alexander Petryakov 2014-03-13 03:53:17 MSK
conntrack-tools-1.4.2-3
************** Advisory **************
conntrack-tools were updated to 1.4.2 version.
Clemence Faure (2):
      conntrack: introduce -l option to filter by labels
      conntrack: fix reporting of unknown arguments

Florian Westphal (5):
      conntrackd: fix compiler warnings
      include: kill unused PLD_* macros
      conntrack: add connlabel format attribute
      conntrackd: support replication of connlabels
      conntrack: fix -L format output

James Guthrie (1):
      conntrackd: fix parsing of non-abbreviated IPv6 address in config file

Pablo Neira Ayuso (11):
      build: requires libnetfilter_conntrack >= 1.0.3
      conntrack: fix timestamps when microseconds are less than 100000
      tests: cthelper: remove test infrastructure from this tree
      cthelper: add IPv6 support
      cthelper: helpers may not use private information area
      conntrackd: cache: fix hashing based on IPv6 address
      conntrackd: deprecate `Family' in configuration file
      conntrackd: fix crash with IPv6 expectation in the filtering code
      conntrackd: simplify expectation filtering
      cthelper: fix IPv6 address and mask in newly created expectations
      conntrack-tools 1.4.2 release
This version also adds the user-space helper infrastructure, which includes the RPC portmapper (to support NFSv3) and Oracle*TNS helpers, support to dump the "dying" and "unconfirmed" list via ctnetlink. A deadlock due to wrong nested signal blocking was resolved.
**************************************
QA Verified