Bug 3729 - bash: _rpm_installed_packages: command not found
: bash: _rpm_installed_packages: command not found
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-05 20:08 MSK by Ben Aceler
Modified: 2014-02-11 11:25 MSK (History)
3 users (show)

See Also:
RPM Package: bash
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Aceler 2014-02-05 20:08:13 MSK
Description of problem: using bash completion upon urpme tool cause an error: bash: _rpm_installed_packages: command not found

How reproducible:
Always.


Steps to Reproduce:
1. Open terminal and issue a command: urpme some<TAB>
Comment 1 Denis Silakov 2014-02-05 23:50:11 MSK
Thanks for the report, we have even two issues here.

I'll push updated bash-completion package to repositories soon, but you will have towait a little for urpmi update (I want to wait while our testers check another important change to that tool). But if in a hurry, just go to /etc/bash_completion.d/urpmi, look for _rpm_installed_packages and add "_xfunc rpm" before it, so you should have:

_xfunc rpm _rpm_installed_packages
Comment 2 Denis Silakov 2014-02-10 10:54:56 MSK
Advisory:
Fix bash autocompletion for urpme

Build lists:
bash-completion:
https://abf.io/build_lists/1612418
https://abf.io/build_lists/1612414

urpmi:
https://abf.io/build_lists/1626681
https://abf.io/build_lists/1626680
Comment 3 Vladimir Potapov 2014-02-11 11:20:19 MSK
bash-completion-2.1-7-rosa2012.1
urpmi-6.71-51-rosa2012.1
************************** Advisory *************************
Fix bash autocompletion for urpme
*************************************************************
QA Verified