Bug 3727 - [UPDATE REQUEST] drakx-kbd-mouse-x11-0.106
: [UPDATE REQUEST] drakx-kbd-mouse-x11-0.106
Status: RESOLVED WONTFIX
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: High major
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-05 14:15 MSK by Aleksandr Kazantcev
Modified: 2014-10-07 12:23 MSD (History)
4 users (show)

See Also:
RPM Package: https://abf.rosalinux.ru/import/drakx-kbd-mouse-x11
ISO-related:
Bad POT generating:
Upstream:


Attachments
xx3.png (114.58 KB, image/png)
2014-02-07 18:12 MSK, Postnikov Dmitry
Details
xx1.png (140.89 KB, image/png)
2014-02-07 18:12 MSK, Postnikov Dmitry
Details
xx2.png (138.43 KB, image/png)
2014-02-07 18:13 MSK, Postnikov Dmitry
Details
sc1.png (190.42 KB, image/png)
2014-02-16 23:29 MSK, Postnikov Dmitry
Details
Patch to debug card.pm (378 bytes, patch)
2014-03-03 14:18 MSK, Andrey Ponomarenko
Details
dd1.png (228.16 KB, image/png)
2014-03-11 11:33 MSK, Postnikov Dmitry
Details
card-patch.txt (9.96 KB, text/plain)
2014-03-11 11:34 MSK, Postnikov Dmitry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aleksandr Kazantcev 2014-02-05 14:15:45 MSK
New version
Comment 1 Aleksandr Kazantcev 2014-02-05 14:18:46 MSK
https://abf.rosalinux.ru/build_lists/1587523
https://abf.rosalinux.ru/build_lists/1587524

Advisory: This update improve funcionality and fix some errors in XFdrake:

 * check if driver supports KMS w/o using display_driver_helper utility
 * set xdriver=vesa and nomodeset for vesa driver
 * do not generate xorg.conf for KMS drivers
 * moved monitor configs parts to xorg.conf.d/10-monitor.conf
 * replaced the video card chooser with the driver chooser (free, non-free one and vesa)
 * fixed video driver chooser if DRIVER2 is available
 * "Automatically start X11" is selected by default
 * do not generate 10_monitor.conf for pnp monitor
 * moved Device section back to xorg.conf
 * removed ServerFlags section from 10_monitor.conf
 * do not generate xorg.conf for vesa driver
 * do not run resolution chooser for pnp monitor
Comment 2 Vladimir Potapov 2014-02-07 12:29:28 MSK
The update route to extended testing
Comment 3 Postnikov Dmitry 2014-02-07 18:12:01 MSK
Created attachment 2626 [details]
xx3.png

With the new XFdrake now I can not select a driver for your Nvidia Optimus. Shows only 2 Vesa and all.
Earlier it was shown also to Vesa, but you can scroll through and select Nvidia-Current. And then all was. Now there is no such possibility. :(
Comment 4 Postnikov Dmitry 2014-02-07 18:12:48 MSK
Created attachment 2627 [details]
xx1.png

Old XFdrake detect Vesa and have scrolling.
Comment 5 Postnikov Dmitry 2014-02-07 18:13:21 MSK
Created attachment 2628 [details]
xx2.png

Old XFdrake and select Nvidia-Current
Comment 6 Vladimir Potapov 2014-02-07 18:30:38 MSK
(In reply to comment #3)
> Created attachment 2626 [details]
> xx3.png
> 
> With the new XFdrake now I can not select a driver for your Nvidia Optimus.
> Shows only 2 Vesa and all.
> Earlier it was shown also to Vesa, but you can scroll through and select
> Nvidia-Current. And then all was. Now there is no such possibility. :(
**********************
QA Denied
Comment 7 Aleksandr Kazantcev 2014-02-07 18:53:54 MSK
This is not a bug - we prevent user break system.

In future version we add Optium 'out of the box'
Comment 8 Postnikov Dmitry 2014-02-07 19:28:40 MSK
On my HD7770 not install fglrx. I don't have hybride graphics.
FAIL
See screencast http://cdn.2safe.com/719303033759/screenXFd1.avi
Comment 9 Andrey Ponomarenko 2014-02-10 18:19:35 MSK
(In reply to comment #8)
> On my HD7770 not install fglrx. I don't have hybride graphics.
> FAIL
> See screencast http://cdn.2safe.com/719303033759/screenXFd1.avi

Fixed in 107
Comment 10 Postnikov Dmitry 2014-02-10 18:26:43 MSK
(In reply to comment #3)
> Created attachment 2626 [details]
> xx3.png
> 
> With the new XFdrake now I can not select a driver for your Nvidia Optimus.
> Shows only 2 Vesa and all.
> Earlier it was shown also to Vesa, but you can scroll through and select
> Nvidia-Current. And then all was. Now there is no such possibility. :(

My hardware: https://corpwiki.rosalinux.ru/User:Dmitry.postnikov/Hardware
Comment 13 Andrey Ponomarenko 2014-02-14 21:09:35 MSK
XFdrake 109: fixed a bug with selecting of a proprietary driver after a free one

https://abf.rosalinux.ru/build_lists/1639138
https://abf.rosalinux.ru/build_lists/1639139
Comment 14 Vladimir Potapov 2014-02-16 20:31:14 MSK
If you need new QA, please, set qa_verified flag to "?"
Comment 15 Postnikov Dmitry 2014-02-16 23:05:08 MSK
(In reply to comment #13)
> XFdrake 109: fixed a bug with selecting of a proprietary driver after a free
> one
> 
> https://abf.rosalinux.ru/build_lists/1639138
> https://abf.rosalinux.ru/build_lists/1639139

==============
warning: /var/cache/urpmi/rpms/drakx-kbd-mouse-x11-0.109-1-rosa2012.1.x86_64.rpm: Заголовок V4 RSA/SHA1 подпись: NOKEY, key ID 16a853e7                             
Следующий пакет имеет неверную подпись:
/var/cache/urpmi/rpms/drakx-kbd-mouse-x11-0.109-1-rosa2012.1.x86_64.rpm: Неверная подпись (NOT OK (no key): /var/cache/urpmi/rpms/drakx-kbd-mouse-x11-0.109-1-rosa2012.1.x86_64.rpm: Заголовок V4 RSA/SHA1 подпись: NOKEY, key ID 16a853e7)
Продолжить установку? (y/N) y
==============
Comment 16 Postnikov Dmitry 2014-02-16 23:29:02 MSK
Created attachment 2661 [details]
sc1.png

(In reply to comment #13)
> XFdrake 109: fixed a bug with selecting of a proprietary driver after a free
> one
> 
> https://abf.rosalinux.ru/build_lists/1639138
> https://abf.rosalinux.ru/build_lists/1639139

No, not detect Optimus+Intel.
See att.

====================
[pastordi@mindlife2-red64efi ~]$ rpm -qa | grep drakx-kbd
drakx-kbd-mouse-x11-0.109-1-rosa2012.1.x86_64
[pastordi@mindlife2-red64efi ~]$ 
[pastordi@mindlife2-red64efi ~]$ lspci -knn | grep -A 3 VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)
	Subsystem: Acer Incorporated [ALI] Device [1025:064b]
	Kernel driver in use: i915
	Kernel modules: i915
--
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF117M [GeForce 610M/710M / GT 620M/625M/630M/720M] [10de:1140] (rev a1)
	Subsystem: Acer Incorporated [ALI] GeForce GT 620M [1025:064c]
	Kernel modules: nvidiafb, nouveau
02:00.0 Ethernet controller [0200]: Broadcom Corporation NetLink BCM57785 Gigabit Ethernet PCIe [14e4:16b5] (rev 10)
[pastordi@mindlife2-red64efi ~]$ 
====================
Comment 17 Andrey Ponomarenko 2014-03-03 14:18:13 MSK
Created attachment 2689 [details]
Patch to debug card.pm

Please apply the attached patch card.pm.debug.patch (compatible with v.109), run XFdrake and attach its stdout to this bug.

Thanks.
Comment 18 Andrey Ponomarenko 2014-03-03 14:19:38 MSK
(In reply to comment #17)
> Created attachment 2689 [details]
> Patch to debug card.pm
> 
> Please apply the attached patch card.pm.debug.patch (compatible with v.109),
> run XFdrake and attach its stdout to this bug.
> 
> Thanks.

To apply patch type: sudo patch -p0 < ./card.pm.debug.patch
Comment 19 Vladimir Potapov 2014-03-07 11:12:34 MSK
(In reply to comment #18)
> (In reply to comment #17)
> > Created attachment 2689 [details]
> > Patch to debug card.pm
> > 
> > Please apply the attached patch card.pm.debug.patch (compatible with v.109),
> > run XFdrake and attach its stdout to this bug.
> > 
> > Thanks.
> 
> To apply patch type: sudo patch -p0 < ./card.pm.debug.patch

Do create new containers with patch?
Comment 20 Andrey Ponomarenko 2014-03-07 11:38:03 MSK
(In reply to comment #19)
> 
> Do create new containers with patch?

No, just apply the patch and run XFdrake on the optimus machine and then attach the console std output of the program to this bug.
Comment 21 Vladimir Potapov 2014-03-07 11:52:03 MSK
(In reply to comment #20)
> (In reply to comment #19)
> > 
> > Do create new containers with patch?
> 
> No, just apply the patch and run XFdrake on the optimus machine and then
> attach the console std output of the program to this bug.

Мммм... typically, qa_flag set up after created new containers for check...
Comment 22 Andrey Ponomarenko 2014-03-07 15:10:14 MSK
(In reply to comment #21)
> (In reply to comment #20)
> > (In reply to comment #19)
> > > 
> > > Do create new containers with patch?
> > 
> > No, just apply the patch and run XFdrake on the optimus machine and then
> > attach the console std output of the program to this bug.
> 
> Мммм... typically, qa_flag set up after created new containers for check...

Sorry for this, I've just wanted to draw attention to the bug.
Comment 23 Postnikov Dmitry 2014-03-11 11:33:36 MSK
Created attachment 2708 [details]
dd1.png

(In reply to comment #18)
> (In reply to comment #17)
> > Created attachment 2689 [details]
> > Patch to debug card.pm
> > 
> > Please apply the attached patch card.pm.debug.patch (compatible with v.109),
> > run XFdrake and attach its stdout to this bug.
> > 
> > Thanks.
> 
> To apply patch type: sudo patch -p0 < ./card.pm.debug.patch

I apply patch.
Comment 24 Postnikov Dmitry 2014-03-11 11:34:39 MSK
Created attachment 2709 [details]
card-patch.txt

(In reply to comment #17)
> Created attachment 2689 [details]
> Patch to debug card.pm
> 
> Please apply the attached patch card.pm.debug.patch (compatible with v.109),
> run XFdrake and attach its stdout to this bug.
> 
> Thanks.

This stdout from XFdrake.
Comment 25 Vladimir Potapov 2014-03-13 11:42:38 MSK
I close the request until you have created new containers
Comment 26 Andrey Ponomarenko 2014-06-16 18:10:06 MSD
Update to 0.109: http://bugs.rosalinux.ru/show_bug.cgi?id=4095