Bug 3720 - [UPDATE REQUEST] GTK+2 version 2.24.22
: [UPDATE REQUEST] GTK+2 version 2.24.22
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-03 14:10 MSK by Eugene Shatokhin
Modified: 2014-02-06 11:49 MSK (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Shatokhin 2014-02-03 14:10:18 MSK
Upstream update to 2.24.22 + fix for GNOME bug #723366 ("GtkFileChooser crashes due to a signal connection left behind by GtkMountOperation") found by D.Postnikov.
Comment 1 Eugene Shatokhin 2014-02-03 14:12:04 MSK
Advisory:
GTK+2 has been updated to the latest upstream version 2.24.22. Most significant fixes since 2.24.20:
* GNOME bug #513812: Optimize gdk_cairo_set_source_pixbuf() alpha multiplication loop
* GNOME bug #536767: gtksignal.h includes gtk.h
* GNOME bug #703789: gtk.immodules still referenced after switch to immodules.cache
* Support building with automake 1.14
* Look in /usr/share/gtk-2.0 for the default gtkrc file
Besides that, the following problem has been fixed:
* GNOME bug #723366: GtkFileChooser crashes due to a signal connection left behind by GtkMountOperation

Build lists:
i586:
https://abf.rosalinux.ru/build_lists/1607625
x86_64:
https://abf.rosalinux.ru/build_lists/1607626
Comment 2 Vladimir Potapov 2014-02-04 09:34:00 MSK
The update route to extended testing
Comment 3 Postnikov Dmitry 2014-02-06 10:27:39 MSK
***********************
Extended testing report
***********************
All work without regression.
Comment 4 Vladimir Potapov 2014-02-06 10:36:37 MSK
gtk+2.0-2.24.22-1-rosa2012.1
************************ Advisory **********************
GTK+2 has been updated to the latest upstream version 2.24.22. 
************************ Changelist ********************
Most significant fixes since 2.24.20:
* GNOME bug #513812: Optimize gdk_cairo_set_source_pixbuf() alpha multiplication loop
* GNOME bug #536767: gtksignal.h includes gtk.h
* GNOME bug #703789: gtk.immodules still referenced after switch to immodules.cache
* Support building with automake 1.14
* Look in /usr/share/gtk-2.0 for the default gtkrc file
Besides that, the following problem has been fixed:
* GNOME bug #723366: GtkFileChooser crashes due to a signal connection left behind by GtkMountOperation
***********************************************************
QA Verified