Bug 3708 - Speed up "urpmq --fuzzy" in case of many matches
: Speed up "urpmq --fuzzy" in case of many matches
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks: 3707
  Show dependency treegraph
 
Reported: 2014-01-29 18:06 MSK by Denis Silakov
Modified: 2014-02-11 11:27 MSK (History)
3 users (show)

See Also:
RPM Package: urpmi
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Silakov 2014-01-29 18:06:04 MSK
Currently requests like "urpmq -ya java" work very slow and eat a lot of memory (see bug #3707). This is caused by one of the old patches which seems to be unneeded now. However, it's better to test if there are any regressions if we drop that patch.
Comment 1 Denis Silakov 2014-01-29 18:07:28 MSK
Advisory:

Speed up "urpmq --fuzzy" and "urpmq -a" requests.

Build lists:
https://abf.io/build_lists/1606098
https://abf.io/build_lists/1606099
Comment 2 Vladimir Potapov 2014-02-04 06:59:22 MSK
The update route to extended testing
Comment 3 Postnikov Dmitry 2014-02-06 14:01:42 MSK
(In reply to comment #2)
> The update route to extended testing

**********************
Extended testing report
**********************

On all 32 & 64 bit system work fine!

Before update:
=====================
time urpmq -ya java

real    2m16.986s
user    2m16.836s
sys     0m0.039s
====================
After update:

=========
time urpmq -ya java

real    0m1.145s
user    0m1.114s
sys     0m0.028s
=========
Comment 4 Vladimir Potapov 2014-02-06 17:51:50 MSK
urpmi-6.71-50-rosa2012.1
************************** Advisory *********************
Speed up "urpmq --fuzzy" and "urpmq -a" requests.
*********************************************************
QA Verified