Bug 3680 - [UPDATE REQUEST] mesa-9.2.4-4
: [UPDATE REQUEST] mesa-9.2.4-4
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on: 3650
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-23 15:48 MSK by Aleksandr Kazantcev
Modified: 2014-02-04 11:00 MSK (History)
2 users (show)

See Also:
RPM Package: https://abf.rosalinux.ru/import/mesa
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments
ss1 (247.06 KB, image/png)
2014-01-30 14:26 MSK, Vladimir Potapov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aleksandr Kazantcev 2014-01-23 15:48:17 MSK
Use DRI instead Gallium for Intel i915/945
Comment 1 Aleksandr Kazantcev 2014-01-23 15:50:36 MSK
https://abf.rosalinux.ru/build_lists/1543916
https://abf.rosalinux.ru/build_lists/1543917

Advisory: This update fix bug 3650. We did disable Gallium software 3D render and use internal DRI reneder from driver for i915/945 chipset.
Comment 2 Vladimir Potapov 2014-01-30 13:56:37 MSK
I install to x64 system.

Следующие пакеты будут удалены для обновления остальных:
libalsa-plugins-1.0.27-1-rosa2012.1.i586
 (из-за отсутствия libavcodec.so.55(LIBAVCODEC_55),
  из-за отсутствия libavcodec.so.55)
libavcodec55-2.1-2plf-plf2012.1.i586
 (из-за отсутствия libva.so.1)
libdri-drivers-9.2.4-3-rosa2012.1.i586
 (из-за неудовлетворённости mesa == 9.2.4-3:2012.1)
libgl1-9.2.4-3-rosa2012.1.i586
 (из-за неудовлетворённости libdri-drivers == 9.2.4-3:2012.1)
libva1-1.1.0-1-rosa2012.1.i586
 (из-за отсутствия libGL.so.1)
Comment 3 Aleksandr Kazantcev 2014-01-30 13:59:14 MSK
You has i586 repos and you NEED add i586 containers for update too.
Comment 4 Vladimir Potapov 2014-01-30 14:26:53 MSK
Created attachment 2611 [details]
ss1

i586 repos present.
Comment 5 Aleksandr Kazantcev 2014-01-30 14:28:15 MSK
You need add both containers on 64 bit - i586 and x86_64 becouse you has mesa i586 package installed too
Comment 6 Vladimir Potapov 2014-01-30 14:30:30 MSK
(In reply to comment #5)
> You need add both containers on 64 bit - i586 and x86_64 becouse you has
> mesa i586 package installed too
O! Sorry, I forgot...
Comment 7 Vladimir Potapov 2014-01-30 15:45:43 MSK
/usr/bin/blinking-teapot
Unable to open shader file /usr/lib64/mesa-demos-data/blinking-teapot.vert
Unable to open shader file /usr/lib64/mesa-demos-data/blinking-teapot.frag
blinking-teapot: shaderutil.c:192: LinkShaders3: Assertion `vertShader || fragShader' failed.
Аварийный останов (слепок снят)
Comment 8 Aleksandr Kazantcev 2014-01-30 15:53:15 MSK
In 3 release work?
Comment 9 Vladimir Potapov 2014-01-31 12:35:16 MSK
(In reply to comment #8)
> In 3 release work?
Not. But many error in demos is not good.
Comment 10 Aleksandr Kazantcev 2014-01-31 13:08:32 MSK
We need push update, because now we has non-working dri on i915/945/950 chipsets. If we have no regress, i think update is correct. Non-working test - may be, becouse some things not support on some cards. 


You may install Fedora 20 and mesa and try test again. Or in Ubuntu. If on this system test present and failed - this is normal. I think as in another tests no reason has 100% test pass - this is imposible.
Comment 11 Vladimir Potapov 2014-01-31 13:21:00 MSK
(In reply to comment #10)
> We need push update, because now we has non-working dri on i915/945/950
> chipsets. If we have no regress, i think update is correct. Non-working test
> - may be, becouse some things not support on some cards. 
> 
> 
> You may install Fedora 20 and mesa and try test again. Or in Ubuntu. If on
> this system test present and failed - this is normal. I think as in another
> tests no reason has 100% test pass - this is imposible.
I don't denied the update, it's only note.
Comment 12 Vladimir Potapov 2014-01-31 14:29:06 MSK
mesa-9.2.4-4-rosa2012.1
********************** Advisory *******************
This update fix bug 3650. We did disable Gallium software 3D render and use internal DRI reneder from driver for i915/945 chipset.
***************************************************
QA Verified