Bug 3635 - command-not-found is silent
: command-not-found is silent
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: i586 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-17 20:42 MSK by Sylvainsjc
Modified: 2014-01-27 12:23 MSK (History)
1 user (show)

See Also:
RPM Package: command-not-found
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sylvainsjc 2014-01-17 20:42:32 MSK
Description of problem:

After installing Package "command-not-found", no more results are given for a unknown or erroneous command

I type "toto" : no result, not even "unknown command"
Same for any wrong or non-existent command
Comment 1 Denis Silakov 2014-01-23 23:18:50 MSK
Can't confirm at the moment, just updated my system to the latest versions and works fine.

What does "cnf toto" say in your system?
Comment 2 Sylvainsjc 2014-01-25 14:39:36 MSK
(In reply to comment #1)
> What does "cnf toto" say in your system?

Absolutely nothing as you can see below :

[root@ThinkPad-R61 ~]# cat /etc/release 
ROSA Desktop Fresh R2 release 2012.1 for i586
[root@ThinkPad-R61 ~]# urpmi --auto-update
le média « main » est à jour
le média « main updates » est à jour
le média « main testing » est à jour
le média « contrib » est à jour
le média « contrib updates » est à jour
le média « non-free » est à jour
le média « non-free updates » est à jour
le média « restricted » est à jour
le média « restricted updates » est à jour
Les paquetages sont à jour
[root@ThinkPad-R61 ~]# rpm -qa | grep command
command-not-found-1.2-3-rosa2012.1.noarch
command-not-found-data-2013.02.21-2-rosa2012.1.noarch
[root@ThinkPad-R61 ~]# cnf toto
[root@ThinkPad-R61 ~]# toto
[root@ThinkPad-R61 ~]# cnf --help
usage: cnf [-h] [command]

Rechercher des commandes dans le dépôt. Pour rappel : 127 est un code de
sortie de programme normal !

positional arguments:
  command     Commande à rechercher.

optional arguments:
  -h, --help  show this help message and exit

Dans le cas d'une proposition unique de paquet contenant la commande donnée,
cnf vous affichera une proposition de commande pour l'installer et vous
demandera si vous souhaitez le faire immédiatement (la question est suivie des
options et o/N). Si vous ne voulez pas que cnf propose quoi que ce soit à
l'utilisateur - mettez la variable d'environnement
COMMAND_NOT_FOUND_TURN_OFF_INSTALL_PROMPT à 1.
[root@ThinkPad-R61 ~]#
Comment 3 Sylvainsjc 2014-01-25 15:18:51 MSK
The problem is only on 32 bits which has version command-not-found-1.2-3
It works well on 64 bits which has version command-not-found-1.2-4

if I install the package 1.2.4 on 32 bits desktop, it works
Comment 4 Denis Silakov 2014-01-27 12:23:42 MSK
Indeed. I have built cnf-1.2-4 for i586 and it seems to work fine. The package is available at ABF repositories, but it can take some time for it to appear in mirrors.