Bug 3624 - Add urpmicfg.d support for urpmi
: Add urpmicfg.d support for urpmi
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: unspecified
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-17 11:33 MSK by Denis Silakov
Modified: 2014-01-30 11:32 MSK (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Silakov 2014-01-17 11:33:32 MSK
urpmi is often compared with its analogues like yum and apt and one of the features missing in our software manager is possibility to put descriptions of different repositories to different files, without introducing a big mess in /etc/urpmi/urpmi.cfg.

At the same time yum, for example, provides possibility to put *repo files to /etc/yum/repos.d folder (or any other folder you set in configuration). So you can get different files for repositories of different purposes. And if you want to add/remove a set of repositories to you system, it can just add/remove a file from /etc/yum/repos.d.

The first attempt to implement analogue of /etc/yum.repos.d was pushed to the testing repo of Desktop Fresh more thatn month ago and up to now there were no complains. So I think it is time to send it to QA.
Comment 1 Denis Silakov 2014-01-17 11:37:14 MSK
Advisory:
Added support for additional repo configuration files in urpmicdg.d.

Build lists:
https://abf.io/build_lists/1522058
https://abf.io/build_lists/1522057

Note for testers:
Default urpmi behavior should not be affected. If you add a new media by means of urpmi.addmedia or drakrpm-edit-media, it will be simply added to urpmi.cfg.

However, you can now create *cfg files in /etc/urpmi/urpmicfg.d folder (the folder should be created manually atm). *cfg files should be of the same format as urpmi.cfg except the global options section - there is no need in it in /etc/urpmi/urpmicfg.d/*cfg files.

Urpmi, Rpmdrake & other tools will read information from these cfg files in addition to urpmi.cfg. If you invoke manager of Media Sources (drakrpm-edit-media), you should be able to modify parameters of media specified in /etc/urpmi/urpmicfg.d/*cfg files (to be sure, these parameters will be updated in the corresponding cfg file).
Comment 2 Vladimir Potapov 2014-01-24 12:56:23 MSK
Assigning order the sources causing me questions.
I have locale repos. I create file locale.cfg in /etc/urpmi/urpmicfg.d folder.
Locale soursec added AFTER remote sources. 
But I want the system to refer to the local repository before remote!
I run GUI and rearrange sources, but it's order don't save.
Comment 3 Vladimir Potapov 2014-01-24 12:58:03 MSK
The update route to extended testing
Comment 4 Denis Silakov 2014-01-24 13:00:46 MSK
(In reply to comment #2)
> Assigning order the sources causing me questions.
> I have locale repos. I create file locale.cfg in /etc/urpmi/urpmicfg.d
> folder.
> Locale soursec added AFTER remote sources. 
> But I want the system to refer to the local repository before remote!
> I run GUI and rearrange sources, but it's order don't save.

Yes, in the current implementation the order is not preserved, since urpmi first reads urpmi.cfg and then files from urpmicfg.d folder. But the order of repositories should not affect anything, urpmi doesn't take repository order into account when choosing packages to install.
Comment 5 Postnikov Dmitry 2014-01-29 11:12:17 MSK
*************************
Extended testing report
*************************
We tested on 4 computers, 64&32bit, KDE & Gnome. No regression.
Comment 6 Vladimir Potapov 2014-01-29 13:04:26 MSK
urpmi-6.71-48-rosa2012.1
************************ Advisory ****************
Added support for additional repo configuration files in urpmicfg.d
*************************************************
QA Verified