Bug 3602 - ath5k broken after suspend-to-ram
: ath5k broken after suspend-to-ram
Status: RESOLVED WORKSFORME
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-14 23:23 MSK by Sylvainsjc
Modified: 2015-04-27 01:10 MSD (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
inxi (1.92 KB, text/plain)
2014-01-14 23:23 MSK, Sylvainsjc
Details
journalctl (306.57 KB, text/plain)
2014-01-14 23:23 MSK, Sylvainsjc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sylvainsjc 2014-01-14 23:23:00 MSK
Created attachment 2515 [details]
inxi

Description of problem:

After suspend-to-ram, Wifi isn't working anymore, only way to have it back is reboot

Tried workaround with SUSPEND_MODULES="iwlwifi" or SUSPEND_MODULES="ath5k" in /etc/pm/config.d/ but ineffective

journalctl give this error :
janv. 12 23:47:51 marc kernel: ath5k 0000:06:00.0: Refused to change power state, currently in D3

On another Desktop with ROSA LXDE 32 bits, the same Wifi card resumes correctly from suspend-to-ram

I attach journalctl and inxi -F results
Comment 1 Sylvainsjc 2014-01-14 23:23:48 MSK
Created attachment 2516 [details]
journalctl
Comment 2 Aleksandr Kazantcev 2014-01-14 23:34:17 MSK
You need try change powersaving mode in BIOS first.
Comment 3 Sylvainsjc 2014-01-15 00:34:45 MSK
(In reply to comment #2)
> You need try change powersaving mode in BIOS first.

Hi Aleksandr, this was done as you can see in french subject below 
http://forum.rosalab.ru/fr/viewtopic.php?f=36&t=2905

Switch to S1 : it works on resume but the system isn't fully stopped
Switch to S3 : problem with ath5k on resume
Comment 4 Eugene Shatokhin 2014-01-15 11:23:27 MSK
Does reloading of ath5k module help? I mean,

# modprobe -r ath5k && modprobe ath5k

Besides that, could you please check if the problem persists in 3.12 kernel? You can install that kernel version from this repository:

http://abf-downloads.rosalinux.ru/kernels_3_12x_personal/repository/rosa2012.1/x86_64/main/release/

If the problem is in the kernel and it is fixed there, we could try to identify and backport the fix to 3.10 as well.
Comment 5 Sylvainsjc 2014-01-16 22:52:34 MSK
Well, with the command "modprobe -r ath5k && modprobe ath5k"

Before suspend-to-ram, one can see Wifi goes down and then goes up
After suspend-to-ram, it cause a kernel panic

Same behavior with kernel 3.12 :/

With ROSA Marathon LiveCD session, suspend and resume works fine on this desktop
Comment 6 Eugene Shatokhin 2014-01-17 10:46:41 MSK
(In reply to comment #5)
> Well, with the command "modprobe -r ath5k && modprobe ath5k"
> 
> Before suspend-to-ram, one can see Wifi goes down and then goes up
> After suspend-to-ram, it cause a kernel panic

I see.

Could you obtain the system log (dmesg) after the crash or at least take a photo of the screen with the info about that kernel panic and post it here?
Comment 7 Eugene Shatokhin 2014-01-20 12:00:38 MSK
Please attach also the output of 'lcpci -vnn' here.
Comment 8 Sylvainsjc 2014-01-20 13:39:22 MSK
(In reply to comment #7)
> Please attach also the output of 'lcpci -vnn' here.

Hi,

Here the result of 'lcpci -vnn'
http://pastebin.com/Jd2EKQVM

Here the result of dmesg
http://pastebin.com/XuGQjPUU
Comment 9 Eugene Shatokhin 2014-01-20 18:54:18 MSK
I have reported the problem to the maintainers of ath5k. Let's see what they say.

A similar problems occurred in the past (e.g. https://www.mail-archive.com/ath5k-devel@lists.ath5k.org/msg04964.html) but I have found no suitable solutions in these reports so far.

By the way, could you try 'modprobe -r ath5k && modprobe ath5k' once again and if kernel crash occurs, just take a photo of the screen with the crash info and post it here? The system log (dmesg) does not contain crash info unfortunately.
Comment 10 Eugene Shatokhin 2014-01-21 11:39:15 MSK
Also, could you try live images of recent Fedora or Ubuntu releases and check if the problem shows up?

Thanks for you patience.
Comment 11 Eugene Shatokhin 2014-01-23 13:53:18 MSK
Well, the maintainer of ath5k replied but it is not all that helpful.
https://lists.ath5k.org/pipermail/ath5k-devel/2014-January/005527.html

He suggests to perform a bisection to identify which kernel change (if any) has caused this problem. 

Not a silver bullet, but if you can help, this is doable. 

What is needed is to try the kernels I'll be building and reporting if the bug shows up there. This may take time but, with a bit of luck, we may identify the cause of the problem as a result.

I have prepared the versions of kernel 3.10 and 3.2 without most of ROSA/Mandriva-specific patches. Could you check if the problem shows up there?

Here are the rpms:
3.10:
http://cdn.2safe.com/696304033760/kernel-desktop-3.10.27-1rosa8bb495e-1-1-rosa2012.1.x86_64.rpm
http://cdn.2safe.com/696302033760/kernel-desktop-devel-3.10.27-1rosa8bb495e-1-1-rosa2012.1.x86_64.rpm

3.2:
http://cdn.2safe.com/696306033760/kernel-desktop-3.2.0-1rosa805a6af-1-1-rosa2012.1.x86_64.rpm
http://cdn.2safe.com/696300033760/kernel-desktop-devel-3.2.0-1rosa805a6af-1-1-rosa2012.1.x86_64.rpm

Please attach the output of dmesg for these, no matter whether the bug is there or not.

You may also need to temporarily run your system with the opensource video driver (radeon) rather than fglrx to avoid potential problems with the latter.
Comment 12 Sylvainsjc 2014-01-25 14:52:44 MSK
Unfortunately the user on the french forum who had this problem no longer provides new.
We wait a bit but if he's gone, we will not be able to progress :/
Comment 13 Denis Silakov 2015-04-27 01:10:30 MSD
It looks like we had no chance to test this deeply. Let's optimistically close this as "worksforme". Feel free to reopen if you have a reproducer for modern Fresh R5.