Bug 3601 - Add start/stop script callbacks to rpm and fix several minor issues
: Add start/stop script callbacks to rpm and fix several minor issues
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-14 17:33 MSK by Denis Silakov
Modified: 2014-01-31 12:18 MSK (History)
3 users (show)

See Also:
RPM Package: rpm
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Silakov 2014-01-14 17:33:56 MSK
Implementation of start/stop script callbacks in rpm is potentially useful and already implemented in cooker. Let's merge it to Desktop Fresh; this will simplify merge of different fixes to perl-URPM that also exist in cooker.
Comment 1 Denis Silakov 2014-01-14 17:35:39 MSK
Advisory:
Added start/stop callbacks to rpm, fixed some potential issues (there are no known examples of real problems caused by them, but let's guarantee that we won't have them in future).

Build lists:
https://abf.rosalinux.ru/build_lists/1517759
https://abf.rosalinux.ru/build_lists/1517779

Note for testers: after this update, users won't see any changes. But let's ensure that there are no regressions.
Comment 2 Denis Silakov 2014-01-15 12:40:01 MSK
slight update - we have also created a separate perl-RPMBDB module

Advisory:
Added start/stop callbacks to rpm, add separate perl-RPMBDB module (to replace some functions from perl-URPM in future), fixed some potential issues (there are no known examples of real problems caused by them, but let's guarantee that we won't have them in future).

Build lists:
https://abf.io/build_lists/1522091
https://abf.io/build_lists/1522090

Note for testers: after this update, users won't see any changes. But let's ensure that there are no regressions.
Comment 3 Vladimir Potapov 2014-01-22 17:18:34 MSK
The update route to extended testing
Comment 4 Postnikov Dmitry 2014-01-29 11:12:10 MSK
*************************
Extended testing report
*************************
We tested on 4 computers, 64&32bit, KDE & Gnome. No regression.
Comment 5 Vladimir Potapov 2014-01-29 13:02:12 MSK
rpm-5.4.10-22-rosa2012.1
************************* Advisory **********************
Added start/stop callbacks to rpm, add separate perl-RPMBDB module (to replace some functions from perl-URPM in future), fixed some potential issues (there are no known examples of real problems caused by them, but let's guarantee that we won't have them in future).
*********************************************************
QA Verified