Bug 3562 - [UPDATE REQUEST] systemd-208
: [UPDATE REQUEST] systemd-208
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: High major
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks: 3599
  Show dependency treegraph
 
Reported: 2014-01-12 04:02 MSK by Aleksandr Kazantcev
Modified: 2014-02-11 12:22 MSK (History)
5 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments
report.odt (16.24 KB, application/vnd.oasis.opendocument.text)
2014-01-15 15:17 MSK, Postnikov Dmitry
Details
Xorg.0.log (8.28 KB, text/x-log)
2014-01-15 15:17 MSK, Postnikov Dmitry
Details
syslog (802.26 KB, application/octet-stream)
2014-01-15 15:18 MSK, Postnikov Dmitry
Details
dmesg (58.13 KB, application/octet-stream)
2014-01-15 15:18 MSK, Postnikov Dmitry
Details
report1.odt (375.61 KB, application/vnd.oasis.opendocument.text)
2014-01-23 23:40 MSK, Postnikov Dmitry
Details
report2.odt (35.54 KB, application/vnd.oasis.opendocument.text)
2014-01-23 23:40 MSK, Postnikov Dmitry
Details
report3.odt (15.71 KB, application/vnd.oasis.opendocument.text)
2014-01-23 23:41 MSK, Postnikov Dmitry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aleksandr Kazantcev 2014-01-12 04:02:14 MSK
Update systemd to 208 and update related package
Comment 1 Aleksandr Kazantcev 2014-01-12 04:06:17 MSK
systemd
https://abf.rosalinux.ru/build_lists/1514818
https://abf.rosalinux.ru/build_lists/1514818

initscripts
https://abf.rosalinux.ru/build_lists/1514458
https://abf.rosalinux.ru/build_lists/1514458

plymouth
https://abf.rosalinux.ru/build_lists/1514450
https://abf.rosalinux.ru/build_lists/1514450

Advisory: This update bring new version of systemd - 208. Many fixes and changes before previous 204 release. You may read about in changelog: http://upstream-tracker.org/changelogs/systemd/208/changelog.html

Also initscrips update with drop mandriva-everytime service and clean rc.sysinit script for improve boot time.

Plymouth update to latest version for properly work with latest systemd.
Comment 4 Aleksandr Kazantcev 2014-01-13 10:10:51 MSK
Wrong previous link to systemd.

Correct link:

https://abf.rosalinux.ru/build_lists/1516410
https://abf.rosalinux.ru/build_lists/1516411
Comment 5 Aleksandr Kazantcev 2014-01-13 10:34:53 MSK
Fixed DKMS

https://abf.rosalinux.ru/build_lists/1516424
https://abf.rosalinux.ru/build_lists/1516425

Enable dkms allready if preset missing
Comment 6 Vladimir Potapov 2014-01-13 14:30:41 MSK
The update route to extended testing
Comment 8 Aleksandr Kazantcev 2014-01-14 12:28:04 MSK
Please note that correct version of dkms is dkms-2.0.19-31 !
Comment 9 Vladimir Potapov 2014-01-14 12:37:13 MSK
(In reply to comment #8)
> Please note that correct version of dkms is dkms-2.0.19-31 !
Alexander, please write last version all needed for test containers!
Comment 11 Postnikov Dmitry 2014-01-15 15:17:02 MSK
Created attachment 2529 [details]
report.odt

***************************
Extended testing report
***************************
Comment 12 Postnikov Dmitry 2014-01-15 15:17:22 MSK
Created attachment 2530 [details]
Xorg.0.log
Comment 13 Postnikov Dmitry 2014-01-15 15:18:23 MSK
Created attachment 2531 [details]
syslog
Comment 14 Postnikov Dmitry 2014-01-15 15:18:35 MSK
Created attachment 2532 [details]
dmesg
Comment 15 Vladimir Potapov 2014-01-15 15:21:59 MSK
(In reply to comment #11)
> Created attachment 2529 [details]
> report.odt
> 
> ***************************
> Extended testing report
> ***************************

********************
QA Denied
Comment 16 Aleksandr Kazantcev 2014-01-15 16:16:20 MSK
First error (with dbus) - try check polkitd running. I see this is error with disabling polkitd (may be after Gnome)...
Comment 17 Aleksandr Kazantcev 2014-01-22 22:59:51 MSK
systemd-208

https://abf.rosalinux.ru/build_lists/1543729
https://abf.rosalinux.ru/build_lists/1543730

dkms-2.0.19-31

https://abf.rosalinux.ru/build_lists/1516424
https://abf.rosalinux.ru/build_lists/1516425

initscripts
https://abf.rosalinux.ru/build_lists/1514458
https://abf.rosalinux.ru/build_lists/1514459

plymouth
https://abf.rosalinux.ru/build_lists/1514450
https://abf.rosalinux.ru/build_lists/1514451


Advisory: This update bring new version of systemd - 208. Many fixes and changes before previous 204 release. You may read about in changelog: http://upstream-tracker.org/changelogs/systemd/208/changelog.html

Also initscrips update with drop mandriva-everytime service and clean rc.sysinit script for improve boot time.

Plymouth update to latest version for properly work with latest systemd.

Add dkms service.
Comment 18 Vladimir Potapov 2014-01-23 05:04:29 MSK
The update route to extended testing
Comment 19 Postnikov Dmitry 2014-01-23 23:40:26 MSK
Created attachment 2585 [details]
report1.odt

Report1
Comment 20 Postnikov Dmitry 2014-01-23 23:40:47 MSK
Created attachment 2586 [details]
report2.odt

Report2
Comment 21 Postnikov Dmitry 2014-01-23 23:41:13 MSK
Created attachment 2587 [details]
report3.odt

Report3
Comment 22 Postnikov Dmitry 2014-01-23 23:42:12 MSK
(In reply to comment #17)
> systemd-208
> 
> https://abf.rosalinux.ru/build_lists/1543729
> https://abf.rosalinux.ru/build_lists/1543730
> 
> dkms-2.0.19-31
> 
> https://abf.rosalinux.ru/build_lists/1516424
> https://abf.rosalinux.ru/build_lists/1516425
> 
> initscripts
> https://abf.rosalinux.ru/build_lists/1514458
> https://abf.rosalinux.ru/build_lists/1514459
> 
> plymouth
> https://abf.rosalinux.ru/build_lists/1514450
> https://abf.rosalinux.ru/build_lists/1514451
> 
> 
> Advisory: This update bring new version of systemd - 208. Many fixes and
> changes before previous 204 release. You may read about in changelog:
> http://upstream-tracker.org/changelogs/systemd/208/changelog.html
> 
> Also initscrips update with drop mandriva-everytime service and clean
> rc.sysinit script for improve boot time.
> 
> Plymouth update to latest version for properly work with latest systemd.
> 
> Add dkms service.

*****************************
Extended testing report
****************************

See Report1, Report2, Report3
Comment 23 Vladimir Potapov 2014-01-24 04:40:15 MSK
(In reply to comment #21)
> Created attachment 2587 [details]
> report3.odt
> 
> Report3
With new systemd and new nvidia I see string "A Wite for Plymouth Service boot Quit" and break system too. But after reinstall my system the error don't showed.
(I wrote the bug in http://bugs.rosalinux.ru/show_bug.cgi?id=3600#c7)
It seems that this is a random error associated with the new systemd setup :-(
Then I deleted xorg.conf allowed to boot the system and roll back systemd (but it did not solve the problem)
Comment 24 Postnikov Dmitry 2014-01-24 10:14:17 MSK
(In reply to comment #23)
> (In reply to comment #21)
> > Created attachment 2587 [details]
> > report3.odt
> > 
> > Report3
> With new systemd and new nvidia I see string "A Wite for Plymouth Service
> boot Quit" and break system too. But after reinstall my system the error
> don't showed.
> (I wrote the bug in http://bugs.rosalinux.ru/show_bug.cgi?id=3600#c7)
> It seems that this is a random error associated with the new systemd setup
> :-(
> Then I deleted xorg.conf allowed to boot the system and roll back systemd
> (but it did not solve the problem)

This problem not systemd. This problem KDM+Plymouth. The Kdm.service starts earlier than Plymouth-quit-wite.service and stop system boot.
In launchpad adn redhat bagzilla the same bug.
We need pathed KDM or Plymouth.
Comment 25 Vladimir Potapov 2014-01-24 10:21:34 MSK
(In reply to comment #24)
> (In reply to comment #23)
> > (In reply to comment #21)
> > > Created attachment 2587 [details]
> > > report3.odt
> > > 
> > > Report3
> > With new systemd and new nvidia I see string "A Wite for Plymouth Service
> > boot Quit" and break system too. But after reinstall my system the error
> > don't showed.
> > (I wrote the bug in http://bugs.rosalinux.ru/show_bug.cgi?id=3600#c7)
> > It seems that this is a random error associated with the new systemd setup
> > :-(
> > Then I deleted xorg.conf allowed to boot the system and roll back systemd
> > (but it did not solve the problem)
> 
> This problem not systemd. This problem KDM+Plymouth. The Kdm.service starts
> earlier than Plymouth-quit-wite.service and stop system boot.
> In launchpad adn redhat bagzilla the same bug.
> We need pathed KDM or Plymouth.
Maybe the problem is not systemd problem, but it appear after systemd update....
Because it would be good to fix this problem with systemd updating.
Comment 26 Aleksandr Kazantcev 2014-01-24 10:24:51 MSK
This is not systemd - error appear with plymouth and kdm only.
Comment 27 Aleksandr Kazantcev 2014-01-24 10:25:27 MSK
We need try test without new plymouth
Comment 28 Postnikov Dmitry 2014-01-24 10:27:21 MSK
(In reply to comment #25)
> (In reply to comment #24)
> > (In reply to comment #23)
> > > (In reply to comment #21)
> > > > Created attachment 2587 [details]
> > > > report3.odt
> > > > 
> > > > Report3
> > > With new systemd and new nvidia I see string "A Wite for Plymouth Service
> > > boot Quit" and break system too. But after reinstall my system the error
> > > don't showed.
> > > (I wrote the bug in http://bugs.rosalinux.ru/show_bug.cgi?id=3600#c7)
> > > It seems that this is a random error associated with the new systemd setup
> > > :-(
> > > Then I deleted xorg.conf allowed to boot the system and roll back systemd
> > > (but it did not solve the problem)
> > 
> > This problem not systemd. This problem KDM+Plymouth. The Kdm.service starts
> > earlier than Plymouth-quit-wite.service and stop system boot.
> > In launchpad adn redhat bagzilla the same bug.
> > We need pathed KDM or Plymouth.
> Maybe the problem is not systemd problem, but it appear after systemd
> update....
> Because it would be good to fix this problem with systemd updating.

100% not the systemd problem.
You maybe try install Systemd+dkms+initscripts without Plymouth. You will see no promblem start system.

@Kazantcev

I try install systemd+dkms+initscripts ,without Plymouth, on new updating KDM R2 system. And all normall boot system, no promlem. All work fine.
Comment 29 Vladimir Potapov 2014-01-24 10:33:46 MSK
It's maybe random error. I can't reproduce the bug again, after system reinstall.
If your tester reliably reproduce the problem, try and test the solution.
Comment 30 Postnikov Dmitry 2014-01-24 10:42:00 MSK
(In reply to comment #29)
> It's maybe random error. I can't reproduce the bug again, after system
> reinstall.
> If your tester reliably reproduce the problem, try and test the solution.

Let's produce systemd WITHOUT new Plymouth.
The bug fix will take a long time. This is better release systemd now without plymouth. And then fixed the error with plymouth and kdm.
Comment 31 Vladimir Potapov 2014-01-24 12:30:42 MSK
systemd-208-7-rosa2012.1
dkms-2.0.19-31-rosa2012.1
initscripts-9.34-14-rosa2012.1
************************ Advisory ************************
This update bring new version of systemd - 208. Many fixes and changes before previous 204 release. You may read about in changelog: http://upstream-tracker.org/changelogs/systemd/208/changelog.html

Also initscrips update with drop mandriva-everytime service and clean rc.sysinit script for improve boot time.
*********************************************************
QA Verified
Comment 32 Fabiano Kuller 2014-02-02 22:59:54 MSK
After upgrading to systemd 208, urpmi and rpm stopped working.
Comment 33 Aleksandr Kazantcev 2014-02-02 23:02:00 MSK
Please do not touch UPDATE REQUEST bug. This is internal QA bugs. Open new bug for you problem.
Comment 34 Denis Silakov 2014-02-11 12:22:53 MSK
Yes, please open new bugs if you have any problems after updates.