Bug 3545 - Please build torbrowser
: Please build torbrowser
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Package Requests
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-10 09:48 MSK by FirstLevel
Modified: 2015-05-27 21:42 MSD (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2014-01-10 09:48:05 MSK
Description of problem:
Please build torbrowser
https://www.torproject.org/projects/torbrowser.html.en#linux


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 symbianflo 2015-01-05 00:07:32 MSK
torbrowser-launcher
available in contrib, for rosa2014.1 with all the dependencies.

"Tor Browser Launcher is intended to make the 
Tor Browser Bundle (TBB) easier to maintain 
and use for GNU/Linux users. 
You install torbrowser-launcher from your 
distribution's package manager and it handles 
downloading the most recent 
version of TBB for you, in your 
language and for your architecture. 
It also adds a "Tor Browser" 
application launcher to your 
operating system's menu, and 
lets you set Tor Browser as your 
default web browser.
When you first launch Tor Browser Launcher, 
it will download TBB from https://www.torproject.org/, 
extract it in your home directory, and execute it. 
When you run it after that it will just execute TBB. 
When you open Tor Browser after an update, 
it will download the newer version of TBB 
for you and extract it over your old TBB 
directory, so you will maintain your TBB 
bookmarks and always be running the latest version."

I guess is far more useful that the actual tor browser, since 
it will install/update tbb user-wide and not system-wide .
If this cheat is acceptable we can close this.

(sync with MRB)
Comment 2 symbianflo 2015-01-05 00:10:29 MSK
@ QA team
###########
Forgot to mention that I didn't had the chance to test the Ru locale in tor, just ro, ita, eng, so please check the russian translation before close the bug.
thanks.
Comment 3 Denis Silakov 2015-05-27 21:42:56 MSD
It looks like everybody is happy with the current solution, closing.