Bug 3542 - Firefox 26 window silently closes after 10-20 s
: Firefox 26 window silently closes after 10-20 s
Status: RESOLVED INVALID
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: i586 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-09 22:03 MSK by gavriluk
Modified: 2014-01-24 00:29 MSK (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
Disk controller errors in dmesg output when on battery (42.05 KB, application/octet-stream)
2014-01-10 20:52 MSK, gavriluk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gavriluk 2014-01-09 22:03:12 MSK
Description of problem:
On freshly installed ROSA system Firefox window silently closes after 10-20 s

Version-Release number of selected component (if applicable):


How reproducible:
Problem is stable and could be reproduced on demand.

Steps to Reproduce:
1. Take ASUS X51RL notebook
2. Install ROSA Fresh R2 LXDE
3. Start Firefox (or Chromium, or Opera)
4. Do nothing for 10-20 s
5. Firefox (or Opera window) will close silently, Chromium will hang

Command line messages:
----------------------------------------------------
firefox
(process:6707): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed
Ошибка сегментирования (слепок снят)
----------------------------------------------------

Debugger messages:
----------------------------------------------------
gdb firefox
GNU gdb (GDB) 7.3.50.20110722-4 (ROSA Linux release 2012.1)
Copyright (C) 2011 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i586-unknown-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/bin/firefox...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/bin/firefox 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/i686/libthread_db.so.1".
[New Thread 0xb1e87b40 (LWP 9056)]
[Thread 0xb1e87b40 (LWP 9056) exited]

(process:9053): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed
Detaching after fork from child process 9057.
[New Thread 0xb1e87b40 (LWP 9058)]
[New Thread 0xaff4cb40 (LWP 9059)]
[New Thread 0xaf3ffb40 (LWP 9060)]
[New Thread 0xaebfeb40 (LWP 9061)]
[New Thread 0xae3fdb40 (LWP 9062)]
[New Thread 0xad4ffb40 (LWP 9063)]
[New Thread 0xacaffb40 (LWP 9064)]
[New Thread 0xaabacb40 (LWP 9065)]
[New Thread 0xaa1ffb40 (LWP 9066)]
[New Thread 0xa99feb40 (LWP 9067)]
[New Thread 0xa90ffb40 (LWP 9068)]
[New Thread 0xa86ffb40 (LWP 9069)]
[New Thread 0xa78ffb40 (LWP 9070)]
[New Thread 0xa63ffb40 (LWP 9071)]
[New Thread 0xa5bfeb40 (LWP 9072)]
[New Thread 0xa88feb40 (LWP 9073)]
[New Thread 0xa51ffb40 (LWP 9074)]
[New Thread 0xa47ffb40 (LWP 9075)]
[New Thread 0xa3ffeb40 (LWP 9076)]
[New Thread 0xa33ffb40 (LWP 9400)]
[New Thread 0xa29ffb40 (LWP 9401)]
[New Thread 0xa21feb40 (LWP 9402)]
[New Thread 0xa17fdb40 (LWP 9403)]
[New Thread 0xa0ffcb40 (LWP 9404)]
[New Thread 0xa07fbb40 (LWP 9405)]

Program received signal SIGSEGV, Segmentation fault.
0xb7fea956 in _dl_relocate_object () from /lib/ld-linux.so.2
(gdb) bt
#0  0xb7fea956 in _dl_relocate_object () from /lib/ld-linux.so.2
#1  0xb7ff2aba in dl_open_worker () from /lib/ld-linux.so.2
#2  0xb7fee6de in _dl_catch_error () from /lib/ld-linux.so.2
#3  0xb7ff22b4 in _dl_open () from /lib/ld-linux.so.2
#4  0xb7fadcbe in ?? () from /lib/libdl.so.2
#5  0xb7fee6de in _dl_catch_error () from /lib/ld-linux.so.2
#6  0xb7fae472 in ?? () from /lib/libdl.so.2
#7  0x00000000 in ?? ()
(gdb) quit
A debugging session is active.

   Inferior 1 [process 9053] will be killed.

Quit anyway? (y or n) y
----------------------------------------------------

ROSA Lab forum thread (with extra info in Russian)
http://forum.rosalab.ru/viewtopic.php?f=39&t=2751&p=23641#p23621
Comment 1 gavriluk 2014-01-10 20:52:15 MSK
Created attachment 2509 [details]
Disk controller errors in dmesg output when on battery

Found strange disk controller errors when notebook is on battery power (see files dmesg-nb-on-battery-1.txt, dmesg-nb-on-battery-2.txt).
When notebook is on line power no errors exist (file dmesg-nb-on-line-power.txt).
Comment 2 gavriluk 2014-01-13 00:07:21 MSK
1. Did full run of MemTest and found defective memory module.
2. Replaced module with good one and checked Firefox, Chromium and Opera functions - no changes, still hangs and crashes.
3. As far as Opera was most stable, checked online video playback. Surprisingly discovered missed Adobe Flash, though proper package was in place.
4. Reinstall Adobe Flash package, and all three browsers became stable. Suspect bad memory module during previous ROSA installation as a root cause.
5. Did clean install of Fresh R2 LXDE, added Chromium and Opera, but did not touch Adobe Flash package. All three browsers work fine, no errors, crashes and hangs.

Disk controller errors (when on battery) in dmesg output are in place. MS WinXP as second OS on this notebook shows no errors in its logs.

Please give advice how to define if it's software or hardware problem.
Comment 3 Denis Silakov 2014-01-16 00:56:51 MSK
It is possible that something weird came from Flash Player plugin or its first installation was broken. Plugins are usually loaded and managed using libdl function (dlopen & co), so crashes in dl* functions can indicate that something went wrong with some of plugins.

Maybe the plugin file was broken during copying from CD/flash to hard drive (during system installation)?
Comment 4 gavriluk 2014-01-16 01:12:16 MSK
(In reply to comment #3)
> Maybe the plugin file was broken during copying from CD/flash to hard drive
> (during system installation)?
Fully agree with you - bad memory module is unpredictable factor during all memory read/write operations. After first two (!) installations it was simply wrong impression that incompatibility with old AMD chipset and video exists.
Comment 5 Denis Silakov 2014-01-23 23:05:49 MSK
As for the bug itself - I am marking it as invalid, since I don't think we can provide much help here (except memtest). And definitely it is not firefox who causes the issue.
Comment 6 gavriluk 2014-01-24 00:29:25 MSK
Concur with invalid mark, case could be closed.