Bug 3540 - Segfault on update
: Segfault on update
Status: RESOLVED WORKSFORME
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-09 15:52 MSK by Vladimir Potapov
Modified: 2014-11-20 17:01 MSK (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Potapov 2014-01-09 15:52:10 MSK
В программе "MandrivaUpdate" произошла ошибка сегментации со следующей ошибкой:

  SEGV
  Glibc's trace:
  4: /usr/lib/perl5/5.14.2/x86_64-linux-thread-multi/CORE/libperl.so(Perl_sighandler+0x1e5) [0x7f86864a6235]
  5: /lib64/libc.so.6(+0x35b20) [0x7f8686086b20]
  6: /usr/lib64/librpmio-5.4.so(rpmioPutPool+0x31) [0x7f8681480d71]
  7: /usr/lib64/librpm-5.4.so(+0x4fa2a) [0x7f8681a21a2a]
  8: /usr/lib64/librpmio-5.4.so(rpmioFreePoolItem+0x10c) [0x7f8681480eec]
  9: /usr/lib64/librpm-5.4.so(rpmtsEmpty+0x6b) [0x7f8681a2485b]
  10: /usr/lib/perl5/vendor_perl/5.14.2/x86_64-linux-thread-multi/auto/URPM/URPM.so(XS_URPM__Transaction_run+0x40e) [0x7f8681e9ea7e]
  11: /usr/lib/perl5/5.14.2/x86_64-linux-thread-multi/CORE/libperl.so(Perl_pp_entersub+0x57c) [0x7f86864bf1bc]
  12: /usr/lib/perl5/5.14.2/x86_64-linux-thread-multi/CORE/libperl.so(Perl_runops_standard+0x16) [0x7f86864b67a6]
  13: /usr/lib/perl5/5.14.2/x86_64-linux-thread-multi/CORE/libperl.so(Perl_call_sv+0x45b) [0x7f86864524eb]
  14: /usr/lib/perl5/vendor_perl/5.14.2/x86_64-linux-thread-multi/auto/Glib/Glib.so(+0x27d21) [0x7f867b704d21]
  15: /lib64/libgobject-2.0.so.0(g_closure_invoke+0x190) [0x7f867b49f5f0]
  16: /lib64/libgobject-2.0.so.0(+0x21e10) [0x7f867b4b0e10]
  17: /lib64/libgobject-2.0.so.0(g_signal_emit_valist+0xea1) [0x7f867b4b8ce1]
  18: /lib64/libgobject-2.0.so.0(g_signal_emit+0x82) [0x7f867b4b8f62]
  19: /usr/lib64/libgtk-x11-2.0.so.0(+0x8d4e5) [0x7f86775774e5]
  
  Perl's trace:
  standalone::bug_handler() called from /usr/lib/libDrakX/standalone.pm:225
  standalone::__ANON__() called from /usr/lib/perl5/vendor_perl/5.14.2/urpm/install.pm:293
  (eval)() called from /usr/lib/perl5/vendor_perl/5.14.2/urpm/install.pm:293
  urpm::install::install() called from /usr/lib/perl5/vendor_perl/5.14.2/urpm/main_loop.pm:296
  ::urpm::main_loop::run() called from /usr/lib/perl5/vendor_perl/5.14.2/Rpmdrake/pkg.pm:876
  Rpmdrake::pkg::perform_installation() called from /usr/lib/perl5/vendor_perl/5.14.2/Rpmdrake/gui.pm:965
  Rpmdrake::gui::do_action__real() called from /usr/lib/perl5/vendor_perl/5.14.2/Rpmdrake/gui.pm:980
  (eval)() called from /usr/lib/perl5/vendor_perl/5.14.2/Rpmdrake/gui.pm:980
  Rpmdrake::gui::do_action() called from /usr/sbin/MandrivaUpdate:192
  main::__ANON__() called from /usr/lib/libDrakX/mygtk2.pm:1426
  (eval)() called from /usr/lib/libDrakX/mygtk2.pm:1426
  mygtk2::main() called from /usr/lib/libDrakX/ugtk2.pm:767
  ugtk2::main() called from /usr/sbin/MandrivaUpdate:274
  main::run_treeview_dialog() called from /usr/sbin/MandrivaUpdate:289

Тема оформления: rosa-elementary
Comment 1 Denis Silakov 2014-01-09 23:08:38 MSK
This issue can be caused by either perl-Glib or by perl-URPM. As for perl-Glib, I have built the newest version (see bug #3543), it makes sense to try it.

Note also that there are some known issues with latest versions of glib and perl (http://code.activestate.com/lists/perl5-porters/202990/), not sure if we are affected by them.

And I will try to prepare an update for perl-URPM in the near future, but I have to prepare some updates for rpm first.
Comment 2 FirstLevel 2014-10-08 16:31:27 MSD
Please check the problem for our new release
http://mirror.rosalab.ru/rosa/rosa2014.1/iso/ROSA.Fresh.R4/
Comment 3 Denis Silakov 2014-11-20 17:01:51 MSK
Closing as "worksforme". We couldn't reproduce this issue and there were no reports of this kind for Desktop Fresh R4.