Bug 3381 - [UPDATE REQUEST] KDE 4.11.3 -> 4.11.4
: [UPDATE REQUEST] KDE 4.11.3 -> 4.11.4
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-12-10 19:21 MSK by Andrey Bondrov
Modified: 2014-01-22 12:16 MSK (History)
4 users (show)

See Also:
RPM Package: various
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments
ggg4,png (142.53 KB, image/png)
2013-12-17 20:13 MSK, Postnikov Dmitry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Bondrov 2013-12-10 19:21:23 MSK
New version of KDE is ready for testing. 

http://abf-downloads.rosalinux.ru/kde4_backports_personal/repository/rosa2012.1/
Comment 1 Vladimir Potapov 2013-12-16 15:12:09 MSK
The update route to extended testing
Comment 2 Vladimir Potapov 2013-12-17 16:26:23 MSK
1) After screen lock I can't see language indicator (standard theme)
2) If I enable OpenGL screensaver, after it password may be enter only by one symbol (focus lost)
Comment 3 Andrey Bondrov 2013-12-17 16:50:15 MSK
(In reply to comment #2)
> 1) After screen lock I can't see language indicator (standard theme)
> 2) If I enable OpenGL screensaver, after it password may be enter only by
> one symbol (focus lost)

I cannot reproduce #2. Maybe it was introduced by latest XServer update? I haven't updated my system this week yet.
Comment 4 Aleksandr Kazantcev 2013-12-17 16:55:28 MSK
What videocard?

Try change 3d-acceleration method and if free driver radeon, install and enable Glamor.
Comment 5 Andrey Bondrov 2013-12-17 17:34:59 MSK
Even after system update I cannot reproduce the issue with screenlocker focus. Please try to investigate why you have it (test on different PCs etc).
Comment 6 Postnikov Dmitry 2013-12-17 20:13:33 MSK
Created attachment 2419 [details]
ggg4,png

(In reply to comment #2)
> 1) After screen lock I can't see language indicator (standard theme)
> 2) If I enable OpenGL screensaver, after it password may be enter only by
> one symbol (focus lost)

I have neither the first nor the second bug is not confirmed.
Comment 7 Postnikov Dmitry 2013-12-17 20:33:20 MSK
Yes, I could reproduce the second bug with OpenGL screensaver.
1. Enable screensaver OpenGL
2. Enter the wrong password
3. The second time password is not entered, only ONE character can be entered, the focus is lost.

My driver fglrx+new x11 server.
Comment 8 Vladimir Potapov 2013-12-18 05:15:42 MSK
(In reply to comment #4)
> What videocard?
> 
> Try change 3d-acceleration method and if free driver radeon, install and
> enable Glamor.
Intel HD3500. The bug fixed in R1 but showed again.
Comment 9 Andrey Bondrov 2013-12-18 08:58:03 MSK
(In reply to comment #8)
> (In reply to comment #4)
> > What videocard?
> > 
> > Try change 3d-acceleration method and if free driver radeon, install and
> > enable Glamor.
> Intel HD3500. The bug fixed in R1 but showed again.

I found a way to reproduce it. This bug will be fixed during kde4_backports -> main/updates merge.
Comment 10 Andrey Bondrov 2013-12-18 10:28:18 MSK
Screenlocker focus issue should be fixed in kdebase4-workspace 4.11.4-6. Please update and test.
Comment 11 Postnikov Dmitry 2013-12-18 11:27:43 MSK
(In reply to comment #10)
> Screenlocker focus issue should be fixed in kdebase4-workspace 4.11.4-6.
> Please update and test.

After update, screenlocker focus is normal.
Comment 12 Vladimir Potapov 2013-12-18 14:44:31 MSK
KDE 4.11.4
**************** Advisory *************
New bugfix version
***************************************
QA Verified