Bug 3357 - [UPDATE REQUEST] cups-1.7.0-4
: [UPDATE REQUEST] cups-1.7.0-4
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-12-06 10:39 MSK by Aleksandr Kazantcev
Modified: 2013-12-09 17:19 MSK (History)
1 user (show)

See Also:
RPM Package: cups-1.7.0-4
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alexander.kazantsev: published+


Attachments
errors.log (5.41 KB, text/x-log)
2013-12-08 16:20 MSK, Vladimir Potapov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aleksandr Kazantcev 2013-12-06 10:39:04 MSK
Update CUPS
Comment 1 Aleksandr Kazantcev 2013-12-06 10:41:39 MSK
https://abf.rosalinux.ru/build_lists/1457820
https://abf.rosalinux.ru/build_lists/1457821

Advisory: This update fix some bug and add features:
- Add cups-filters and ghostscript to Requires
- Prevent USB timeouts causing incorrect print output and avoid stale lockfile in dbus notifier
- Corectly place config file in /etc
Comment 2 Vladimir Potapov 2013-12-06 16:11:26 MSK
It's works but new errors appear in log (cups)

 [06/Dec/2013:21:07:19 +0900] [cups-driverd] Bad driver information file "/usr/share/cups/model/ibm/readme"!
E [06/Dec/2013:21:07:19 +0900] [cups-driverd] Bad driver information file "/usr/share/cups/model/ricoh/readme"!
E [06/Dec/2013:21:07:19 +0900] [cups-driverd] Bad driver information file "/usr/share/cups/model/mitsubishi/readme"!
E [06/Dec/2013:21:07:19 +0900] [cups-driverd] Bad driver information file "/usr/share/cups/model/ti/readme"!
E [06/Dec/2013:21:07:19 +0900] [cups-driverd] Bad driver information file "/usr/share/cups/model/tektronix/readme"!
E [06/Dec/2013:21:07:19 +0900] [cups-driverd] Bad driver information file "/usr/share/cups/model/adobe/readme"!
E [06/Dec/2013:21:07:19 +0900] [cups-driverd] Bad driver information file "/usr/share/cups/model/samsung/readme"!
E [06/Dec/2013:21:07:20 +0900] [cups-driverd] Bad driver information file "/usr/share/cups/model/panasonic/readme"!
E [06/Dec/2013:21:07:20 +0900] [cups-driverd] Bad driver information file "/usr/share/cups/model/minolta/readme"!
E [06/Dec/2013:21:07:20 +0900] [cups-driverd] Bad driver information file "/usr/share/cups/model/hp/readme"!
E [06/Dec/2013:21:07:20 +0900] [cups-driverd] Bad driver information file "/usr/share/cups/model/canon/readme"!
E [06/Dec/2013:21:07:20 +0900] [cups-driverd] Bad driver information file "/usr/share/cups/model/apple/readme"!
E [06/Dec/2013:21:07:20 +0900] [cups-driverd] Bad driver information file "/usr/share/cups/model/nec/readme"!
E [06/Dec/2013:21:07:20 +0900] [cups-driverd] Bad driver information file "/usr/share/cups/model/citoh/readme"!
E [06/Dec/2013:21:07:20 +0900] [cups-driverd] Bad driver information file "/usr/share/cups/model/qms/readme"!
E [06/Dec/2013:21:07:20 +0900] [cups-driverd] Bad driver information file "/usr/share/cups/model/xerox/readme"!
E [06/Dec/2013:21:07:20 +0900] [cups-driverd] Bad driver information file "/usr/share/cups/model/lexmark/readme.1st"!
E [06/Dec/2013:21:07:20 +0900] [cups-driverd] Bad driver information file "/usr/share/cups/model/lexmark/readme"!
E [06/Dec/2013:21:07:20 +0900] [cups-driverd] Bad driver information file "/usr/share/cups/model/dec/readme"!
E [06/Dec/2013:21:07:20 +0900] [cups-driverd] Bad driver information file "/usr/share/cups/model/fujitsu/readme"!
E [06/Dec/2013:21:07:20 +0900] [cups-driverd] Bad driver information file "/usr/share/cups/model/epson/epl6100l.ppd.gz"!
E [06/Dec/2013:21:07:20 +0900] [cups-driverd] Bad driver information file "/usr/share/cups/model/epson/readme"!
E [06/Dec/2013:21:07:20 +0900] [cups-driverd] Bad driver information file "/usr/share/cups/model/epson/epl6200l.ppd.gz"!
E [06/Dec/2013:21:07:20 +0900] [cups-driverd] Bad driver information file "/usr/share/cups/model/epson/epl5700l.ppd.gz"!
E [06/Dec/2013:21:07:20 +0900] [cups-driverd] Bad driver information file "/usr/share/cups/model/epson/epl5900l.ppd.gz"!
E [06/Dec/2013:21:07:20 +0900] [cups-driverd] Bad driver information file "/usr/share/cups/model/epson/epl5800l.ppd.gz"!
Comment 3 Vladimir Potapov 2013-12-06 16:15:36 MSK
Also

W [06/Dec/2013:21:07:19 +0900] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/KONICA_MINOLTA/KOC451JX.ppd.gz!
E [06/Dec/2013:21:07:19 +0900] [cups-driverd] Bad driver information file "/usr/share/cups/model/foomatic-db-ppds/Kyocera/ReadMe.htm"!
W [06/Dec/2013:21:07:19 +0900] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Brother/BR5070DN_GPL.ppd.gz!
W [06/Dec/2013:21:07:19 +0900] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp960s.ppd.gz!
W [06/Dec/2013:21:07:19 +0900] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp9100.ppd.gz!
W [06/Dec/2013:21:07:19 +0900] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp850c.ppd.gz!
W [06/Dec/2013:21:07:19 +0900] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp920c.ppd.gz!
W [06/Dec/2013:21:07:19 +0900] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp980c.ppd.gz!
W [06/Dec/2013:21:07:19 +0900] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp950c.ppd.gz!
W [06/Dec/2013:21:07:19 +0900] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp880c.ppd.gz!
W [06/Dec/2013:21:07:19 +0900] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp830c.ppd.gz!
Comment 4 Aleksandr Kazantcev 2013-12-06 16:22:19 MSK
This all been in previous package too.

E [06/Dec/2013:21:07:20 +0900] [cups-driverd] Bad driver information file "/usr/share/cups/model/canon/readme"!

not error, only wrong reading readme as driver. Need investigate in upstream, but this not abble broke CUPS work anymore.

On ppd think this bug in foomatic-db, not CUPS.
Comment 5 Vladimir Potapov 2013-12-06 16:36:57 MSK
(In reply to comment #4)
> This all been in previous package too.
> 
> E [06/Dec/2013:21:07:20 +0900] [cups-driverd] Bad driver information file
> "/usr/share/cups/model/canon/readme"!
> 
> not error, only wrong reading readme as driver. Need investigate in
> upstream, but this not abble broke CUPS work anymore.
> 
> On ppd think this bug in foomatic-db, not CUPS.

I don't see the error in old version of cups. 
Readme, as I see, is a information index file for driver set.
Comment 6 Aleksandr Kazantcev 2013-12-06 16:38:51 MSK
I think we need rebuild foomatic-db and foomatic-filters. Then try see about error.

For version - if error not appeared in previous CUPS 1.7 ?
Comment 7 Vladimir Potapov 2013-12-06 17:08:39 MSK
The error present in "clear" r2 installiation for cups 1.7
Comment 8 Aleksandr Kazantcev 2013-12-06 17:20:37 MSK
try install latest foomatic-db package and see for this error:

https://abf.rosalinux.ru/build_lists/1459746
https://abf.rosalinux.ru/build_lists/1459746
Comment 9 Vladimir Potapov 2013-12-06 17:33:19 MSK
(In reply to comment #8)
> try install latest foomatic-db package and see for this error:
> 
> https://abf.rosalinux.ru/build_lists/1459746
> https://abf.rosalinux.ru/build_lists/1459746
two identical links exist.
Comment 10 Aleksandr Kazantcev 2013-12-06 17:41:53 MSK
https://abf.rosalinux.ru/build_lists/1459776
Comment 11 Aleksandr Kazantcev 2013-12-06 21:00:24 MSK
Also please update this
https://abf.rosalinux.ru/build_lists/1459939
https://abf.rosalinux.ru/build_lists/1459940

Then delete old cups error log

  rm -f /var/log/cups/error_log

and reboot

Some error may appear becouse some ppd not present in package directly.
Comment 12 Vladimir Potapov 2013-12-08 16:19:05 MSK
(In reply to comment #11)
> Also please update this
> https://abf.rosalinux.ru/build_lists/1459939
> https://abf.rosalinux.ru/build_lists/1459940
> 
> Then delete old cups error log
> 
>   rm -f /var/log/cups/error_log
> 
> and reboot
> 
> Some error may appear becouse some ppd not present in package directly.
1) Install new x64r2
2) Add sources cups, foomatic and postscript-ppds
3) Update
4) reboot
5) add mfu dj3520 and print test page
Comment 13 Vladimir Potapov 2013-12-08 16:20:00 MSK
Created attachment 2372 [details]
errors.log
Comment 14 Aleksandr Kazantcev 2013-12-08 16:25:22 MSK
For now this is all warnings, not errors.

Becouse if you see 

rpm -qf /usr/share/cups/model/foomatic-db-ppds/Brother/BR5070DN_GPL.ppd.gz

for example this ppd not present in current package - we need investigate who create it.


readme file error from obsolete package for now i think - this package present only in ROSA and Mageia and we also need see this (it don't change from 2006 yeard and may be need drop).


But this is not fast process and we need step-by-step fix this (and this is not problem for CUPS and stop it work).
Comment 15 Vladimir Potapov 2013-12-08 16:33:17 MSK
As I see, errors set don't change after postscript-ppds update.
Do add the update in final advisory?
Comment 16 Aleksandr Kazantcev 2013-12-08 16:40:53 MSK
postscript-ppds may be obsolete - is some old and not present in other distro - but it requires cups and it rebuilt was been good task :)

After LXDE release i will plan return to CUPS and fix as more erors as possible.
Comment 18 Vladimir Potapov 2013-12-09 11:30:36 MSK
cups-1.7.0-5
postscript-ppds-2006-12
foomatic-db-4.0-3.20130928.2
***************************** Advisory ***************************
- Add cups-filters and ghostscript to Requires
- Prevent USB timeouts causing incorrect print output and avoid stale lockfile in dbus notifier
- Corectly place config file in /etc
- Fix (bug#3348) and similar with Brother printers.
******************************************************************
QA Verified