Bug 3356 - Libreoffice can crash when Opening certain DocX files
: Libreoffice can crash when Opening certain DocX files
Status: RESOLVED WONTFIX
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-12-06 04:59 MSK by Zombie Ryushu
Modified: 2014-03-03 21:58 MSK (History)
1 user (show)

See Also:
RPM Package: libreoffice
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zombie Ryushu 2013-12-06 04:59:09 MSK
Libreoffice can crash when Opening certain DocX files. I received an MS Office 2010 Word document that literally caused 'swriter' to crash when opening it. I had to use odf-integrator-converter to get the document to Open as an ODT, but in DocX, it will segfault.
Comment 1 Denis Silakov 2014-03-03 21:27:56 MSK
It would be nice to have examples of such files at least for regression tests.
Comment 2 Zombie Ryushu 2014-03-03 21:30:13 MSK
The Specimen I had is now gone. It was worked around using the ODF Converter Integrator. It was an Office 2012 Document.
Comment 3 Denis Silakov 2014-03-03 21:32:33 MSK
Ok, thanks for the info in any case.

I'm closing this particular bug as 'wontfix' since we actually don't have a way to check if we fix it or not:) In future, it would be nice to have examples of problematic files (to be sure, ifthey don't contain any confidentional data).
Comment 4 Zombie Ryushu 2014-03-03 21:58:56 MSK
They did. Thats why I couldn't give you the specimen at the time.