Bug 3348 - Brother USB printing stopped working
: Brother USB printing stopped working
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-12-05 08:47 MSK by Rolf Pedersen
Modified: 2013-12-10 22:53 MSK (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rolf Pedersen 2013-12-05 08:47:52 MSK
Brother MFC-685CW that was working in Rosa2012.1 and still works in Mandriva 2011 on the same machine stopped working, probably due to recent updates.  I thought to revert cups but that looks just about impossible without risking further breakage.

I tried uninstalling and installing the Brother printer drivers but no help:

mfc685cwlpr-1.0.1-1.i386
mfc685cwcupswrapper-1.0.1-1.i386

The printer is recognized by lpstat and printer configurator and CUPS admin web pages at /dev/usb/lp0.  It's supposed to have a uri something like usb://Brother/MFC685CW but it's like usb/lp0 and the proper uri choice is not shown, whereas it ordinarily is shown after driver installation.

Jobs queue but don't print.  Status is:

Processing - "Waiting for printer to become available."

$ lsusb

Bus 002 Device 003: ID 04f9:01d9 Brother Industries, Ltd

It was working before the update, still works in MDV 2011.
Comment 1 Aleksandr Kazantcev 2013-12-05 09:11:00 MSK
Hi. Are cups-filters and foomatic-* package installed ?
Comment 2 Rolf Pedersen 2013-12-05 09:20:21 MSK
I deleted the printer in the CUPS web interface but it could not be found after.

I tried a workaround found here: https://wiki.archlinux.org/index.php/CUPS#Printer_doesn.27t_print_with_an_.22Filter_failed.22_message_on_CUPS_web_interface_.28HP_printer.29

-->

$ cat /etc/udev/rules.d/10-cups-usb.rules 
# Brother MFC-685CW

SUBSYSTEM=="usb", ATTRS{idVendor}=="04f9", ATTRS{idProduct}=="01d9", GROUP="lp", MODE:="666"


After a reboot, the printer can be added with a proper-looking uri:

Description:	Brother MFC685CW
Location:	
Driver:	Brother MFC-685CW CUPS v1.1 (color, 2-sided printing)
Connection:	usb://Brother/MFC-685CW?serial=BROJ7F351565
Defaults:	job-sheets={job_sheets_default} media=na_letter_8.5x11in sides=one-sided

However, printing does not yet work.  

	                            Status:	Idle - "Sending data to printer."
Comment 3 Rolf Pedersen 2013-12-05 09:21:38 MSK
[rolf@localhost ~]$ rpm -qa|grep cups
cups-drivers-lz11-1.2-11-rosa2012.1.x86_64
cups-drivers-lxx74-0.8.4.2-11-rosa2012.1.x86_64
cups-drivers-foo2kyo-0.1.0a-13-rosa2012.1.x86_64
cups-drivers-lbp660-0.3.1-6-rosa2012.1.x86_64
cups-drivers-foo2zjs-0.0-0.20101208.4-rosa2012.1.x86_64
cups-drivers-magicolor2430dl-1.6.1-14-rosa2012.1.x86_64
cups-drivers-magicolor5440dl-1.2.1-13-rosa2012.1.x86_64
cups-drivers-pegg-0.23-12-rosa2012.1.x86_64
cups-drivers-magicolor5430dl-1.8.1-14-rosa2012.1.x86_64
cups-drivers-splix-2.0.0-6-rosa2012.1.x86_64
cups-drivers-2008-9-rosa2012.1.x86_64
cups-drivers-m2300w-0.51-13-rosa2012.1.x86_64
cups-drivers-capt-0.1-11-rosa2012.1.x86_64
cups-drivers-ptouch-1.3-8-rosa2012.1.x86_64
gutenprint-cups-5.2.9-2-rosa2012.1.x86_64
cups-pdf-2.6.1-1-rosa2012.1.x86_64
lib64cups2-1.7.0-3-rosa2012.1.x86_64
lib64cupsimage2-1.7.0-3-rosa2012.1.x86_64
lib64cupsppdc1-1.7.0-3-rosa2012.1.x86_64
lib64cupscgi1-1.7.0-3-rosa2012.1.x86_64
lib64cupsmime1-1.7.0-3-rosa2012.1.x86_64
cups-common-1.7.0-3-rosa2012.1.x86_64
cups-1.7.0-3-rosa2012.1.x86_64
python-cups-1.9.63-1-rosa2012.1.x86_64
libcups2-1.7.0-3-rosa2012.1.i586
mfc685cwcupswrapper-1.0.1-1.i386


[rolf@localhost ~]$ rpm -qa |grep foomatic
foomatic-db-engine-4.0.8-4-rosa2012.1.x86_64
foomatic-db-4.0-2.20110503.3-rosa2012.1.noarch
gutenprint-foomatic-5.2.9-2-rosa2012.1.x86_64
foomatic-filters-4.0.17-3-rosa2012.1.x86_64
Comment 4 Rolf Pedersen 2013-12-05 09:34:34 MSK
(In reply to comment #1)
> Hi. Are cups-filters and foomatic-* package installed ?

I installed cups-filters and rebooted.  Now, printing seems back to normal.  Should be some requires, maybe?
Thanks.
Comment 5 Denis Silakov 2013-12-05 17:57:57 MSK
Well, cups-filters is installed as task-printing (and task-printing-minimal) dependencies. If you use system-config-printer, then task-printing is installed and thus you get cups-filters, as well.

But maybe it would be better to add cups-filters to cups requirements?
Comment 6 Aleksandr Kazantcev 2013-12-05 18:09:09 MSK
I prepare new cups, but not push to git. Please wait some time...
Comment 7 Rolf Pedersen 2013-12-05 18:39:16 MSK
(In reply to comment #5)
> Well, cups-filters is installed as task-printing (and task-printing-minimal)
> dependencies. If you use system-config-printer, then task-printing is
> installed and thus you get cups-filters, as well.
> 
> But maybe it would be better to add cups-filters to cups requirements?

Sorry, the intricacies of packaging is not my specialty.  I would vote yes, if pressed.  I tried to deal with some irritation with task-printing; maybe I thought it pulled in the hplip stuff with annoying, unnecessary, to me, as I don't have an HP printer, task-bar icon that can only be hidden, not removed.  Anyway, there is some evidence of what might have affected this problem, although it appears to be not in force for at least a month:

 [rolf@localhost ~]$ cat /etc/urpmi/skip.list 
# Here you can specify the packages that won't be upgraded automatically
# for example, to exclude all apache packages :
# /^apache/
pyparted
#task-printing
[rolf@localhost ~]$ ll /etc/urpmi/skip.list 
-rw-r--r-- 1 root root 157 Nov  3 07:29 /etc/urpmi/skip.list
Comment 8 Denis Silakov 2013-12-09 17:27:27 MSK
Dependency issues should be fixed with latest cups update.
Comment 9 Rolf Pedersen 2013-12-10 21:47:58 MSK
(In reply to comment #8)
> Dependency issues should be fixed with latest cups update.

Hi. The update applet has been offering updates, including 
libcups2                       1.7.0        5             rosa  2012.1 i586
but not lib64cups2

[rolf@localhost ~]$ rpm -q lib64cups2 libcups2
lib64cups2-1.7.0-3-rosa2012.1.x86_64
libcups2-1.7.0-3-rosa2012.1.i586

This is a 64-bit system, albeit brother printer drivers are are not, fwiw

[rolf@localhost ~]$ rpm -qa|grep mfc
mfc685cwlpr-1.0.1-1.i386
mfc685cwcupswrapper-1.0.1-1.i386

Anyway, I thought to test wrt my problem, which seemed to be solved by installing cups-filters, so I removed that to see if it would be pulled in, the only way I can think to test.  

[rolf@localhost ~]$ rpm -q cups-filters
package cups-filters is not installed

However, when I open the applet or update on command line, cups-filters is not offered.

[root@localhost rolf]# urpmi --auto-update
[..]
To satisfy dependencies, the following packages are going to be installed:
 Package                        Version      Release       Dist  DEpoch Arch 
(medium "Main32 Updates")
 foomatic-db                    4.0          3.20130928.2  rosa  2012.1 noarch 
 libcups2                       1.7.0        5             rosa  2012.1 i586 
 postscript-ppds                2006         12            rosa  2012.1 noarch 
 rosa-elementary-theme          2.6.1        3             rosa  2012.1 noarch 
(medium "contrib updates")
 lib64lightdm-gobject1_0        1.8.5        1             rosa  2012.1 x86_64 
1.6MB of additional disk space will be used.
19MB of packages will be retrieved.
Proceed with the installation of the 5 packages? (Y/n) n

[rolf@localhost ~]$ rpm -qa |grep task-printing
task-printing-server-2013-2-rosa2012.1.x86_64
task-printing-okidata-2013-2-rosa2012.1.x86_64
task-printing-epson-2013-2-rosa2012.1.x86_64
task-printing-lexmark-2013-2-rosa2012.1.x86_64
task-printing-misc-2013-2-rosa2012.1.x86_64
task-printing-canon-2013-2-rosa2012.1.x86_64
task-printing-hp-2013-2-rosa2012.1.x86_64

[rolf@localhost ~]$ rpm -qa |grep cups 
cups-drivers-lz11-1.2-11-rosa2012.1.x86_64
cups-drivers-lxx74-0.8.4.2-11-rosa2012.1.x86_64
cups-drivers-foo2kyo-0.1.0a-13-rosa2012.1.x86_64
cups-drivers-lbp660-0.3.1-6-rosa2012.1.x86_64
cups-drivers-foo2zjs-0.0-0.20101208.4-rosa2012.1.x86_64
cups-drivers-magicolor2430dl-1.6.1-14-rosa2012.1.x86_64
cups-drivers-magicolor5440dl-1.2.1-13-rosa2012.1.x86_64
cups-drivers-pegg-0.23-12-rosa2012.1.x86_64
cups-drivers-magicolor5430dl-1.8.1-14-rosa2012.1.x86_64
cups-drivers-splix-2.0.0-6-rosa2012.1.x86_64
cups-drivers-2008-9-rosa2012.1.x86_64
cups-drivers-m2300w-0.51-13-rosa2012.1.x86_64
cups-drivers-capt-0.1-11-rosa2012.1.x86_64
cups-drivers-ptouch-1.3-8-rosa2012.1.x86_64
gutenprint-cups-5.2.9-2-rosa2012.1.x86_64
cups-pdf-2.6.1-1-rosa2012.1.x86_64
lib64cups2-1.7.0-3-rosa2012.1.x86_64
lib64cupsimage2-1.7.0-3-rosa2012.1.x86_64
lib64cupsppdc1-1.7.0-3-rosa2012.1.x86_64
lib64cupscgi1-1.7.0-3-rosa2012.1.x86_64
lib64cupsmime1-1.7.0-3-rosa2012.1.x86_64
cups-common-1.7.0-3-rosa2012.1.x86_64
cups-1.7.0-3-rosa2012.1.x86_64
python-cups-1.9.63-1-rosa2012.1.x86_64
libcups2-1.7.0-3-rosa2012.1.i586
mfc685cwcupswrapper-1.0.1-1.i386
lib64cupsfilters1-1.0.41-5-rosa2012.1.x86_64
Comment 10 Aleksandr Kazantcev 2013-12-10 21:51:56 MSK
You need try

 urpmi --replacepkg cups

cups-filters requred by cups for now.

urpmq --requires cups
--requires behaviour changed, use --requires-recursive to get the old behaviour
cups: cups-common[>= 1.5.4-2]
cups: libavahi-client.so.3
cups: libavahi-common.so.3
cups: libc.so.6
cups: libc.so.6(GLIBC_2.0)
cups: libc.so.6(GLIBC_2.1)
cups: libc.so.6(GLIBC_2.1.3)
cups: libc.so.6(GLIBC_2.15)
cups: libc.so.6(GLIBC_2.2)
cups: libc.so.6(GLIBC_2.3)
cups: libc.so.6(GLIBC_2.3.4)
cups: libc.so.6(GLIBC_2.4)
cups: libc.so.6(GLIBC_2.7)
cups: libcups.so.2
cups: libcupscgi.so.1
cups: libcupsdriver.so.1
cups: libcupsimage.so.2
cups: libcupsppdc.so.1
cups: libdbus-1.so.3
cups: libgcc_s.so.1
cups: libgcc_s.so.1(GCC_3.0)
cups: libgcc_s.so.1(GLIBC_2.0)
cups: libm.so.6
cups: libm.so.6(GLIBC_2.0)
cups: libpthread.so.0
cups: libpthread.so.0(GLIBC_2.0)
cups: libpthread.so.0(GLIBC_2.1)
cups: libpthread.so.0(GLIBC_2.2)
cups: libpthread.so.0(GLIBC_2.3.2)
cups: libstdc++.so.6
cups: libstdc++.so.6(CXXABI_1.3)
cups: libstdc++.so.6(GLIBCXX_3.4)
cups: libusb-1.0.so.0
cups: net-tools
cups: poppler
cups: printer-testpages
cups: rpm-helper[*][>= 0.24.1]
cups: systemd-units[*]
cups: systemd-units[>= 13]
cups: udev
cups: update-alternatives
cups: xdg-utils
cups: acl
cups: cups-common[>= 1.7.0-5]
cups: cups-filters
cups: ghostscript
cups: libavahi-client.so.3
cups: libavahi-common.so.3
cups: libc.so.6
cups: libc.so.6(GLIBC_2.0)
cups: libc.so.6(GLIBC_2.1)
cups: libc.so.6(GLIBC_2.1.3)
cups: libc.so.6(GLIBC_2.15)
cups: libc.so.6(GLIBC_2.2)
cups: libc.so.6(GLIBC_2.3)
cups: libc.so.6(GLIBC_2.3.4)
cups: libc.so.6(GLIBC_2.4)
cups: libc.so.6(GLIBC_2.7)
cups: libcups.so.2
cups: libcupscgi.so.1
cups: libcupsimage.so.2
cups: libcupsppdc.so.1
cups: libdbus-1.so.3
cups: libgcc_s.so.1
cups: libgcc_s.so.1(GCC_3.0)
cups: libgcc_s.so.1(GLIBC_2.0)
cups: libpthread.so.0
cups: libpthread.so.0(GLIBC_2.0)
cups: libpthread.so.0(GLIBC_2.1)
cups: libpthread.so.0(GLIBC_2.2)
cups: libpthread.so.0(GLIBC_2.3.2)
cups: libstdc++.so.6
cups: libstdc++.so.6(CXXABI_1.3)
cups: libstdc++.so.6(GLIBCXX_3.4)
cups: libusb-1.0.so.0
cups: net-tools
cups: poppler
cups: printer-testpages
cups: rpm-helper[*][>= 0.24.1]
cups: systemd
cups: systemd[*]
cups: udev
cups: update-alternatives
cups: xdg-utils
Comment 11 Rolf Pedersen 2013-12-10 22:10:43 MSK
[root@localhost rolf]# urpmi --replacepkg cups
found package(s) cups-1.5.4-2-rosa2012.1.x86_64 in urpmi db, but none are installed
[root@localhost rolf]# rpm -q cups
cups-1.7.0-3-rosa2012.1.x86_64

[root@localhost rolf]# urpmq --sources cups
http://mirror.rosalab.ru/rosa/rosa2012.1/repository/x86_64/media/main/release/cups-1.5.4-2-rosa2012.1.x86_64.rpm

[root@localhost rolf]# urpmq --list-media active
main
Main32
Main32 Updates
contrib
contrib updates
non-free
non-free updates
Non-free32
Non-free32 Updates
restricted
restricted updates
Restricted32
Restricted32 Updates
3.11
3.10

This has got me at least several times and I don't know why:   "main updates" drops off the active list.  I am always on the command line or using the applet, so I usually think the mirror is not synced and wait when I get "package X cannot be installed due to missing package Y".  Finally, it occurs to me to look at sources in rpmdrake media manager, where "main updates" is not checked.  So, I check it and updates work completely.  In this case, I enabled "main updates" and get the following, which seems to show the dependency works for me.
Thanks.

[root@localhost rolf]# urpmi.update "main updates"
    $MIRRORLIST: media/main/updates/media_info/synthesis.hdlist.cz
updated medium "main updates"                                                                                    
[root@localhost rolf]# urpmi --auto-select
[..]
To satisfy dependencies, the following packages are going to be installed:
 Package                        Version      Release       Dist  DEpoch Arch 
(medium "main updates")
 cups                           1.7.0        5             rosa  2012.1 x86_64 
 cups-common                    1.7.0        5             rosa  2012.1 x86_64 
 cups-filters                   1.0.41       5             rosa  2012.1 x86_64 
 foomatic-db                    4.0          3.20130928.2  rosa  2012.1 noarch 
 lib64cups2                     1.7.0        5             rosa  2012.1 x86_64 
 lib64cupscgi1                  1.7.0        5             rosa  2012.1 x86_64 
 lib64cupsimage2                1.7.0        5             rosa  2012.1 x86_64 
 lib64cupsmime1                 1.7.0        5             rosa  2012.1 x86_64 
 lib64cupsppdc1                 1.7.0        5             rosa  2012.1 x86_64 
 postscript-ppds                2006         12            rosa  2012.1 noarch 
 python-m2crypto                0.21.1       2             rosa  2012.1 x86_64 
 rosa-elementary-theme          2.6.1        3             rosa  2012.1 noarch 
(medium "Main32 Updates")
 libcups2                       1.7.0        5             rosa  2012.1 i586 
(medium "contrib updates")
 lib64lightdm-gobject1_0        1.8.5        1             rosa  2012.1 x86_64 
2.5MB of additional disk space will be used.
27MB of packages will be retrieved.
Proceed with the installation of the 14 packages? (Y/n)
Comment 12 Denis Silakov 2013-12-10 22:53:03 MSK
Yes, it's a known issue that urpmi or mdkapplet sometime disable certain repositories - see bug #2525. Up to now we failed to provide a stable reproducer, likely I will add some more debug output to urpmi & co soon to track such situations.