Bug 3337 - [UPDATE REQUEST] [UPSTREAM UPDATE] qemu-kvm
: [UPDATE REQUEST] [UPSTREAM UPDATE] qemu-kvm
Status: RESOLVED FIXED
Product: Server Bugs
Classification: ROSA Server
Component: Main Packages
: unspecified
: All Linux
: Normal normal
: ---
Assigned To: Andrew Lukoshko
: ROSA Server Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-12-04 13:10 MSK by Andrew Lukoshko
Modified: 2014-01-10 11:16 MSK (History)
1 user (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
andrew.lukoshko: published_server+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Lukoshko 2013-12-04 13:10:49 MSK
* Recent changes to the block layer resulted in a disk I/O performance
degradation due to the way block length is calculated and cached internally.
This update improves the logic for calculating such lengths and restores
performance to the expected levels.

* Due to a regression, the "qemu-img info" command took too much time to respond
with the "cluster_size=512,preallocation=metadata" option. This bug has been
fixed and "qemu-img info" now responds within one second.

* On images created with very small non-standard cluster sizes (for example, 512
bytes), the "qemu-img info" command could take a long time to respond if run
immediately after an image creation. This bug has been fixed, and "qemu-img
info" now works as expected.

* When doing live migration with the "--copy-storage-all" option, the virsh user
interface failed with the following error message:

"error: Unable to read from monitor: Connection reset by peer"

This bug, caused by a regression, has been fixed, and live migration now
finishes successfully.

* Previously, qemu (for example, the "qemu-img info" command) could not open
VMWare ESX image files. A patch fixing this bug has been provided, and ESX
images are now handled correctly.

https://rhn.redhat.com/errata/RHBA-2013-1750.html

https://abf.rosalinux.ru/build_lists/1455932
https://abf.rosalinux.ru/build_lists/1455933
Comment 1 Vladimir Potapov 2013-12-10 13:51:59 MSK
qemu-kvm-0.12.1.2-2.415.res6.3
********************************* RHEL Advisory ******************
* Recent changes to the block layer resulted in a disk I/O performance
degradation due to the way block length is calculated and cached internally.
This update improves the logic for calculating such lengths and restores
performance to the expected levels.

* Due to a regression, the "qemu-img info" command took too much time to respond
with the "cluster_size=512,preallocation=metadata" option. This bug has been
fixed and "qemu-img info" now responds within one second.

* On images created with very small non-standard cluster sizes (for example, 512
bytes), the "qemu-img info" command could take a long time to respond if run
immediately after an image creation. This bug has been fixed, and "qemu-img
info" now works as expected.

* When doing live migration with the "--copy-storage-all" option, the virsh user
interface failed with the following error message:

"error: Unable to read from monitor: Connection reset by peer"

This bug, caused by a regression, has been fixed, and live migration now
finishes successfully.

* Previously, qemu (for example, the "qemu-img info" command) could not open
VMWare ESX image files. A patch fixing this bug has been provided, and ESX
images are now handled correctly.
****************************************************************
QA Verified