Bug 3327 - Impossible to select a display driver other than Nouveau on Rosa Fresh R2
: Impossible to select a display driver other than Nouveau on Rosa Fresh R2
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-12-03 22:49 MSK by andrea_scopelliti
Modified: 2014-03-03 21:27 MSK (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andrea_scopelliti 2013-12-03 22:49:33 MSK
Description of problem:
Can't install Nvidia Driver.
Description:
Even if you choose a different graphic driver part of the nouveau driver are still loaded preventing the startup with the new driver. Below the output of my syslog after loading the vesa driver (but I got the same result with nvidia-current):
Dec 3 07:19:02 localhost kernel: [ 4.696918] mtrr: type mismatch for d0000000,8000000 old: write-back new: write-combining
Dec 3 07:19:02 localhost kernel: [ 4.696921] nouveau [ DRM] VRAM: 6144 MiB
Dec 3 07:19:02 localhost kernel: [ 4.696923] nouveau [ DRM] GART: 512 MiB
Dec 3 07:19:02 localhost kernel: [ 4.696926] nouveau [ DRM] TMDS table version 2.0
Dec 3 07:19:02 localhost kernel: [ 4.696928] nouveau [ DRM] DCB version 4.0
Dec 3 07:19:02 localhost kernel: [ 4.696930] nouveau [ DRM] DCB outp 00: 02000300 00000000
Dec 3 07:19:02 localhost kernel: [ 4.696932] nouveau [ DRM] DCB outp 01: 01000302 00020030
Dec 3 07:19:02 localhost kernel: [ 4.696935] nouveau [ DRM] DCB outp 02: 048113b6 0f220010
Dec 3 07:19:02 localhost kernel: [ 4.696937] nouveau [ DRM] DCB outp 03: 04011372 00020010
Dec 3 07:19:02 localhost kernel: [ 4.696939] nouveau [ DRM] DCB outp 04: 088223c6 0f220010
Dec 3 07:19:02 localhost kernel: [ 4.696941] nouveau [ DRM] DCB outp 05: 08022382 00020010
Dec 3 07:19:02 localhost kernel: [ 4.696943] nouveau [ DRM] DCB conn 00: 00001030
Dec 3 07:19:02 localhost kernel: [ 4.696946] nouveau [ DRM] DCB conn 01: 00410146
Dec 3 07:19:02 localhost kernel: [ 4.696948] nouveau [ DRM] DCB conn 02: 00202246
Dec 3 07:19:02 localhost kernel: [ 4.696950] nouveau [ DRM] DCB conn 03: 00000360
Dec 3 07:19:02 localhost kernel: [ 4.697550] [drm] Supports vblank timestamp caching Rev 1 (10.10.2010).
Dec 3 07:19:02 localhost kernel: [ 4.697553] [drm] No driver support for vblank timestamp query.
Dec 3 07:19:02 localhost kernel: [ 4.697758] nouveau [ DRM] 1 available performance level(s)
Dec 3 07:19:02 localhost kernel: [ 4.697761] nouveau [ DRM] 0: core 50MHz shader 101MHz memory 135MHz
Dec 3 07:19:02 localhost kernel: [ 4.697764] nouveau [ DRM] c: core 50MHz shader 101MHz memory 135MHz voltage 890mV
Dec 3 07:19:02 localhost kernel: [ 4.704212] nouveau [ DRM] MM: using COPY1 for buffer copies
Dec 3 07:19:02 localhost kernel: [ 4.889249] nouveau [ DRM] allocated 2560x1440 fb: 0x60000, bo ffff8808031ef400
Dec 3 07:19:02 localhost kernel: [ 4.889309] fbcon: nouveaufb (fb0) is primary device
Dec 3 07:19:02 localhost kernel: [ 4.952950] Console: switching to colour frame buffer device 320x90
Dec 3 07:19:02 localhost kernel: [ 4.963178] nouveau 0000:01:00.0: fb0: nouveaufb frame buffer device
Dec 3 07:19:02 localhost kernel: [ 4.963210] nouveau 0000:01:00.0: registered panic notifier
Dec 3 07:19:02 localhost kernel: [ 4.963270] [drm] Initialized nouveau 1.1.1 20120801 for 0000:01:00.0 on minor 0
Dec 3 07:19:02 localhost kernel: [ 6.788799] Adaptec aacraid driver 1.2-0[30200]-ms
Dec 3 07:19:02 localhost kernel: [ 6.788881] pps_core: LinuxPPS API ver. 1 registered

Trying to add blacklist nouveau in both blacklist-mdv.conf and blacklist-compat.conf had no effect.


Version-Release number of selected component (if applicable):
Rosa Fresh R2

How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 Aleksandr Kazantcev 2013-12-05 12:09:56 MSK
You need XFdrake and setup driver.

What card you use? Please provide lspci output.
Comment 2 andrea_scopelliti 2013-12-05 15:18:59 MSK
Thanks.
Yes, I had already followed your instructions about reinstalling the nvidia driver through cli and XFdrake, and I did it after rebooting in recovery mode.
My card is a Quadro 6000 and the syslog that I attached was the same after the double installation of the nvidia driver.
Below you'll find the output of the lspci command:

[root@Desktop-1 andrea]# lspci
00:00.0 Host bridge: Intel Corporation Ivytown DMI2 (rev 04)
00:01.0 PCI bridge: Intel Corporation Ivytown PCI Express Root Port 1a (rev 04)
00:01.1 PCI bridge: Intel Corporation Ivytown PCI Express Root Port 1b (rev 04)
00:02.0 PCI bridge: Intel Corporation Ivytown PCI Express Root Port 2a (rev 04)
00:03.0 PCI bridge: Intel Corporation Ivytown PCI Express Root Port 3a (rev 04)
00:05.0 System peripheral: Intel Corporation Ivytown VTd/Memory Map/Misc (rev 04)
00:05.2 System peripheral: Intel Corporation Ivytown IIO RAS (rev 04)
00:05.4 PIC: Intel Corporation Ivytown IOAPIC (rev 04)
00:11.0 PCI bridge: Intel Corporation C600/X79 series chipset PCI Express Virtual Root Port (rev 06)
00:16.0 Communication controller: Intel Corporation C600/X79 series chipset MEI Controller #1 (rev 05)
00:19.0 Ethernet controller: Intel Corporation 82579V Gigabit Network Connection (rev 06)
00:1a.0 USB controller: Intel Corporation C600/X79 series chipset USB2 Enhanced Host Controller #2 (rev 06)
00:1b.0 Audio device: Intel Corporation C600/X79 series chipset High Definition Audio Controller (rev 06)
00:1c.0 PCI bridge: Intel Corporation C600/X79 series chipset PCI Express Root Port 1 (rev b6)
00:1c.1 PCI bridge: Intel Corporation C600/X79 series chipset PCI Express Root Port 2 (rev b6)
00:1c.2 PCI bridge: Intel Corporation C600/X79 series chipset PCI Express Root Port 3 (rev b6)
00:1c.3 PCI bridge: Intel Corporation C600/X79 series chipset PCI Express Root Port 4 (rev b6)
00:1c.4 PCI bridge: Intel Corporation C600/X79 series chipset PCI Express Root Port 5 (rev b6)
00:1c.5 PCI bridge: Intel Corporation C600/X79 series chipset PCI Express Root Port 6 (rev b6)
00:1c.7 PCI bridge: Intel Corporation C600/X79 series chipset PCI Express Root Port 8 (rev b6)
00:1d.0 USB controller: Intel Corporation C600/X79 series chipset USB2 Enhanced Host Controller #1 (rev 06)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev a6)
00:1f.0 ISA bridge: Intel Corporation C600/X79 series chipset LPC Controller (rev 06)
00:1f.2 SATA controller: Intel Corporation C600/X79 series chipset 6-Port SATA AHCI Controller (rev 06)
00:1f.3 SMBus: Intel Corporation C600/X79 series chipset SMBus Host Controller (rev 06)
01:00.0 VGA compatible controller: NVIDIA Corporation GF100GL [Quadro 6000] (rev a3)
01:00.1 Audio device: NVIDIA Corporation GF100 High Definition Audio Controller (rev a1)
02:00.0 RAID bus controller: Adaptec Series 7 6G SAS/PCIe 3 (rev 01)
04:00.0 SATA controller: Marvell Technology Group Ltd. 88SE9230 PCIe SATA 6Gb/s Controller (rev 10)
06:00.0 USB controller: ASMedia Technology Inc. ASM1042 SuperSpeed USB Host Controller
07:00.0 USB controller: ASMedia Technology Inc. ASM1042 SuperSpeed USB Host Controller
08:00.0 USB controller: ASMedia Technology Inc. ASM1042 SuperSpeed USB Host Controller
09:00.0 Network controller: Broadcom Corporation BCM4352 802.11ac Wireless Network Adapter (rev 03)
0a:00.0 SATA controller: ASMedia Technology Inc. ASM1062 Serial ATA Controller (rev 01)
0b:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 11)
0c:00.0 SATA controller: ASMedia Technology Inc. ASM1062 Serial ATA Controller (rev 01)
ff:08.0 System peripheral: Intel Corporation Ivytown QPI Link 0 (rev 04)
ff:09.0 System peripheral: Intel Corporation Ivytown QPI Link 1 (rev 04)
ff:0a.0 System peripheral: Intel Corporation Ivytown Power Control Unit 0 (rev 04)
ff:0a.1 System peripheral: Intel Corporation Ivytown Power Control Unit 1 (rev 04)
ff:0a.2 System peripheral: Intel Corporation Ivytown Power Control Unit 2 (rev 04)
ff:0a.3 System peripheral: Intel Corporation Ivytown Power Control Unit 3 (rev 04)
ff:0b.0 System peripheral: Intel Corporation Ivytown Semaphore and Scratchpad Configuration Registers (rev 04)
ff:0b.3 System peripheral: Intel Corporation Ivytown Semaphore and Scratchpad Configuration Registers (rev 04)
ff:0c.0 System peripheral: Intel Corporation Ivytown Unicast Registers (rev 04)
ff:0c.1 System peripheral: Intel Corporation Ivytown Unicast Registers (rev 04)
ff:0c.2 System peripheral: Intel Corporation Ivytown Unicast Registers (rev 04)
ff:0d.0 System peripheral: Intel Corporation Ivytown Unicast Registers (rev 04)
ff:0d.1 System peripheral: Intel Corporation Ivytown Unicast Registers (rev 04)
ff:0d.2 System peripheral: Intel Corporation Ivytown Unicast Registers (rev 04)
ff:0e.0 System peripheral: Intel Corporation Ivytown Home Agent 0 (rev 04)
ff:0e.1 Performance counters: Intel Corporation Ivytown Home Agent 0 (rev 04)
ff:0f.0 System peripheral: Intel Corporation Ivytown Integrated Memory Controller 0 Target Address/Thermal Registers (rev 04)
ff:0f.1 System peripheral: Intel Corporation Ivytown Integrated Memory Controller 0 RAS Registers (rev 04)
ff:0f.2 System peripheral: Intel Corporation Ivytown Integrated Memory Controller 0 Channel Target Address Decoder Registers (rev 04)
ff:0f.3 System peripheral: Intel Corporation Ivytown Integrated Memory Controller 0 Channel Target Address Decoder Registers (rev 04)
ff:0f.4 System peripheral: Intel Corporation Ivytown Integrated Memory Controller 0 Channel Target Address Decoder Registers (rev 04)
ff:0f.5 System peripheral: Intel Corporation Ivytown Integrated Memory Controller 0 Channel Target Address Decoder Registers (rev 04)
ff:10.0 System peripheral: Intel Corporation Ivytown Integrated Memory Controller 1 Channel 0-3 Thermal Control 0 (rev 04)
ff:10.1 System peripheral: Intel Corporation Ivytown Integrated Memory Controller 1 Channel 0-3 Thermal Control 1 (rev 04)
ff:10.2 System peripheral: Intel Corporation Ivytown Integrated Memory Controller 1 Channel 0-3 ERROR Registers 0 (rev 04)
ff:10.3 System peripheral: Intel Corporation Ivytown Integrated Memory Controller 1 Channel 0-3 ERROR Registers 1 (rev 04)
ff:10.4 System peripheral: Intel Corporation Ivytown Integrated Memory Controller 1 Channel 0-3 Thermal Control 2 (rev 04)
ff:10.5 System peripheral: Intel Corporation Ivytown Integrated Memory Controller 1 Channel 0-3 Thermal Control 3 (rev 04)
ff:10.6 System peripheral: Intel Corporation Ivytown Integrated Memory Controller 1 Channel 0-3 ERROR Registers 2 (rev 04)
ff:10.7 System peripheral: Intel Corporation Ivytown Integrated Memory Controller 1 Channel 0-3 ERROR Registers 3 (rev 04)
ff:13.0 System peripheral: Intel Corporation Ivytown R2PCIe (rev 04)
ff:13.1 Performance counters: Intel Corporation Ivytown PCI Express Ring Performance Monitoring (rev 04)
ff:13.4 System peripheral: Intel Corporation Ivytown QPI Ring Registers (rev 04)
ff:13.5 Performance counters: Intel Corporation Ivytown QPI Ring Performance Ring Monitoring (rev 04)
ff:16.0 System peripheral: Intel Corporation Ivytown System Address Decoder (rev 04)
ff:16.1 System peripheral: Intel Corporation Ivytown Broadcast Registers (rev 04)
ff:16.2 System peripheral: Intel Corporation Ivytown Broadcast Registers (rev 04)
[root@Desktop-1 andrea]# 

Thanks
Comment 3 Aleksandr Kazantcev 2013-12-05 15:58:33 MSK
Check you system for grub2.cfg 'nomodeset' string.

Also update you system for latest package version and then try setup and run Nvidia with proprietary blobs.

Then provide Xorg.0.log please.
Comment 4 andrea_scopelliti 2013-12-07 06:42:10 MSK
It looks like the nomodeset option added to the kernel did the trick. I just had to load the nvidia driver through the control center and reboot to have the proprietary drivers work.
I didn't try to do and undo the changes, but I consider the problem solved. Just note that the nomodeset option was already present in the safe boot menuentry, so, now is repeated twice at that entry.
A second consideration is that actually the resolution of the splash screen does not reflect the resolution of the monitor so the image is deformed, but that's not a big issue.
Last, I notice that the HDMI audio is not correctly detected by pulse, so I had to play with aplay and default.pa to set up the audio.

Playing with the card I had the opportunity to deepen the bug I opened about grub 2 malfunctions, so I'll update that voice too.

Thanks for your help.
Comment 5 Aleksandr Kazantcev 2013-12-07 09:34:21 MSK
Grub may use fb, not nvidia-fb. For nomodeset you need simple check option presents in /etc/default/grub config for one time (also you may setup needing resolution in Grub2 on this config), after that run update-grub2 and write correct grub2.cfg
Comment 6 Aleksandr Kazantcev 2013-12-07 09:35:02 MSK
For PA simple run 

 pavucontrol

and setup your card.
Comment 7 andrea_scopelliti 2013-12-07 17:25:11 MSK
(In reply to comment #6)
> For PA simple run 
> 
>  pavucontrol
> 
> and setup your card.

No pavucontrol did not work. I tried to select all the possible HDMI outputs with no success. It worked only after having selected the right combination of card and hardware output manually editing the default.pa file
Comment 8 andrea_scopelliti 2013-12-07 17:31:58 MSK
(In reply to comment #5)
> Grub may use fb, not nvidia-fb. For nomodeset you need simple check option
> presents in /etc/default/grub config for one time (also you may setup
> needing resolution in Grub2 on this config), after that run update-grub2 and
> write correct grub2.cfg

THanks, Isaw that the update-grub2 automatically detects the type of installation and adds the -o option to grub2-mkconfig
Comment 9 Denis Silakov 2014-03-03 21:27:04 MSK
Well, let's marked as 'resolved fixed' since the original problem was solved.