Bug 330 - Can not to configure authentication in Active Directory Windows 2003
: Can not to configure authentication in Active Directory Windows 2003
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 09:42 MSD by FirstLevel
Modified: 2012-06-29 12:20 MSD (History)
6 users (show)

See Also:
RPM Package: drakxtools-13.61-11.src.rpm
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments
Screenshots of wizard (447.76 KB, application/octet-stream)
2012-06-05 09:42 MSD, FirstLevel
Details
messages (8.57 KB, text/plain)
2012-06-05 09:42 MSD, FirstLevel
Details
contents of smb.conf and wbinfo (16.59 KB, text/plain)
2012-06-05 14:08 MSD, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-06-05 09:42:01 MSD
Created attachment 232 [details]
Screenshots of wizard

Description of problem:
I have attempted to configure authentication in Active Directory Windows 2003 by UserGuide, but can not to fo it.
Every time on the final step a have an error Cannot bind with AD.
Screenshots and contents of /var/log/messages in attachments.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2012-06-05 09:42:28 MSD
Created attachment 233 [details]
messages
Comment 2 Aleksandr Kazantcev 2012-06-05 11:25:34 MSD
See this part of log

Jun  5 10:46:53 localhost winbind[32220]: Starting Winbind services: [  OK  ]
Jun  5 10:46:53 localhost drakauth[32085]: running: net time set -S RUS-EKB-SUL.LOCAL
Jun  5 10:46:53 localhost winbindd[32235]: [2012/06/05 10:46:53.693320,  0] winbindd/winbindd_util.c:633(init_domain_list)
Jun  5 10:46:53 localhost winbindd[32235]:   Could not fetch our SID - did we join?
Jun  5 10:46:53 localhost winbindd[32235]: [2012/06/05 10:46:53.701179,  0] winbindd/winbindd.c:1243(main)
Jun  5 10:46:53 localhost winbindd[32235]:   unable to initialize domain list
Jun  5 10:46:59 localhost drakauth[32085]: running: net <hidden arguments>

Is correct information was put in master?
Comment 3 FirstLevel 2012-06-05 11:28:33 MSD
(In reply to comment #2)
> See this part of log
> 
> Jun  5 10:46:53 localhost winbind[32220]: Starting Winbind services: [  OK  ]
> Jun  5 10:46:53 localhost drakauth[32085]: running: net time set -S
> RUS-EKB-SUL.LOCAL
> Jun  5 10:46:53 localhost winbindd[32235]: [2012/06/05 10:46:53.693320,  0]
> winbindd/winbindd_util.c:633(init_domain_list)
> Jun  5 10:46:53 localhost winbindd[32235]:   Could not fetch our SID - did
> we join?
> Jun  5 10:46:53 localhost winbindd[32235]: [2012/06/05 10:46:53.701179,  0]
> winbindd/winbindd.c:1243(main)
> Jun  5 10:46:53 localhost winbindd[32235]:   unable to initialize domain list
> Jun  5 10:46:59 localhost drakauth[32085]: running: net <hidden arguments>
> 
> Is correct information was put in master?

User have answered that he wrote corect information.
Comment 4 FirstLevel 2012-06-05 14:08:11 MSD
Created attachment 240 [details]
contents of smb.conf and wbinfo
Comment 5 FirstLevel 2012-06-05 14:08:58 MSD
I have attached  the output cat /etc/samba/smb.conf and wbinfo -u.
Comment 6 FirstLevel 2012-06-07 07:45:53 MSD
Firewall on DC is disabled. Domain in mixed mode, not native.
Comment 7 Eugene Budanov 2012-06-13 17:42:19 MSD
Manual solution of problem: http://forum.rosalab.ru/viewtopic.php?f=5&t=944&p=5349#p5508.
Comment 8 Vladimir Testov 2012-06-14 18:20:36 MSD
Fixed. Please test new version.

Fixed version can be found in my personal repository.

x86_64:  http://abf.rosalinux.ru/downloads/icedphoenix_personal/repository/rosa2012lts/x86_64/main/release/
i586:    http://abf.rosalinux.ru/downloads/icedphoenix_personal/repository/rosa2012lts/i586/main/release/

You can do it by temporarily adding media:
urpmi.addmedia icedphoenix http://abf.rosalinux.ru/downloads/icedphoenix_personal/repository/rosa2012lts/?????/main/release/   (your arch in place of ???)
urpmi drakxtools
urpmi.removemedia icedphoenix

Do not use urpmi --auto-update with my personal repository. Disconnect it first. There can be some experimental versions of critical components.
Comment 9 Vladimir Testov 2012-06-14 18:39:29 MSD
Advisory: fixed procedure of connecting to Active Directory running under Windows Server 2003.

https://abf.rosalinux.ru/build_lists/618671
https://abf.rosalinux.ru/build_lists/618670

How to verify: try to connect Active Directory running under Windows Server 2003.
Comment 10 Vladimir Potapov 2012-06-21 15:56:36 MSD
http://abf.rosalinux.ru/downloads/rosa2012lts/container/drakxtools-125418/RPMS/

404 Not Found
nginx/1.0.5
Comment 11 Vladimir Testov 2012-06-22 14:11:41 MSD
Advisory: fixed procedure of connecting to Active Directory running under Windows Server 2003.

https://abf.rosalinux.ru/build_lists/619455
https://abf.rosalinux.ru/build_lists/619456

(don't open container if you're not QA !!!)

How to verify: try to connect Active Directory running under Windows Server 2003.
Comment 12 Alexander Burmashev 2012-06-25 14:00:14 MSD
This package was published without QA check due to some bug.