Bug 328 - Incorrect urpmi return code with --auto option
: Incorrect urpmi return code with --auto option
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: Alexander Burmashev
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 13:01 MSD by Anton Kirilenko
Modified: 2013-04-18 16:05 MSD (History)
4 users (show)

See Also:
RPM Package: urpmi-6.69-3-rosa.lts2012.0.noarch.rpm
ISO-related:
Bad POT generating:
Upstream:


Attachments
iw's OK in cooker (65.32 KB, image/png)
2012-07-16 13:20 MSD, Pavel Shved
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Anton Kirilenko 2012-06-04 13:01:46 MSD
Description of problem:
In some cases urpmi with '--auto' return code is incorrect. For example:


Version-Release number of selected component (if applicable):
urpmi 6.69

How reproducible:


Steps to Reproduce:
1. Download a package with build requirements which can not be resolved.
2. $ sudo urpmi --buildrequires --root ~/chroot ./tigervnc-1.1.0-5.fc17.src.rpm  
A requested package cannot be installed:
tigervnc-1.1.0-5.fc17.src (due to unsatisfied gettext-autopoint)
Continue installation anyway? (Y/n) n

$ echo $?
17


$ sudo urpmi --buildrequires --root ~/chroot ./tigervnc-1.1.0-5.fc17.src.rpm  --auto
A requested package cannot be installed:
tigervnc-1.1.0-5.fc17.src (due to unsatisfied gettext-autopoint)

$ echo $?
0
Comment 1 Alexander Burmashev 2012-06-04 14:47:45 MSD
I see that you are installing a tigervnc from Fedora.
Are you sure that package requires are correct for ROSA and this is not the root of the problem ?
Comment 2 Pavel Shved 2012-06-04 19:25:15 MSD
(In reply to comment #1)
> I see that you are installing a tigervnc from Fedora.
> Are you sure that package requires are correct for ROSA and this is not the
> root of the problem ?

Well, this doesn't really matter, because the same problem could have occurred with a ROSA package:  when a "require" is missing from repos, the `urpmi --auto` should fail with nonzero code.

Could you reproduce the same problem with cooker's urpmi?
Comment 3 Anton Kirilenko 2012-06-04 20:49:45 MSD
> I see that you are installing a tigervnc from Fedora.
> Are you sure that package requires are correct for ROSA and this is not the root > of the problem ?

Yes, I'm shure. The problem occured while building the package in ROSA. I got the package from Fedora because there are lots of broken dependencies for those packages in our repositories :)
Comment 4 Alexander Burmashev 2012-06-04 21:00:02 MSD
Sorry, actually i interpreted the problem in a wrong way, clearly it is not important in this case if package is from ROSA repo or not.
Comment 5 Pavel Shved 2012-07-16 13:20:46 MSD
Created attachment 390 [details]
iw's OK in cooker

I recall I fixed this several months ago in cooker (https://qa.mandriva.com/show_bug.cgi?id=63940).    Just verified it on a cooker machine (see screenshot).
Comment 6 Pavel Shved 2012-07-16 13:22:28 MSD
So the solution should be to port URPMI from cooker that contains my patches.
Comment 7 Denis Silakov 2013-01-14 12:20:02 MSK
Advisory:

Fixed urpmi to exit with non-zero code if some packages cannot be installed.

Build lists:
https://abf.rosalinux.ru/build_lists/897432
https://abf.rosalinux.ru/build_lists/897431
Comment 8 Vladimir Potapov 2013-01-15 15:26:53 MSK
Hm. How to test this update?
Are there in the ROSA repositories packages that are not installed?
Comment 9 Denis Silakov 2013-01-15 15:30:34 MSK
You can try any package from other distribution. e.g. this is the one mentioned in this bug report:

http://koji.russianfedora.ru/packages/tigervnc/1.1.0/6.3.fc17.R/src/tigervnc-1.1.0-6.3.fc17.R.src.rpm

(note that you need 'src.rpm' to check behavior of '--buildrequires' option)
Comment 10 Vladimir Potapov 2013-01-19 09:24:17 MSK
After this update, update GUI hang on window "Initialization".
This effect present both x64 and i586 systems.
Comment 11 Denis Silakov 2013-01-21 11:04:22 MSK
Strange, can't reproduce atm...
Comment 12 Vladimir Potapov 2013-01-21 14:21:47 MSK
Error present only in Marathon. In rpmdrake too  - download indicator does not showed, (showed only initialization window) but install process finish correctly.
Comment 13 Denis Silakov 2013-04-18 16:05:46 MSD
With release of Marathon RP2 (aka "Enterprise Desktop X1"), we've backported urpmi-6.71 from Desktop Fresh. This backport solves the issue discussed in this bug - urpmi now return non-zero codes with '--auto' option if something went wrong.