Bug 325 - Bug in Geany install
: Bug in Geany install
Status: RESOLVED INVALID
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: Marathon
: All Linux
: Low minor
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 10:22 MSD by Vladimir Potapov
Modified: 2012-12-27 12:59 MSK (History)
4 users (show)

See Also:
RPM Package: geany
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Potapov 2012-06-04 10:22:05 MSD
urpmi geany


   $MIRRORLIST: media/contrib/updates/geany-0.20-5-rosa.lts2012.0.x86_64.rpm                                                        
устанавливается lib64pango1.0-devel-1.28.4-5-rosa.lts2012.0.x86_64.rpm geany-plugins-0.20-1-rosa.lts2012.0.x86_64.rpm lib64xinerama-devel-1.1.1-5-rosa.lts2012.0.x86_64.rpm pango-doc-1.28.4-5-rosa.lts2012.0.x86_64.rpm lib64gtk+2.0-devel-2.24.5-6-rosa.lts2012.0.x86_64.rpm geany-0.20-5-rosa.lts2012.0.x86_64.rpm lxterminal-0.1.11-2-rosa.lts2012.0.x86_64.rpm из /var/cache/urpmi/rpms
warning: LOOP:
warning: removing geany-0.20-5.x86_64 "Requires(hint): geany-plugins" from tsort relations.
warning: removing geany-plugins-0.20-1.x86_64 "Requires: /usr/lib64/geany" from tsort relations.
Comment 1 Denis Koryavov 2012-12-26 23:00:02 MSK
Hmm. I don't see any problems here. AFAIU these warnings can be and this is not a problem. Geany works after installation?
Comment 2 Denis Silakov 2012-12-27 12:59:22 MSK
Yes, such warnings don't designate a problem. This is just a hint for maintainers that there is a loop in the dependency graph which *probably* should be eliminated.

We have many cases of such LOOP warnings. We fix them from time to time but this is not a high-priority task (since this actually doesn't break anything).

So please don't report bugs about dependency LOOPs unless they really break something. 

Finally, in future we are planning to add one more analyzer to fba.rosalinux.ru to automatically track dependency loops in our repositories.