Bug 324 - chromium not set as default browser
: chromium not set as default browser
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-03 03:15 MSD by Vladimir Potapov
Modified: 2013-10-08 10:31 MSD (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Potapov 2012-06-03 03:15:57 MSD
Description of problem:
Chromium button "Set as default browser" does not work

How reproducible:
Start chromium.
Click "set as default browser"

How to fix:
update package xdg-utils to version 1.1
see http://code.google.com/p/chromium/issues/detail?id=33842
Comment 1 Dmitry Mikhirev 2012-06-29 16:06:30 MSD
Chromium package contains bundled xdg-utils, so changing xdg-utils package will not take effect.

BTW xdg-utils 1.1.0 is not released yet.
Comment 2 Vladimir Potapov 2012-07-02 08:30:49 MSD
Ubuntu 12.04 LTS  - 1.1.0~rc1 http://packages.ubuntu.com/precise/xdg-utils
Mageya 2 1.1.0-0.rc  http://pkgs.org/mageia-2/mageia-core-release-i586/xdg-utils-1.1.0-0.rc1.2.mga2.i586.rpm.html
Fedora 16  1.1.0~rc1
Comment 3 Dmitry Mikhirev 2012-07-02 12:01:43 MSD
(In reply to comment #2)
> Ubuntu 12.04 LTS  - 1.1.0~rc1 http://packages.ubuntu.com/precise/xdg-utils
> Mageya 2 1.1.0-0.rc 
> http://pkgs.org/mageia-2/mageia-core-release-i586/xdg-utils-1.1.0-0.rc1.2.
> mga2.i586.rpm.html
> Fedora 16  1.1.0~rc1

So what? 1) It is not stable release, 2) updating xdg-utils package wouldn't help (see above; yes, I've tried this).
Comment 4 Vladimir Potapov 2012-07-02 15:26:00 MSD
1) Maybe, take patch from 1.1 xdg-utils?   
2) updating xdg-utils package help me. (take from fedora)
Comment 5 Dmitry Mikhirev 2012-07-02 15:35:06 MSD
(In reply to comment #4)

> 2) updating xdg-utils package help me. (take from fedora)

What chromium version are you using?
Comment 6 Vladimir Potapov 2012-07-02 16:21:10 MSD
chromium-browser-17.0.963.65-1-rosa.lts2012.0.x86_64

after press key in chromium, kde default browser has been changed
Comment 7 Denis Silakov 2013-10-01 16:57:32 MSD
Updating xdg-utils to 1.1.0 seems to solve the issue for me.

I suggest to update the package.

Advisory:

Updated xdg-utils to latest snapshot of 1.1.0 version to allow modern applications such as Chromium to use them correctly.

Build lists:
https://abf.rosalinux.ru/build_lists/1337750
https://abf.rosalinux.ru/build_lists/1337749
Comment 8 Vladimir Potapov 2013-10-02 17:38:03 MSD
xdg-utils-1.1.0-0.20130218.1-rosa.lts2012.0
********************** Advisory ************************
Updated xdg-utils to latest snapshot of 1.1.0 version to allow modern applications such as Chromium to use them correctly.
********************************************************
QA Verified
Comment 9 Alexander Burmashev 2013-10-08 10:31:28 MSD
*** Bug 1444 has been marked as a duplicate of this bug. ***