Bug 3164 - Gnome control center window is too large
: Gnome control center window is too large
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Highest blocker
: ---
Assigned To: UXteam
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-15 14:12 MSK by Arkady L. Shane
Modified: 2013-11-22 21:39 MSK (History)
4 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
g-c-c-window.png (141.93 KB, image/png)
2013-11-15 14:14 MSK, Arkady L. Shane
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Arkady L. Shane 2013-11-15 14:12:43 MSK
After adding new items to Gnome Control Center Window, item "Users" is invisible on low resolution monitors (many laptops, or virtual guests).

So, I think, we should make g-c-c window scrollable or increase width.
Comment 1 Arkady L. Shane 2013-11-15 14:14:09 MSK
Created attachment 2255 [details]
g-c-c-window.png

"Users" item somewhere in the bottom.
Comment 2 Arkady L. Shane 2013-11-15 16:24:05 MSK
Oh. I think it will be better if items "Настройка шрифтов" and "Дополнительные параметры" will be moved to "Личное" section.

I have moved Fontconfig to Personal, but tweak tool must be hardcoded.
Comment 3 Postnikov Dmitry 2013-11-15 16:49:32 MSK
Dublicate bug 3124.
Comment 4 Postnikov Dmitry 2013-11-15 16:50:12 MSK
(In reply to comment #3)
> Dublicate bug 3124.

Pardon. Dublicate bug 3142
Comment 5 Arkady L. Shane 2013-11-15 18:14:42 MSK
*** Bug 3142 has been marked as a duplicate of this bug. ***
Comment 6 Stanislav Fomin 2013-11-18 14:18:44 MSK
I considered proposed solutions «move the item to wrong category to increase icons density» as conceptually wrong.

* The GCC window must be usable in 800x600 (the resolutions below can be considered as deprecated and unsupported)
* The GCC window have 5 items ×150px in a row, so 800px>5*150 — no horizontal scrolling need
* But vertical scrolling need to be implemented.
** Ideally — the GCC window has vertical scrolling if vertical resolution less than 800px
Comment 7 Julia Pikareva 2013-11-19 12:03:59 MSK
(In reply to comment #6)
> * The GCC window have 5 items ×150px in a row, so 800px>5*150 — no
> horizontal scrolling need

In fact, even though the size of one element and GCC 150, but there is also the indentation so generally the window size currently exhibited width
at 843.
Comment 8 Stanislav Fomin 2013-11-20 15:07:31 MSK
(In reply to comment #7)
> (In reply to comment #6)
> > * The GCC window have 5 items ×150px in a row, so 800px>5*150 — no
> > horizontal scrolling need
> 
> In fact, even though the size of one element and GCC 150, but there is also
> the indentation so generally the window size currently exhibited width
> at 843.

Is it possible to detect resolution on GSS start and set 140px per icon (5×140 + 93px < 800) when hres <= 800px?
Comment 9 Arkady L. Shane 2013-11-22 21:39:32 MSK
Fixed and packed now.